Udostępnij za pośrednictwem


Usługa Windows Update zawiesza się i nowe aktualizacje są odinstalowywane po ponownym uruchomieniu

Ten artykuł zawiera obejście problemu polegającego na tym, że usługa Windows Update zawiesza się, a nowo zainstalowane aktualizacje są odinstalowywane po ponownym uruchomieniu systemu.

Oryginalny numer KB: 3064434

Symptomy

Rozważmy następujący scenariusz:

  • Masz komputer z systemem Windows.
  • Aktualizacje są instalowane z usługi Windows Update.
  • Po wyświetleniu monitu o wykonanie tego monitu uruchom ponownie system Windows.

W tym scenariuszu podczas procesu ponownego uruchamiania zostanie wyświetlony następujący komunikat:

Praca nad aktualizacjami
Ukończono 13%
Nie wyłączaj komputera

Jest to oczekiwany komunikat. Jednak system wydaje się przestać odpowiadać (zawiesza się) przez około 15 minut. Po tym czasie system zostanie uruchomiony ponownie. Jednak zainstalowane aktualizacje są teraz odinstalowywane.

Ponadto wpis podobny do następującego może zostać zarejestrowany w pliku CBS.log w folderze %SystemRoot%\Logs\CBS:

Shtd: Przekroczono limit czasu oczekiwania na zakończenie przetwarzania zamknięcia — brak postępu wykrytego w ciągu ostatnich 900000 milisekund

Przyczyna

Ten problem występuje, ponieważ usługa Zaufanego Instalatora nie zakończyła procesu instalacji w domyślnym przedziale czasu 15 minut.

Rozwiązanie

Aby obejść ten problem, ustaw wartość limitu czasu na większą wartość w rejestrze, a następnie ponownie zastosuj poprawkę. W tym celu wykonaj następujące kroki:

  1. Uruchom Edytor rejestru.

  2. Odszukaj następujący podklucz rejestru:
    HKLM\System\CurrentControlSet\Services\TrustedInstaller

  3. Kliknij prawym przyciskiem myszy klucz TrustedInstaller , a następnie kliknij pozycję Uprawnienia.

  4. Udziel użytkownikowi pełnej kontroli prawa do grupy Administratorzy.

  5. Zmień wartość BlockTimeIncrement na 2a30 (Szesnastkowa).

    Uwaga 16.

    Ta zmiana ustawia wartość limitu czasu na trzy godziny. Powinno to być wystarczające w przypadku większości sytuacji. Jednak może być konieczne wypróbowanie większej wartości w środowisku.

  6. Uruchom ponownie serwer, a następnie ponownie zastosuj poprawkę.

Stan

Firma Microsoft potwierdziła, że jest to usterka występująca w produktach firmy Microsoft wymienionych w części "Ma zastosowanie do:".

Zbieranie danych

Jeśli potrzebujesz pomocy ze strony pomocy technicznej firmy Microsoft, zalecamy zebranie informacji, wykonując kroki wymienione w artykule Zbieranie informacji przy użyciu zestawu narzędzi TSS w przypadku problemów związanych z wdrożeniem.