Udostępnij za pośrednictwem


Błąd 1058 jest wyświetlany, gdy usługa nagle zatrzymuje się

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że błąd 1058 występuje, gdy usługa nagle się zatrzymuje.

Dotyczy: Windows 10 — wszystkie wersje, Windows 7, Windows Vista, Windows XP
Oryginalny numer KB: 241584

Symptomy

Gdy usługa nagle zostanie zatrzymana, może zostać wyświetlony następujący komunikat o błędzie:

Błąd 1058: Nie można uruchomić usługi, ponieważ jest ona wyłączona lub nie ma skojarzonych z nią urządzeń.

Ten komunikat o błędzie może być również wyświetlany podczas próby uruchomienia usługi.

Przyczyna

Ten problem może wystąpić, jeśli usługa jest wyłączona lub jeśli usługa jest wyłączona dla aktualnie używanego profilu sprzętowego.

Rozwiązanie dla systemów Windows 10, Windows 7 i Windows Vista

  1. Kliknij przycisk Start, wyszukaj pozycję Usługi, a następnie kliknij pozycję Usługi w wynikach wyszukiwania.

  2. Przewiń do momentu znalezienia usługi, a następnie kliknij dwukrotnie usługę.

    Zrzut ekranu przedstawiający opcję Typ uruchamiania na karcie Ogólne okna dialogowego Właściwości routingu i dostępu zdalnego (komputer lokalny).

  3. Jeśli usługa jest wyłączona, kliknij listę Typ uruchamiania, a następnie wybierz opcję inną niż Wyłączone.

  4. Kliknij Zastosuj.

  5. Kliknij przycisk Start , aby spróbować uruchomić usługę.

  6. Kliknij przycisk OK.

Rozwiązanie dla systemu Windows XP

  1. Kliknij przycisk Start, wskaż pozycję Wszystkie programy, wskaż pozycję Narzędzia administracyjne, a następnie kliknij pozycję Usługi.

  2. Przewiń do momentu znalezienia usługi, która jest zatrzymana lub wyłączona.

  3. Kliknij dwukrotnie usługę, która nie została uruchomiona.

  4. Kliknij przycisk Logowanie kartę.

    Zrzut ekranu przedstawiający kartę Logowanie w oknie dialogowym Właściwości lokalizatora zdalnego wywołania procedury (RPC) (Komputer lokalny).

  5. Sprawdź, czy usługa nie jest wyłączona dla używanego profilu sprzętu. Jeśli usługa jest wyłączona dla profilu sprzętu, kliknij przycisk Włącz.

  6. Kliknij kartę Ogólne , a następnie w polu Typ uruchomienia sprawdź, czy usługa nie jest wyłączona. Jeśli usługa jest wyłączona, kliknij przycisk Automatycznie , aby rozpocząć go po uruchomieniu komputera.

    Zrzut ekranu przedstawiający pole typu uruchamiania na karcie Ogólne.

  7. Kliknij przycisk OK.

Więcej informacji

Jeśli usługa ma być uruchamiana automatycznie, ale usługa jest wyłączona dla używanego profilu sprzętu, usługa nie jest uruchamiana i nie jest generowany żaden komunikat o błędzie.