Udostępnij za pośrednictwem


Podczas próby dodania drukarki IPP za pośrednictwem protokołu HTTPS występuje błąd

Ten artykuł zawiera rozwiązanie błędu występującego podczas próby dodania drukarki IPP za pośrednictwem protokołu HTTPS.

Dotyczy: Windows 7 z dodatkiem Service Pack 1
Oryginalny numer KB: 2021626

Symptomy

Podczas próby dodania drukarki IPP do stacji roboczej z systemem Windows Vista lub Windows 7 za pośrednictwem protokołu HTTPS kolejka może zakończyć się niepowodzeniem z powodu następującego błędu:

Dodawanie drukarki
Nawiązywanie połączenia z drukarką
System Windows nie może nawiązać połączenia z drukarką. Sprawdź nazwę drukarki i spróbuj ponownie. Jeśli jest to drukarka sieciowa, upewnij się, że drukarka jest włączona i czy adres drukarki jest poprawny.

Przyczyna

Ten problem występuje, ponieważ system Windows nie ufa lub nie może zweryfikować certyfikatu SSL używanego przez serwer wydruku lub serwer wydruku korzysta z certyfikatu z podpisem własnym.

Rozwiązanie

Można to rozwiązać za pomocą jednego z następujących:

  • Skonfigurowanie serwera wydruku w celu używania prawidłowego certyfikatu SSL z zewnętrznego urzędu certyfikacji zaufanego przez stację roboczą.
  • Jeśli zarówno serwer wydruku, jak i stacja robocza znajdują się w tej samej domenie, skonfiguruj serwer wydruku tak, aby używał prawidłowego certyfikatu SSL z urzędu certyfikacji przedsiębiorstwa.
  • Jeśli serwer wydruku korzysta z certyfikatu z podpisem własnym, zainstaluj certyfikat z podpisem własnym na stacji roboczej.

Jak zainstalować certyfikat z podpisem własnym serwera IPP na kliencie systemu Windows

Jeśli serwer wydruku korzysta z certyfikatów z podpisem własnym, poniższe kroki mogą służyć do instalowania certyfikatu z podpisem własnym na klientach, aby mogli korzystać z drukarki.

Uwaga 16.

Powinno to być wykonywane tylko dla certyfikatów SSL z zaufanych serwerów.

  1. Zaloguj się do klienta jako administrator
  2. Znajdź program Internet Explorer w menu Start, kliknij go prawym przyciskiem myszy i kliknij polecenie Uruchom jako administrator.
  3. W programie Internet Explorer przejdź do serwera wydruku przy użyciu protokołu HTTPS (na przykład https://PrintServerName/)
  4. Na pasku adresu wyrazy "Błąd certyfikatu" powinny pojawić się po prawej stronie obok ikony Czerwonej tarczy — kliknij błąd.
  5. Kliknij pozycję Wyświetl certyfikaty.
  6. W oknie certyfikatu kliknij pozycję Zainstaluj certyfikat....
  7. Wybierz pozycję Umieść wszystkie certyfikaty w następującym magazynie.
  8. Kliknij przycisk Przeglądaj....
  9. Wybierz pozycję Zaufane główne urzędy certyfikacji i kliknij przycisk OK.
  10. Kliknij przycisk Dalej, a następnie kliknij przycisk Zakończ.
  11. Zostanie wyświetlone ostrzeżenie o zabezpieczeniach informujące o dodaniu certyfikatu ze źródła, którego nie można zweryfikować. Kliknij przycisk Tak , aby ufać temu certyfikatowi SSL.
  12. Zamknij program Internet Explorer.
  13. Drukarkę można teraz zainstalować.

Zbieranie danych

Jeśli potrzebujesz pomocy technicznej firmy Microsoft, zalecamy zebranie informacji, wykonując kroki opisane w temacie Zbieranie informacji przy użyciu usługi TSS w przypadku problemów z środowiskiem użytkownika.