Udostępnij za pośrednictwem


Użytkownicy nie mogą pobrać klucza odzyskiwania funkcji BitLocker przy użyciu portalu samoobsługowego MBAM 2.0

Ten artykuł zawiera rozwiązanie błędu występującego podczas próby otwarcia strony internetowej portalu samoobsługowego MBAM 2.0 w celu pobrania klucza odzyskiwania funkcji BitLocker.

Oryginalny numer KB: 2870849

Symptomy

Jeśli użytkownik próbuje otworzyć stronę internetową portalu samoobsługowego MBAM 2.0 w celu pobrania klucza odzyskiwania funkcji BitLocker, otwarcie strony internetowej może zakończyć się niepowodzeniem. Ponadto wyświetlany zostanie następujący komunikat o błędzie:

Wystąpił błąd podczas kontaktowania się z bazą danych MBAM. Spróbuj ponownie później.

Przyczyna

Ten problem może wystąpić z dwóch możliwych powodów:

  1. Zapora systemu Windows blokuje ruch z komputera do programu SQL Server.

    W dziennikach aplikacji, w których zainstalowano funkcję dostawcy usług udostępnionych, zostanie również wyświetlony poniższy komunikat o błędzie.

    Komunikat o wyjątku: wystąpił błąd związany z siecią lub wystąpieniem podczas nawiązywania połączenia z programem SQL Server. Serwer nie został znaleziony lub był niedostępny. Sprawdź, czy nazwa wystąpienia jest prawidłowa oraz czy program SQL Server skonfigurowano tak, aby zezwalał na połączenia zdalne. (dostawca: dostawca nazwanych potoków, błąd: 40 — nie można otworzyć połączenia z programem SQL Server)

  2. Plik web.config usługi obsługi użytkownika nie zawiera parametry połączenia informacji.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące czynności:

W przypadku problemu z zaporą systemu Windows:

Otwórz porty zapory dla programu SQL Server. Domyślnie program SQL używa portu 1433, jeśli skonfigurowano program SQL z wystąpieniem domyślnym.

Konfigurowanie zapory systemu Windows w celu zezwolenia na dostęp do programu SQL Server

W przypadku problemu z plikiem web.config usługi obsługi użytkownika wykonaj następujące kroki:

  1. Nawiąż połączenie z serwerem, na którym jest zainstalowana funkcja portalu samoobsługowego MBAM 2.0.

  2. Otwórz Eksploratora Windows i przejdź do katalogu c:\inetpub\MicrosoftBitLockerManagementSolution\UserSupportService.

  3. Utwórz kopię pliku web.config.

  4. Edytuj plik web.config i upewnij się, że informacje o parametry połączenia są poprawne, jak pokazano poniżej.

  5. <W bloku connectionStrings>:

    <add name="ComplianceStatusConnectionString" providerName="System.Data.SqlClient" connectionString=""/>
    

    powinny mieć następującą wartość:

    <add name="ComplianceStatusConnectionString" providerName="System.Data.SqlClient" connectionString=" Data Source=[SQL server name];Initial Catalog=&quot;MBAM Compliance Status&quot;;Integrated Security=SSPI;"/>
    

    Uwaga 16.

    • Zastąp ciąg [nazwa serwera SQL] nazwą programu SQL Server.
    • Zastąp stan zgodności MBAM nazwą bazy danych stanu zgodności MBAM.

    Jeśli na przykład nazwa programu SQL Server to MBAMSQL, a nazwa bazy danych MBAM Compliance DB jest MBAM_Comp_DB, zapytanie powinno mieć następującą wartość:

    <add name="ComplianceStatusConnectionString" providerName="System.Data.SqlClient" connectionString="*Data Source=[MBAMSQL];Initial Catalog=&quot;MBAM_ Comp_DB &quot;;Integrated Security=SSPI;*"/>
    
  6. Zapisz plik web.config.

  7. Uruchom ponownie usługi IIS na serwerze.

  8. Teraz użytkownik powinien pomyślnie pobrać klucz odzyskiwania funkcji BitLocker ze strony internetowej programu MBAM SSP.

Informacje

Jak odzyskać dostęp do komputera za pomocą portalu samoobsługowego