Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł pomaga rozwiązać problem polegający na tym, że usługa dostępu do urządzeń interfejsu człowieka lub usługa wejściowa HID nie może uruchomić się w systemie Windows Embedded dla punktu usługi.
Oryginalna wersja produktu: Usługa dostępu do urządzeń interfejsu człowieka, usługa HID Input Service
Oryginalny numer KB: 2009753
Symptomy
Usługa dostępu do urządzeń interfejsu człowieka lub usługa wejściowa HID nie może uruchomić się w systemie Windows Embedded dla punktu usługi. Błąd SCM ID 7023 jest widoczny w dzienniku zdarzeń.
Ta brakująca usługa może być główną przyczyną niepowodzenia wyliczania urządzeń Bluetooth w systemie Windows Embedded dla punktu usługi. Może to również spowodować awarię typowych urządzeń POS HID, takich jak skanery, czytniki paska magnetycznego i inne urządzenia peryferyjne, które polegają na usłudze HID Input Service w celu nawiązania połączenia z systemem Windows Embedded for Point of Service.
Przyczyna
Jeśli nie ma urządzenia HID dołączonego podczas instalacji systemu Windows Embedded for Point of Service, plik HIDSERV.DLL może nie zostać zainstalowany w systemie, uniemożliwiając uruchomienie usługi HID. Jeśli urządzenia HID są później dodawane do systemu Windows Embedded for Point of Service lub inne funkcje zależne od usługi HID są wymagane, awaria usługi HID uniemożliwia ich działanie.
Rozwiązanie
Jeśli usługa HID Input Service lub podstawowe zależności Bluetooth nie są wymaganiami systemu Windows Embedded dla punktu usługi, usługa może zostać wyłączona, aby wyczyścić raportowanie błędów w dzienniku zdarzeń.
Jeśli wymagana jest usługa HID Input Service, zainstaluj brakujący plik, wykonując poniższe kroki, aby uruchomić usługę.
- Przejdź do folderu
%systemroot%\i386
. - Kliknij dwukrotnie plik sp2.cab . Zostaną wyświetlone skompresowane pliki w pliku .cab .
- Skopiuj plik hidserv.dll do
%systemroot%\system32
folderu . - Uruchom ponownie usługę HID Input Service lub uruchom ponownie komputer.