Udostępnij za pośrednictwem


Nie można nawiązać połączenia z Internetem i nie można dołączyć ani zalogować się do domeny, jeśli na kontrolerze domeny jest zainstalowany system Windows Server 2003 z dodatkiem SP1

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że klienci nie mogą dołączać ani logować się do domeny.

Dotyczy: Windows Server 2003
Oryginalny numer KB: 912023

Symptomy

Rozważmy następujący scenariusz. Komputer kliencki z systemem Microsoft Windows XP jest przyłączony do domeny systemu Microsoft Windows Server 2003. Ponadto system Windows Server 2003 z dodatkiem Service Pack 1 (SP1) jest instalowany na kontrolerze domeny uwierzytelniania. W tym scenariuszu występują następujące objawy:

  • Nie można nawiązać połączenia z Internetem.
  • Nie można dołączyć ani zalogować się do domeny. W związku z tym kontroler domeny jest w trybie bloku protokołu IPsec.

Po uruchomieniu składnika usług IPSEC na kontrolerze domeny może zostać wyświetlony komunikat o błędzie podobny do następującego:

W systemie nie można odnaleźć określonego pliku.

Ponadto w dzienniku systemu serwera mogą być rejestrowane następujące zdarzenia:

Typ zdarzenia: Błąd
Źródło zdarzenia: IPSEC
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 4292
Data: <Data/godzina>
Godzina: <Data/godzina>
Użytkownik: Nie dotyczy
Komputer: <ComputerName>
Opis rozwiązania:
Sterownik IPSec został wprowadzony w tryb bloku. Protokół IPSec odrzuci cały przychodzący i wychodzący ruch sieciowy TCP/IP, który nie jest dozwolony przez wykluczenia zasad protokołu IPSec w czasie rozruchu.

Typ zdarzenia: Błąd
Źródło zdarzeń: Service Control Manager
Kategoria zdarzenia: Brak
Identyfikator zdarzenia: 7023
Data: <Data/godzina>
Godzina: <Data/godzina>
Użytkownik: Nie dotyczy
Komputer: <ComputerName>
Opis rozwiązania:
Usługa usług IPSEC została zakończona z następującym błędem: System nie może odnaleźć określonego pliku

Przyczyna

Ten problem może wystąpić, jeśli klucz rejestru IPSec\Policy\Local zostanie usunięty lub gdy w magazynie zasad znajduje się uszkodzony plik. Plik może ulec uszkodzeniu, jeśli wystąpi przerwa w zapisywaniu zasad na dysku.

Rozwiązanie

Ważne

W tej sekcji, metodzie lub w tym zadaniu podano informacje dotyczące modyfikowania rejestru. Niepoprawne zmodyfikowanie rejestru może jednak być przyczyną poważnych problemów. Dlatego należy uważnie wykonać poniższe kroki. Aby zapewnić dodatkową ochronę, utwórz kopię zapasową rejestru przed przystąpieniem do jego modyfikacji. Dzięki temu będzie można przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji na temat sposobu tworzenia kopii zapasowych, przywracania i modyfikowania rejestru, zobacz artykuł Tworzenie kopii zapasowych i przywracanie rejestru systemu Microsoft Windows.

Aby rozwiązać ten problem, wykonaj poniższe czynności:

  1. Usuń podklucz rejestru zasad lokalnych. W tym celu wykonaj następujące kroki:

    1. Kliknij przycisk Start, kliknij przycisk Uruchom, wpisz regedit w polu Otwórz, a następnie kliknij przycisk OK.

    2. W Edytorze rejestru znajdź, a następnie kliknij następujący podklucz:

      HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\IPSec\Policy\Local

    3. W menu Edycja kliknij pozycję Usuń.

    4. Kliknij przycisk Tak , aby potwierdzić, że chcesz usunąć podklucz.

    5. Zamknij Edytor rejestru.

  2. Ponownie skompiluj nowy magazyn zasad lokalnych. W tym celu kliknij przycisk Start, kliknij przycisk Uruchom, wpisz regsvr32 polstore.dll w polu Otwórz, a następnie kliknij przycisk OK.

  3. Sprawdź, czy składnik usług IPSEC jest ustawiony na automatyczny, a następnie uruchom ponownie kontroler domeny.

Rozwiązanie

Aby tymczasowo obejść ten problem, wyłącz składnik usług IPSEC, a następnie uruchom ponownie kontroler domeny.