Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
W tym artykule omówiono problem polegający na tym, że operacja tworzenia kopii zapasowej przy użyciu usługi Kopia zapasowa systemu Windows Server lub aplikacja kopii zapasowej innej firmy kończy się niepowodzeniem.
Oryginalny numer KB: 2009513
Symptomy
Operacja tworzenia kopii zapasowej przy użyciu kopii zapasowej systemu Windows Server lub aplikacji kopii zapasowej innej firmy kończy się niepowodzeniem w systemie Windows Server.
W dzienniku zdarzeń systemu rejestrowane jest następujące zdarzenie:
Nazwa dziennika: System
Źródło: Service Control Manager
Identyfikator zdarzenia: 7023
Poziom: Błąd
Opis rozwiązania:
Usługa Microsoft Software Shadow Copy Provider została zakończona z powodu następującego błędu:
W systemie nie można odnaleźć określonego pliku.
W dzienniku zdarzeń aplikacji rejestrowane są następujące zdarzenia:
Nazwa dziennika: Aplikacja
Źródło: VSS
Identyfikator zdarzenia: 12292
Poziom: Błąd
Opis rozwiązania:
Błąd usługi kopiowania woluminów w tle: błąd podczas tworzenia klasy COM dostawcy kopii w tle za pomocą identyfikatora CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} [0x80080005].
Operacja:
Uzyskiwanie wywoływanego interfejsu dla tego dostawcy
Uzyskiwanie interfejsu zarządzania dostawcą
Kontekst:
Identyfikator dostawcy: {b5946137-7b9f-4925-af80-51abd60b20d5}
Identyfikator klasy: {00000000-0000-0000-0000-000000000000}
Kontekst migawki: -1
Identyfikator dostawcy: {b5946137-7b9f-4925-af80-51abd60b20d5}
Nazwa dziennika: Aplikacja
Źródło: VSS
Identyfikator zdarzenia: 11
Poziom: Błąd
Opis rozwiązania:
Informacje o usłudze kopiowania woluminów w tle: serwer COM z identyfikatorem CLSID {65ee1dba-8ff4-4a58-ac1c-3470ee2f376a} i nazwa SW_PROV nie można uruchomić. Najprawdopodobniej procesor jest obciążony dużym obciążeniem. [0x80080005]
Operacja:
Uzyskiwanie wywoływanego interfejsu dla tego dostawcy
Uzyskiwanie interfejsu zarządzania dostawcą
Kontekst:
Identyfikator dostawcy: {b5946137-7b9f-4925-af80-51abd60b20d5}
Identyfikator klasy: {00000000-0000-0000-0000-000000000000}
Kontekst migawki: -1
Identyfikator dostawcy: {b5946137-7b9f-4925-af80-51abd60b20d5}
W systemie Windows Server 2008, jeśli kopia zapasowa systemu Windows Server została użyta do wykonania kopii zapasowej, operacja tworzenia kopii zapasowej kończy się niepowodzeniem z jednym z następujących błędów:
Nie można utworzyć kopii w tle w lokalizacji magazynu.
BŁĄD — błąd operacji kopiowania woluminów w tle (0x8004230f)
Dostawca kopii w tle miał nieoczekiwany błąd podczas próby przetworzenia określonej operacji.
Or
Tworzenie kopii w tle w miejscu docelowym kopii zapasowej nie powiodło się.
Operacja kopiowania woluminów w tle nie powiodła się z powodu błędu 0x8004230F.
Aby uzyskać więcej informacji, wyświetl dziennik zdarzeń.
W systemie Windows Server 2008 R2, jeśli kopia zapasowa systemu Windows Server została użyta do wykonania kopii zapasowej, operacja tworzenia kopii zapasowej kończy się niepowodzeniem z jednym z następujących błędów:
Kopia zapasowa systemu Windows nie można utworzyć kopii w tle w lokalizacji magazynu.
Or
Tworzenie kopii w tle w miejscu docelowym magazynu kopii zapasowej nie powiodło się.
Przyczyna
Ten problem może wystąpić, jeśli brakuje wartości rejestru ServiceDll dla funkcji Swprv lub jest ona niepoprawna.
Rozwiązanie
Aby rozwiązać ten problem, wykonaj następujące kroki:
Kliknij przycisk Start, wpisz regedit w polu Rozpocznij wyszukiwanie, a następnie naciśnij Enter.
Znajdź, a następnie kliknij następujący klucz rejestru:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\swprv\Parameters
Uwaga 16.
Jeśli brakuje klucza rejestru Parametry, wykonaj następujące kroki: kliknij prawym przyciskiem myszy klucz rejestru swprv, wybierz pozycję Nowy, wybierz pozycję Klucz, wpisz Parametry i naciśnij Enter.
Po wybraniu klucza rejestru Parameters sprawdź, czy wartość rejestru ServiceDll ma następującą wartość:
%Systemroot%\System32\swprv.dll
Uwaga 16.
Jeśli brakuje wartości rejestru ServiceDll, wykonaj następujące kroki:
- Kliknij prawym przyciskiem myszy klucz rejestru Parametry, wybierz pozycję Nowy, a następnie wybierz pozycję Rozwiń wartość ciągu.
- Jako nazwę wartości wpisz ServiceDll i naciśnij Enter.
- Kliknij dwukrotnie wartość rejestru ServiceDll.
- W polu Dane wartości wpisz %Systemroot%\System32\swprv.dll, a następnie kliknij przycisk OK.
Wykonaj operację tworzenia kopii zapasowej, aby sprawdzić, czy problem został rozwiązany.