Udostępnij za pośrednictwem


Woluminy proste mogą stać się niedostępne, jeśli utrata zasilania nastąpi wkrótce po utworzeniu

Ten artykuł zawiera rozwiązanie problemu, który może stać się niedostępny, jeśli utrata zasilania nastąpi wkrótce po utworzeniu.

Dotyczy: Windows 7 z dodatkiem Service Pack 1
Oryginalny numer KB: 2001877

Symptomy

Rozważmy następujący scenariusz. W systemie Windows 7 tworzysz nowy wolumin prosty w usłudze Zarządzanie dyskami lub DiskPart.exe na dysku niewymiennym. Jeśli system Windows 7 doświadcza nagłej utraty zasilania w ciągu kilku minut od utworzenia woluminu, możesz zauważyć, że wolumin utworzony przed utratą zasilania jest niedostępny i nie ma przypisanej litery dysku po włączeniu zasilania systemu.

Ponadto w obszarze Zarządzanie dyskami wolumin może nie mieć stanu (na przykład "W dobrej kondycji") lub typu systemu plików na liście. Jeśli spróbujesz zmodyfikować wolumin w usłudze Zarządzanie dyskami, może zostać wyświetlony następujący komunikat o błędzie:

Operacja nie powiodła się, ponieważ widok konsoli zarządzania dyskami nie jest aktualny. Odśwież widok przy użyciu zadania odświeżania. Jeśli problem będzie się powtarzać, zamknij konsolę zarządzania dyskami, uruchom ponownie przystawkę Zarządzanie dyskami lub uruchom ponownie komputer.

Przyczyna

Ten problem występuje, ponieważ informacje o konfiguracji nowego woluminu nie zostały zapisane na dysku przez czas wystąpienia utraty zasilania.

Rozwiązanie

Jeśli występuje problem opisany w sekcji "Objawy", ponowne zainstalowanie woluminu rozwiąże problem. Wykonaj następujące kroki, aby ponownie zainstalować wolumin.

  1. Otwórz Menedżera urządzeń. Dostęp do Menedżer urządzeń można uzyskać, wpisując "Menedżer urządzeń" lub "devmgmt.msc" w polu Rozpocznij wyszukiwanie.

  2. Po otwarciu Menedżer urządzeń kliknij pozycję "Woluminy magazynu", aby rozwinąć część Woluminy magazynu drzewa urządzeń.

  3. W obszarze Woluminy magazynu należy zauważyć wolumin wymieniony jako "Nieznane urządzenie". Kliknij to urządzenie prawym przyciskiem myszy i wybierz pozycję "Odinstaluj". Po wyświetleniu monitu o potwierdzenie wybierz przycisk OK.

  4. Uruchom ponownie system, jeśli zostanie wyświetlony monit o to. Wolumin powinien być dostępny po zakończeniu ponownego uruchamiania systemu. Jeśli nie zostanie wyświetlony monit o ponowne uruchomienie systemu, kliknij prawym przyciskiem myszy Menedżer urządzeń i wybierz pozycję "Skanuj pod kątem zmian sprzętu". Po zakończeniu skanowania i zakończeniu instalacji woluminu będzie można uzyskać dostęp do woluminu.

    Uwaga 16.

    Jeśli utrata zasilania wystąpi w ciągu kilku sekund od utworzenia woluminu, w rzadkich okolicznościach może zostać wyświetlony monit o sformatowanie woluminu po wykonaniu powyższych kroków. W takim przypadku konfiguracja systemu plików nie została zapisana w momencie wystąpienia utraty zasilania. Może być konieczne ponowne sformatowanie lub ponowne utworzenie woluminu.

Jeśli problem został rozwiązany, to koniec pracy z tą sekcją. Jeśli problem nie został rozwiązany, można skontaktować się z pomocą techniczną.