Udostępnij za pośrednictwem


Strefy DNS nie są ładowane, a rejestrowane są zdarzenia o identyfikatorze 4000 i 4007

W tym artykule rozwiązano problem polegający na tym, że identyfikatory zdarzeń 4000 i 4007 są rejestrowane, gdy strefy DNS nie są ładowane w konsoli DNS.

Oryginalny numer KB: 2751452

Symptomy

Jeden z serwerów DNS w środowisku rozpoczyna się od problemu, że strefy nie są ładowane w konsoli DNS. Identyfikatory zdarzeń 4000 i 4007 są rejestrowane w dziennikach zdarzeń DNS:

Identyfikator zdarzenia 4000:

The DNS server was unable to open Active Directory. This DNS server is configured to obtain and use information from the directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and reload the zone. The event data is the error code.

Identyfikator zdarzenia 4007:

The DNS server was unable to open zone \<zone> in the Active Directory from the application directory partition \<partition name>. This DNS server is configured to obtain and use information from the directory for this zone and is unable to load the zone without it. Check that the Active Directory is functioning properly and reload the zone. The event data is the error code.

Ponadto podczas próby otwarcia konsoli DNS zostanie wyświetlone wyskakujące okienko z powodu odmowy dostępu.

Zauważysz, że usługa serwera DNS jest uruchomiona.

Podczas próby wykonania dowolnej operacji w strefach zintegrowanych z usługą AD przy użyciu polecenia DNSCMD zostanie wyświetlony komunikat o błędzie Odmowa dostępu.

Przyczyna

Ten problem występuje, gdy dany serwer DC/DNS utracił swój bezpieczny kanał z samym kontrolerem PDC lub kontrolerem PDC.

Ten problem może również wystąpić w jednym środowisku kontrolera domeny, w którym ten serwer DC/DNS przechowuje wszystkie role FSMO i wskazuje się jako podstawowy serwer DNS.

Rozwiązanie

Jeśli w środowisku znajduje się inny kontroler domeny/serwer DNS, skonfiguruj serwer, na którym występuje problem, aby wskazywał inny aktywny serwer DNS we właściwościach protokołu TCP/IP.

  1. Zatrzymaj usługę centrum dystrybucji kluczy na kontrolerze domeny, w której występuje problem.

  2. Uruchom następujące polecenie z podwyższonym poziomem uprawnień:

    netdom resetpwd /server:<PDC.domain.com> /userd:<Domain\domain_admin> /passwordd:*
    

    Zostanie wyświetlony monit o podanie hasła użytego konta administratora domeny.

  3. Po wykonaniu polecenia uruchom ponownie serwer.

Strefy DNS powinny teraz ładować się.

Jeśli jest to jedyny kontroler domeny w środowisku i nie ma żadnych innych dostępnych serwerów DNS, wykonaj te same kroki, ale zastąp element PDC.Domain.com własnym adresem IP serwera (ponieważ sam jest kontrolerem PDC).