Udostępnij za pośrednictwem


Usługa routingu i dostępu zdalnego nie jest uruchamiana, gdy nie ma łączności sieciowej

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że usługa routingu i dostępu zdalnego (RRAS) nie uruchamia się, gdy nie ma łączności sieciowej.

Oryginalny numer KB: 973990

Symptomy

W systemie Windows usługa routingu i dostępu zdalnego (RRAS — nazwa usługi: RemoteAccess) nie jest uruchamiana, gdy nie ma łączności sieciowej. Na przykład funkcja RemoteAccess nie uruchamia się, gdy wszystkie połączenia sieciowe przewodowe są odłączone lub gdy łączność bezprzewodowa jest wyłączona.

Ponadto nie można tworzyć nowych połączeń przychodzących, gdy nie ma łączności sieciowej. Dzieje się tak, ponieważ połączenia przychodzące wymagają uruchomienia funkcji RemoteAccess.

Przyczyna

Po uruchomieniu funkcji RemoteAccess próbuje zainicjować niektóre funkcje w usłudze IAS (Internet Authentication Service) na potrzeby uwierzytelniania. Inicjowanie IAS kończy się niepowodzeniem, gdy nie ma łączności sieciowej. W związku z tym funkcja RemoteAccess nie uruchamia się. Niepowodzenie inicjowania IAS jest projektowane, gdy nie ma łączności sieciowej. Następnie zobaczysz zachowanie wymienione w sekcji Objawy .
To zachowanie jest niezależne od instalacji serwera zasad sieciowych (NPS), następcy IAS.

Rozwiązanie

Aby uruchomić funkcję RemoteAccess w celu utworzenia nowego połączenia przychodzącego, komputer musi być połączony z siecią. Po uruchomieniu funkcji RemoteAccess można nadal utworzyć nowe połączenie przychodzące po rozłączeniu z siecią.

Aby sprawdzić stan funkcji RemoteAccess, sprawdź stan usługi RemoteAccess (Routing i dostęp zdalny) na karcie Usługi w Menedżerze zadań systemu Windows.

Stan

Wynika to z ustawienia fabrycznego. Usługa RemoteAccess jest domyślnie wyłączona na serwerze z systemem Windows i w wersjach klienckich.