Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
W tym artykule wyjaśniono, jak rozwiązywać problemy ze zdarzeniami o identyfikatorze 1020 na serwerze plików bloku komunikatów serwera (SMB).
Oryginalny numer KB: 4562940
Symptomy
Na serwerze plików SMB systemu Windows Server obserwujesz zdarzenia o identyfikatorze 1020 z protokołu SMB-Server w dzienniku zdarzeń Microsoft-Windows-SMBServer/Operational. Informacje w tych zdarzeniach przypominają następujący komunikat:
Operacja systemu plików trwa dłużej niż oczekiwano.
Nazwa klienta: <Client-IP/Name>
Adres klienta: <Client-IP>:<Client-Port>
Nazwa użytkownika: <nazwa użytkownika>
Identyfikator sesji: <SMB-Session-ID>
Nazwa udziału: <SMB-Share-Name>
Nazwa pliku: <Nazwa pliku>
Polecenie: <SMB-Command-Code>
Czas trwania (w milisekundach): <czas trwania>
Próg ostrzeżenia (w milisekundach): 15000
Wskazówki:
Podstawowy system plików trwał zbyt długo, aby zareagować na operację. Zwykle oznacza to problem z magazynem, a nie SMB.
Podczas rejestrowania tych zdarzeń w systemie Windows mogą być również obserwowane następujące objawy:
- Klienci serwera SMB mają problemy z wydajnością. Ponieważ serwer SMB uzyskuje dostęp do lokalnego systemu plików w imieniu swoich klientów SMB, problemy z wydajnością na serwerze SMB mają bezpośredni wpływ na klientów. Aplikacje klienckie mogą mieć bardzo długi czas oczekiwania, jeśli ich interakcja z serwerem SMB obejmuje kilka kolejnych operacji, a każda operacja doświadcza opóźnienia.
- Klienci serwera SMB mogą mieć problemy z dostępem do udziałów zarządzanych przez serwer SMB.
- Lokalne aplikacje serwera SMB lub inne składniki napotykają problemy z wydajnością. Te aplikacje i składniki mogą nie być w stanie zarejestrować takich problemów z wydajnością.
- Serwer SMB wydaje się przestać odpowiadać.
Uwaga 16.
Problemy z wydajnością mogą nie mieć wpływu na wszystkie dyski serwera SMB w tym samym czasie lub w tym samym stopniu.
Przyczyna
Identyfikator zdarzenia 1020 wskazuje, że system plików serwera SMB nie może ukończyć operacji odczytu/zapisu (we/wy) w czasie dozwolonym. Domyślnie dozwolony czas wynosi 15 sekund. Zazwyczaj oczekujemy, że takie operacje zakończą się w ciągu jednej cyfry w milisekundowym przedziale czasu.
Nieprawidłowe działanie sterowników filtrów systemu plików może spowodować opóźnienia kilku sekund. Problemy związane z dyskami fizycznymi serwera SMB mogą również spowodować znaczne zmniejszenie wydajności. Takie problemy obejmują następujące kwestie:
- Dyski fizyczne są przeciążone.
- Usługa VSS lub inne rozwiązania do tworzenia kopii zapasowych powodują długotrwałe zawieszanie się dysku.
- Stos sieciowy/magazyn bazowej funkcji hypervisor działa słabo.
- Występują problemy z połączeniami sieciowymi z dyskami fizycznymi.
- Występują problemy z samym urządzeniem magazynowym (san), magazynem dołączonym do sieci (NAS) lub innym typem.
Opóźnienia systemu plików, które są mniejsze niż próg 15 sekund, nie generują zdarzenia ostrzegawczego, ale zmniejszają wydajność serwera SMB.
Rozwiązanie
Ponieważ przyczyna tych opóźnień systemu plików może zależeć od specyfiki środowiska, zwykle trzeba zebrać więcej danych, aby odizolować konkretny problem.
Zacznij od przejrzenia dziennika zdarzeń serwera SMB. Zdarzenia o identyfikatorze zdarzenia 1020 zawierają informacje, które mogą ułatwić identyfikowanie szczegółów i wzorców. Dane zdarzenia obejmują dokładny czas trwania opóźnienia i kod polecenia SMB, który napotkał opóźnienie. Aby uzyskać listę kodów poleceń SMBv2, zobacz 2.2.1.2 SMB2 Packet Header — SYNC.
Zbieranie dzienników śledzenia
Aby dokładniej zdiagnozować, czy problem pochodzi z systemu operacyjnego Windows (na przykład sterowników filtrów) lub z zewnątrz (na przykład sprzętu, funkcji hypervisor, sieci lub magazynu), użyj aplikacji, takiej jak Storport Trace, aby zbierać dane śledzenia. Użyj narzędzia, takiego jak StorPortPacman, aby sprawdzić czasy odpowiedzi dysku. Ślady usługi StorPort na dolnym końcu stosu magazynu systemu Windows, a serwer SMB (lub dowolna inna aplikacja) napotyka opóźnienia na górnym końcu stosu. Aby uzyskać więcej informacji na temat urządzenia StorPortPacman, zobacz Deciphering Storport Traces 101 (Dekodowanie śladów storportu 101).
Wysoki maksymalny czas odpowiedzi na poziomie StorPort wskazuje, że przyczyna problemów z wydajnością znajduje się poza systemem operacyjnym. Aby określić, jakie opóźnienia napotyka system z dysków logicznych na poziomie aplikacji (serwera plików), włącz śledzenie wydajności lub funkcji WPR. Takie dane śledzenia pokazują również opóźnienia, które są mniejsze niż 15-sekundowy próg ostrzeżenia. Aby uzyskać więcej informacji, zobacz Mierzenie opóźnienia dysku za pomocą systemu Windows monitor wydajności (Perfmon).
Zbieranie danych pliku zrzutu jądra
W przypadku ekstremalnych opóźnień (co najmniej 10 minut) i w innych warunkach serwer SMB tworzy plik zrzutu na żywo jądra. Takie informacje są przydatne podczas rozwiązywania problemów.
Następujące zdarzenia w dzienniku zdarzeń Microsoft-Windows-SMBServer/Operational wskazują, czy plik zrzutu jądra na żywo jest dostępny:
- Identyfikator zdarzenia 1031: Serwer wykrył problem i przechwycił zrzut jądra na żywo w celu zbierania informacji o debugowaniu.
- Identyfikator zdarzenia 1032: Serwer wykrył problem, ale nie mógł przechwycić zrzutu jądra na żywo w celu zbierania informacji o debugowaniu.
System Windows umieszcza pliki zrzutu w folderze %SystemRoot%\LiveKernelReports .