Udostępnij za pośrednictwem


Czarny ekran podczas rozruchu

Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że ponowne uruchomienie komputera z systemem Windows x86 kończy się niepowodzeniem z czarnym ekranem.

Oryginalny numer KB: 155053

Symptomy

Po ponownym uruchomieniu komputera z systemem Windows x86 komputer zatrzymuje się z pustym, czarnym ekranem natychmiast po zakończeniu samodzielnego testowania zasilania (POST).

Przyczyna

Główny rekord rozruchowy (MBR), tabele partycji, sektor rozruchowy lub plik NTLDR jest uszkodzony.

Rozwiązanie

  1. Utwórz dysk rozruchowy systemu Windows, aby uruchomić komputer.

    Jeśli możesz uruchomić komputer bez błędów, uszkodzenie jest ograniczone do głównego rekordu rozruchowego (MBR), sektora rozruchowego lub pliku NTLDR. Po uruchomieniu systemu Windows natychmiast wykonaj kopię zapasową wszystkich danych wartości. Użyj administratora dysku, aby sprawdzić, czy partycje na dysku rozruchowym są prawidłowym rozmiarem. Jeśli istnieją nieprawidłowe partycje, najlepszym rozwiązaniem jest ponowne utworzenie tych partycji i ponowne sformatowanie dotkniętych dysków, a następnie przywrócenie danych z najnowszej taśmy kopii zapasowej. Jeśli nie można uruchomić systemu z dysku rozruchowego systemu Windows, najprawdopodobniej konieczne będzie ponowne zainstalowanie systemu Windows i przywrócenie z taśmy.

  2. Uruchom najnowsze oprogramowanie antywirusowe, aby sprawdzić, czy nie ma wirusa. Oprogramowanie antywirusowe oparte na ms-DOS jest wystarczające do tego celu, nawet jeśli system plików jest NTFS. Programy antywirusowe oparte na ms-DOS można uruchamiać z dysku rozruchowego MS-DOS.

  3. Upewnij się, że główny rekord rozruchowy (MBR) jest prawidłowy. Rozruch z dysku rozruchowego MS-DOS bez wirusów w wersji 5.0 lub nowszej z dyskiem FDISK na nim. FDISK /MBR Uruchom polecenie:

    Ostrzeżenie

    Jeśli komputer jest zainfekowany wirusem, użycie FDISK /MBR przełącznika może uniemożliwić uruchomienie komputera. Przed użyciem FDISK /MBR polecenia należy mieć pewność, że komputer nie jest zainfekowany wirusem.

  4. Jeśli podstawowa partycja rozruchowa to partycja tabeli alokacji plików (FAT), rozruch z dysku MS-DOS, wykonaj SYS C: polecenie, aby dysk MS-DOS był rozruchowy, a następnie wykonaj krok 5, aby zastąpić sektor rozruchu systemu Windows.

  5. Uruchom Instalatora systemu Windows i wybierz opcję Napraw. Wybierz opcje Inspekcja sektora rozruchowego i Przywróć środowisko uruchamiania. Jeśli sektor rozruchowy na dysku rozruchowym jest uszkodzony, należy go naprawić.

  6. Jeśli system nadal nie uruchomi się poprawnie, użyj Attrib.exe lub Menedżera plików, aby usunąć atrybuty pliku z pliku NTLDR znajdującego się w katalogu głównym partycji systemowej. Skopiuj nowy plik NTLDR z katalogu i386 dysku CD-ROM systemu Windows, aby zastąpić istniejący.

  7. Jeśli korzystasz z systemu Windows, a partycja systemowa ma system NTFS, może istnieć fragmentowany MFT, który uniemożliwia rozruch systemu.