Uwaga
Dostęp do tej strony wymaga autoryzacji. Może spróbować zalogować się lub zmienić katalogi.
Dostęp do tej strony wymaga autoryzacji. Możesz spróbować zmienić katalogi.
Ten artykuł zawiera rozwiązanie problemu polegającego na tym, że klienci usług terminalowych wielokrotnie odmawiają dostępu do serwera terminali po uaktualnieniu systemu Windows.
Oryginalny numer KB: 329896
Symptomy
Po uaktualnieniu domeny systemu Microsoft Windows NT do systemu Windows 2000 lub Windows Server 2003 klienci usług terminalowych systemu Windows 2000 mogą wielokrotnie odmawiać dostępu do serwera terminali. Jeśli używasz klienta usług terminalowych do logowania się na serwerze terminali, może zostać wyświetlony jeden z następujących komunikatów o błędach:
Z powodu błędu zabezpieczeń klient nie może nawiązać połączenia z serwerem terminali. Po upewnieniu się, że zalogowano się do sieci, spróbuj ponownie połączyć się z serwerem.
lub
Pulpit zdalny rozłączony. Z powodu błędu zabezpieczeń klient nie mógł nawiązać połączenia z komputerem zdalnym. Sprawdź, czy zalogowano się do sieci, a następnie spróbuj ponownie nawiązać połączenie.
Ponadto następujące komunikaty o identyfikatorze zdarzeń mogą być rejestrowane Podgląd zdarzeń na serwerze terminalu:
Identyfikator zdarzenia: 50
Źródło zdarzenia: TermDD
Opis zdarzenia: składnik protokołu RDP X.224 wykrył błąd w strumieniu protokołu i odłączył klienta.
oraz
Identyfikator zdarzenia: 1008
Źródło zdarzenia: TermService
Opis zdarzenia: Okres prolongaty licencjonowania usług terminalowych wygasł i usługa nie została zarejestrowana na serwerze licencji. Serwer licencji usług terminalowych jest wymagany do ciągłej operacji. Serwer terminali może działać bez serwera licencji przez 90 dni po początkowym uruchomieniu.
oraz
Identyfikator zdarzenia: 1004
Źródło zdarzenia: TermService
Opis zdarzenia: Serwer terminalu nie może wydać licencji klienta.
oraz
Identyfikator zdarzenia: 1010
Źródło zdarzenia: TermService
Opis zdarzenia: usługi terminalowe nie mogły zlokalizować serwera licencji. Upewnij się, że wszystkie serwery licencji w sieci są zarejestrowane w usłudze WINS\DNS, akceptując żądania sieciowe, a usługa licencjonowania usług terminalowych jest uruchomiona.
oraz
Identyfikator zdarzenia: 28
Źródło zdarzenia: TermServLicensing
Opis zdarzenia: Licencjonowanie usług terminalowych można uruchamiać tylko na kontrolerach domeny lub serwerze w grupie roboczej. Aby uzyskać więcej informacji, zobacz Temat pomocy dotyczącej licencjonowania serwera terminali.
Przyczyna
Ten problem może wystąpić, jeśli certyfikat na serwerze terminalu jest uszkodzony.
Rozwiązanie
Ważne
W tej sekcji, metodzie lub w tym zadaniu podano informacje dotyczące modyfikowania rejestru. Niepoprawne zmodyfikowanie rejestru może jednak być przyczyną poważnych problemów. Dlatego należy uważnie wykonać poniższe kroki. Aby zapewnić dodatkową ochronę, utwórz kopię zapasową rejestru przed przystąpieniem do jego modyfikacji. Dzięki temu będzie można przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji na temat tworzenia kopii zapasowej i przywracania rejestru, kliknij następujący numer artykułu, aby wyświetlić artykuł w bazie wiedzy Microsoft Knowledge Base: 322756 Jak utworzyć kopię zapasową i przywrócić rejestr w systemie Windows
Aby rozwiązać ten problem, wykonaj kopię zapasową, a następnie usuń klucze rejestru certyfikatów X509, uruchom ponownie komputer, a następnie ponownie uaktywnij serwer licencjonowania usług terminalowych. W tym celu należy wykonać następujące czynności:
Uwaga 16.
Wykonaj następującą procedurę na każdym z serwerów terminali.
Upewnij się, że utworzono pomyślnie kopię zapasową rejestru serwera terminali.
Uruchom Edytor rejestru.
Odszukaj, a następnie kliknij następujący podklucz rejestru:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TermService\Parameters
W menu Rejestr kliknij polecenie Eksportuj plik rejestru.
Wpisz wyeksportowane parametry w polu Nazwa pliku, a następnie kliknij przycisk Zapisz.
Uwaga 16.
Jeśli w przyszłości będzie trzeba przywrócić ten podklucz rejestru, kliknij dwukrotnie plik Exported-parameters.reg zapisany w tym kroku.
W podkluczu rejestru Parameters kliknij prawym przyciskiem myszy każdą z następujących wartości, kliknij przycisk Usuń, a następnie kliknij przycisk Tak , aby potwierdzić usunięcie:
- Certyfikat
- Certyfikat X509
- Identyfikator certyfikatu X509
Zamknij Edytor rejestru, a następnie uruchom ponownie serwer.
Ponownie uaktywnij serwer licencjonowania usług terminalowych przy użyciu metody połączenia telefonicznego w Kreatorze licencjonowania.
Uwaga 16.
W przypadku aktywowania serwera licencjonowania usług terminalowych przy użyciu opcji Telefon serwer licencjonowania używa innej formy certyfikatu.