Udostępnij za pośrednictwem


Błąd "Odmowa dostępu" podczas korzystania z harmonogramu zadań

Podczas korzystania z harmonogramu zadań jest wyświetlany następujący komunikat o błędzie:

Odmowa dostępu. Konto użytkownika nie ma uprawnień do uruchamiania tego zadania.

Przyczyna

Problem występuje z jednego z następujących powodów:

  • Konto użytkownika użyte do uruchomienia zadania nie ma niezbędnych uprawnień administracyjnych.
  • Uprawnienia do folderu C:\Windows\System32\Tasks zostały zmienione.
  • Zadanie jest skonfigurowane do uruchamiania z określonym zestawem poświadczeń, które różnią się od bieżącego konta użytkownika.

Uwaga

Jeśli łączysz się z hostem zdalnym przy użyciu mmc.exe z przystawką Harmonogram zadań lub konsolą taskschd.msc przy użyciu zwykłego konta, oczekuje się, że zostanie wyświetlony błąd odmowy dostępu. Tylko konta należące do grupy Administratorzy lokalni lub Administratorzy domeny mogą zdalnie zarządzać systemem. Ze względów bezpieczeństwa użytkownik niebędący administratorem nie może wyświetlać ani zarządzać zadaniem Harmonogramu zadań systemu Windows utworzonym przez innego użytkownika. Aby uzyskać więcej informacji, zobacz Co nowego w harmonogramie zadań.

Rozwiązanie

Aby rozwiązać ten problem, zastosuj jedną z następujących metod:

Uruchamianie harmonogramu zadań jako administrator

Kliknij prawym przyciskiem myszy harmonogram zadań i wybierz polecenie Uruchom jako administrator. Takie podejście może często rozwiązywać problemy z dostępem.

Sprawdzanie uprawnień konta użytkownika

Upewnij się, że używane konto użytkownika ma uprawnienia niezbędne do uruchomienia zadania. Może być konieczne dodanie konta użytkownika do grupy Administratorzy.

Modyfikowanie właściwości zadania

  1. Otwórz harmonogram zadań, znajdź zadanie powodujące problem, kliknij go prawym przyciskiem myszy i wybierz polecenie Właściwości.
  2. Przejdź do karty Ogólne i wybierz pozycję Uruchom z najwyższymi uprawnieniami.

Sprawdzanie ustawień zasad grupy

  1. Otwórz Edytor zasad grupy, wpisując gpedit.msc w polu Uruchom .
  2. Przejdź do pozycji Konfiguracja>komputera Ustawienia systemu Windows Ustawienia zabezpieczeń>Ustawienia>lokalne Zasady>przypisywanie praw użytkownika.
  3. Upewnij się, że twoje konto użytkownika ma prawo logować się jako zadanie wsadowe.

Ponowne inicjowanie zadań ręcznych

  1. Wyeksportuj problematyczne zadanie do pliku XML przed jego usunięciem. W tym celu uruchom następujące polecenie:

    Export-ScheduledTask -TaskName "<task_name>" -FilePath "<backup_xml_file_path>"
    
  2. Ponownie zaimportuj zadanie po korektach rejestru/plików:

    Register-ScheduledTask -Xml (Get-Content "<backup_xml_file_path>" | Out-String) -TaskName "<task_name>"