Solucionar problemas do Azure Load Balancer

Esta página fornece informações para solução de problemas comuns do Azure Load Balancer Basic e Standard. Para obter mais informações sobre o Load Balancer Standard, veja Visão geral do Load Balancer Standard.

Quando a conectividade do Load Balancer não estiver disponível, os sintomas mais comuns são os seguintes:

  • VMs por trás do Load Balancer não estão respondendo às investigações de integridade
  • VMs por trás do Load Balancer não estão respondendo ao tráfego na porta configurada

Quando os clientes externos para as VMs de back-end passarem pelo balanceador de carga, o endereço IP dos clientes será usado para a comunicação. Garanta que o endereço IP dos clientes foi adicionado à lista de permissões do NSG.

Sem conectividade de saída dos Balanceadores de Carga Internos (ILB) Padrão

Validação e Resolução

Os ILBs Standard são seguros por padrão. Os ILBs básicos permitem conectar-se à Internet por meio de um endereço IP público oculto chamado de IP de acesso de saída padrão. Isso não é recomendado para cargas de trabalho de produção, pois o endereço IP não fica estático nem bloqueado através dos grupos de segurança de rede que você possui. Se você passou recentemente de um ILB Basic para um ILB Standard, você deve criar um IP Público explicitamente por meio da configuração Somente saída, que bloqueia o IP através dos grupos de segurança de rede. Você também pode usar um Gateway da NAT em sua sub-rede. O Gateway da NAT é a solução recomendada para saída.

Sem conectividade de entrada com Balanceadores de Carga Externos (ELB) Padrão

Causa

Os Standard Load Balancers e os endereços IP padrão são fechados para conexões de entrada, a menos que sejam abertos por Grupos de Segurança de Rede. Os NSGs são usados para permitir explicitamente o tráfego permitido. Se você não tiver um NSG em uma sub-rede ou adaptador de rede do seu recurso de máquina virtual, o tráfego não terá permissão para acessar o recurso.

Resolução

Para permitir o tráfego de entrada, adicione um grupo de segurança de rede à sub-rede ou interface do recurso virtual.

Não é possível alterar a porta de back-end para a regra de LB existente de um balanceador de carga que tenha um conjunto de dimensionamento de máquinas virtuais implantado no pool de back-end.

Causa

A porta de back-end não pode ser modificada para uma regra de balanceamento de carga usada por uma investigação de integridade para o balanceador de carga referenciado pelo Conjunto de Dimensionamento de Máquina Virtual

Resolução

Para alterar a porta, você pode remover a investigação de integridade através da atualização do Conjunto de Dimensionamento de Máquinas Virtuais, atualizar a porta e, em seguida, configurar a investigação de integridade novamente.

Problema: o tráfego pequeno ainda passará pelo balanceador de carga depois de remover as VMs do pool de back-end do balanceador de carga.

Causa

As VMs removidas do pool de back-end não devem mais receber tráfego. A pequena quantidade de tráfego de rede pode estar relacionada ao armazenamento, ao DNS e a outras funções no Azure.

Resolução

Para verificar, você pode conduzir um rastreamento de rede. O Nome de Domínio Totalmente Qualificado (FQDN) usado para sua conta de armazenamento de blobs está listado nas propriedades de cada conta de armazenamento. De uma máquina virtual em sua assinatura do Azure, você pode executar nslookup para determinar o IP do Azure atribuído a essa conta de armazenamento.

Problema: o balanceador de carga está em estado de falha

Resolução

  • Depois de identificar o recurso que está em um estado de falha, acesse o Azure Resource Explorer e identifique o recurso nesse estado.
  • Atualize a alternância no canto superior direito para Leitura/Gravação.
  • Selecione Editar no recurso em estado de falha.
  • Selecione PUT e, depois, GET para garantir que o estado de provisionamento seja atualizado para Êxito.
  • Em seguida, você pode realizar outras ações, pois o recurso não estará no estado de falha.

Capturas de rede necessárias para solução de problemas e casos de suporte

Se você optar por abrir um caso de suporte, colete as informações a seguir para uma resolução mais rápida. Escolha uma única VM de back-end para executar os seguintes testes:

  • Use ps ping de uma das VMs de back-end na rede virtual para testar a resposta da porta de investigação (exemplo: ps ping 10.0.0.4:3389) e registre os resultados.
  • Se nenhuma resposta for recebida nesses testes de ping, execute um rastreamento Netsh simultâneo na VM de back-end e na VM de teste da rede virtual enquanto executa PsPing. Depois, interrompa o rastreamento Netsh.

Próximas etapas

Se as etapas anteriores não resolverem o problema, abra um tíquete de suporte.