Um lote é realizado na status Postagem, Recebimento, Ocupado, Marcado, Bloqueado ou Editado no Microsoft Dynamics GP

Este artigo fornece uma solução para um erro que ocorre quando você tenta postar um lote e abri-lo no Microsoft Dynamics GP ou no Microsoft Business Solutions – Great Plains.

Aplica-se a: Microsoft Dynamics GP
Número de KB original: 850289

Sintomas

Depois de tentar postar um lote no Microsoft Dynamics GP ou no Microsoft Business Solutions – Great Plains, o lote recebe um dos seguintes status:

  • Postar
  • Receber
  • Ocupado
  • Marcado
  • Bloqueado
  • Edição

Você não pode postar ou unmark o lote. Ao tentar abrir o lote, você pode receber a seguinte mensagem de erro:

"O lote está marcado para ser postado por outro usuário."

Motivo

Esse problema pode ocorrer porque uma flutuação de energia ou algum outro problema fez com que o processo de postagem parasse.

Resolução

Observação

Todos os scripts que estão na seção "Resolução" devem ser executados em uma ferramenta de consulta. Para abrir a ferramenta de consulta apropriada, execute a instrução no Microsoft SQL Server Management Studio. Para abrir SQL Server Management Studio, selecione Iniciar, aponte para Programas>microsoft SQL Server (2019) (ou a versão que você tem) e selecione SQL Server Management Studio. Para executar um script, selecione Nova Consulta.

Para resolver esse problema, siga estas etapas:

  1. Verifique se você tem um backup atual do banco de dados da empresa e peça a todos os usuários que saiam do Microsoft Dynamics GP. Para criar o backup no Microsoft Dynamics GP, siga as etapas apropriadas depois que todos os usuários sairem do Microsoft Dynamics GP:

    1. No menu Arquivo , selecione Backup.
    2. Na lista Nome da Empresa , selecione a empresa que você deseja fazer backup.
    3. Na caixa Selecionar o arquivo de backup , selecione a pasta amarela para abrir o local em que você deseja colocar o arquivo de backup.

    Ou

    1. No Pesquisador de Objetos, expanda seus bancos de dados para ver o banco de dados que deseja fazer backup.
    2. Clique com o botão direito do mouse no Nome do Banco de Dados, vá para Tarefas e selecione Backup.
    3. Selecione o botão adicionar e selecione o local e o nome do arquivo ao qual deseja salvar seu backup.
    4. Selecione Ok para iniciar o backup.
  2. Exiba o conteúdo das seguintes tabelas para verificar se todos os usuários estão conectados: DYNAMICS..ACTIVITY, DYNAMICS..SY00800, DYNAMICS..SY00801, , TEMPDB..DEX_LOCKe TEMPDB..DEX_SESSION. Para fazer isso, execute o script a seguir.

    SELECT * FROM DYNAMICS..ACTIVITY SELECT * FROM DYNAMICS..SY00800 SELECT * FROM DYNAMICS..SY00801 SELECT * FROM TEMPDB..DEX_LOCK SELECT * FROM TEMPDB..DEX_SESSION
    

    Observação

    Quando todos os usuários forem retirados do Microsoft Dynamics GP, essas tabelas não terão registros neles.

  3. Se nenhum resultado for retornado, vá para a etapa 4. Caso contrário, desmarque os registros presos usando qualquer um dos scripts apropriados a seguir.

    DELETE DYNAMICS..ACTIVITY DELETE DYNAMICS..SY00800 DELETE DYNAMICS..SY00801 DELETE TEMPDB..DEX_LOCK DELETE TEMPDB..DEX_SESSION
    
  4. Execute o script a seguir no banco de dados da empresa. Substitua XXX pelo número do lote ou pelo nome do lote que você está tentando postar ou selecionar no Microsoft Dynamics GP.

    UPDATE SY00500 SET MKDTOPST=0, BCHSTTUS=0 where BACHNUMB='XXX'
    

    Observação

    O valor de BACHNUMB é o mesmo que o valor da janela ID do Lote no Microsoft Dynamics GP.

  5. Verifique a precisão das transações.

  6. Verifique se você pode editar e postar os lotes.