Sync AD On Premise x Azure AD

Thiago tcarvalhal 0 Pontos de reputação
2025-02-21T04:00:49.9+00:00

No AD On Premise tem um único usuário que não atualizava novos dados (cargo, departamento, gestor) de jeito algum no Azure AD.

Excluí permanentemente do Azure AD para ver se aparecia novamente com dados do On Premise e nada.

Agora só esta no On Premise e no Azure AD não vem. O que pode ser esse mistério único entre centenas de usuários ?

Desenvolvimento para Windows | Serviços de Informações da Internet
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  1. Gao Chen 10,665 Pontos de reputação Equipe Externa da Microsoft Moderador
    2025-02-21T19:52:22.6933333+00:00

    Olá Thiago tcarvalhal,

    Bem-vindo ao Mircosoft Q&A!

    Entendo a frustração com esse problema específico de sincronização. Vamos analisar algumas possíveis causas e soluções para resolver essa questão.

    Possíveis Causas

    Problemas de Sincronização de Atributos:

    • Pode haver um problema com os atributos específicos do usuário no AD On-Premise que estão impedindo a sincronização correta com o Azure AD. Verifique se os atributos como userPrincipalName, proxyAddresses e sourceAnchor estão configurados corretamente

    Erros de Conectividade:

    • Certifique-se de que o servidor que hospeda o Azure AD Connect tem conectividade de rede adequada com o Azure AD. Problemas de rede podem impedir a sincronização de dados

    Conflitos de Dados:

    • Pode haver conflitos de dados, como duplicação de nomes de usuário ou endereços de e-mail, que estão impedindo a sincronização. Utilize a Ferramenta de Correção de Erros DirSync (IdFix) para identificar e resolver esses problemas

    Configurações de Sincronização:

    • Verifique se a configuração do Azure AD Connect está correta e atualizada. Às vezes, uma atualização ou reconfiguração pode resolver problemas de sincronização

    Soluções Sugeridas

    Verificação de Atributos:

    • Utilize o Synchronization Service Manager para verificar os atributos do usuário e garantir que não há erros ou conflitos. Abra o Synchronization Service Manager no servidor onde o Azure AD Connect está instalado e verifique as operações de sincronização na aba “Operations”

    Ferramenta IdFix:

    • Execute a Ferramenta IdFix para identificar e corrigir possíveis problemas relacionados aos objetos no AD DS local. Isso pode ajudar a resolver conflitos de dados que estão impedindo a sincronização

    Reconfiguração do Azure AD Connect:

    • Reconfigure o Azure AD Connect para garantir que todas as configurações estejam corretas. Verifique se você está utilizando a versão mais recente do Azure AD Connect, pois atualizações podem resolver problemas conhecidos

    Monitoramento com Azure AD Connect Health:

    • Utilize o Azure AD Connect Health para monitorar o estado da sincronização e identificar quaisquer erros ou avisos que possam estar afetando o processo de sincronização. Acesse o Azure AD Connect Health no portal do Azure e verifique o estado da sincronização

    Espero que essas informações ajudem a resolver o problema de sincronização do usuário. Se precisar de mais assistência, estou à disposição!

    Saudações

    Gao.


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