Solução de problemas de conta da Automação do Azure

Este artigo aborda soluções para problemas que você pode encontrar ao usar uma conta de Automação do Azure. Confira informações gerais sobre contas de automação em Visão geral da autenticação da conta de Automação do Azure.

Cenário: Não é possível criar uma conta de Automação quando o GUID é usado como nome da conta

Problema

Ao criar uma conta de Automação com um GUID como um nome de conta, você encontra um erro.

Causa

Uma accountid é um identificador exclusivo em todas as contas de Automação em uma região e, quando o nome da conta for um GUID, manteremos accountid de Automação e o nome como GUID. Nesse cenário, ao criar uma nova conta de Automação e especifica um GUID (como um nome de conta) e, se ele entrar em conflito com qualquer accountid de Automação existente, você encontrará um erro.

Por exemplo, ao tentar criar uma conta de Automação com o nome 8a2f48c1-9e99-472c-be1b-dcc11429c9ff e se já houver um accountid de Automação existente em todas as contas de Automação nessa região, a criação da conta falhará e você verá o seguinte erro:

   {

   "code": "BadRequest",

   "message": Automation account already exists with this account id. AccountId: 8a2f48c1-9e99-472c-be1b-dcc11429c9ff. 

   }

Resolução

Certifique-se de criar uma conta de Automação com um novo nome.

Cenário: não é possível registrar o Provedor de Recursos de Automação para assinaturas

Problema

Ao trabalhar em sua conta de automação com recursos de gerenciamento como, por exemplo, o Gerenciamento de Atualizações, você encontra o seguinte erro:

Error details: Unable to register Automation Resource Provider for subscriptions:

Causa

O Provedor de Recursos de Automação não está registrado na assinatura.

Resolução

Para registrar o Provedor de Recursos de Automação, execute as seguintes etapas no portal do Azure:

  1. No navegador, acesse o portal do Azure.

  2. Em Assinaturas, selecione sua assinatura.

  3. Em Configurações, selecione Provedores de Recursos.

  4. Na lista de provedores de recursos, verifique se o provedor de recursos Microsoft.Automation está registrado.

  5. Se o provedor não estiver listado, registre-o conforme descrito em Resolver erros de registro do provedor de recursos.

Próximas etapas

Se este artigo não conseguiu resolver seu problema, visite um dos seguintes canais para obter mais suporte:

  • Obtenha respostas de especialistas do Azure nos Fóruns do Azure.
  • Conecte-se ao @AzureSupport. Esta é a conta oficial do Microsoft Azure para conectar-se aos recursos certos de respostas, suporte e especialistas da comunidade do Azure.
  • Registrar um incidente de suporte do Azure. Acesse o site de suporte do Azure e selecione Obter suporte.