Compartilhar via


Interface do usuário e instalação do Kusto.Explorer

Kusto. Explorer é software gratuito para download e uso na área de trabalho do Windows. Kusto. Explorer permite consultar e analisar seus dados com Linguagem de Consulta Kusto (KQL) em uma interface amigável. Esta visão geral explica como configurar o Kusto. Explorer e descreve a interface do usuário que você usará.

Com o Kusto.Explorer, você pode:

Instalação do Kusto.Explorer

  • Baixe e instale a ferramenta do Kusto.Explorer usando as seguintes opções:

  • Como alternativa, acesse seu cluster Kusto com um navegador habilitado para ClickOnce em:https://<your_cluster>/?web=0 Substitua <your_cluster> pelo URI do cluster (por exemplo, help.kusto.windows.net.)

Usando o Google Chrome e o Kusto. Explorer

Se o Google Chrome for seu navegador padrão, a instalação da extensão ClickOnce para Chrome será necessária. https://chrome.google.com/webstore/detail/clickonce-for-google-chro/kekahkplibinaibelipdcikofmedafmb/related?hl=en-US

Se o navegador padrão for o Microsoft Edge, a instalação dessa extensão não será necessária. Valide as configurações do ClickOnce nas configurações do sinalizador do Microsoft Edge.

Visão geral da interface do usuário

A interface do usuário do Kusto.Explorer foi projetada com um layout baseado em guias e painéis, semelhante ao de outros produtos da Microsoft:

  • Navegue pelas guias no painel de menus para executar várias operações
  • Gerencie suas conexões no painel de conexões
  • Crie scripts para executar no painel de script
  • Veja os resultados dos scripts no painel de resultados

Captura de tela do Kusto Explorer interface do usuário que mostra uma visão geral dos quatro painéis da interface.

Painel Conexões

Captura de tela do painel Conexões que mostra os bancos de dados do cluster de Ajuda.

O painel Conexões mostra todas as conexões de cluster configuradas. Para cada cluster, são mostrados os bancos de dados, as tabelas e os atributos (colunas) que eles armazenam. Selecione itens (que definam um contexto implícito para a pesquisa/consulta no painel principal) ou clique duas vezes neles para copiar o nome no painel de pesquisa/consulta.

Se o esquema real for grande (como um banco de dados com centenas de tabelas), pressione Ctrl+F e insira uma substring (que não diferencia maiúsculas de minúsculas) do nome da entidade que você está procurando para pesquisar o esquema.

O Kusto.Explorer dá suporte ao controle do painel de conexões na janela de consulta, o que é útil para scripts. Por exemplo, você pode iniciar um arquivo de script com um comando que instrui o Kusto. Explorer se conectar ao cluster/banco de dados que o script consulta usando a seguinte sintaxe:

#connect cluster('help').database('Samples')

StormEvents | count

Execute cada linha usando F5 ou um equivalente.

Painel Documentos de Trabalho

Captura de tela do painel Pastas de Trabalho mostrando o trabalho não salvo e pastas controladas.

O painel Pastas de trabalho organiza suas pastas de trabalho em um só lugar para facilitar a navegação no seu trabalho. Há dois tipos de pastas de trabalho:

  • Trabalho não salvo: lista pastas para guias de consulta abertas nas quais você ainda pode estar trabalhando.
  • Pastas controladas: lista pastas de seu dispositivo local que você pode adicionar como bibliotecas KQL para facilitar o acesso e o gerenciamento.

Guia Página Inicial

Captura de tela da guia Página Inicial que mostra as cinco seções da guia Página Inicial.

A guia Página Inicial mostra as operações mais usadas. Ele inclui:

Seção de consulta

Captura de tela da seção Guia Página Inicial intitulada Guias que mostra uma opção para criar uma nova guia para consultas.

Menu Comportamento
Menu suspenso
  • Modo de consulta: alterna o editor de consultas para um modo de consulta. Os comandos podem ser gravados e salvos como consultas (padrão)
  • Modo de pesquisa: um único modo de consulta em que cada comando inserido é processado imediatamente e apresenta um resultado no painel de resultados
  • Modo de Pesquisa++: permite pesquisar um termo pela sintaxe de pesquisa em uma ou mais tabelas. Saiba mais sobre como usar o Modo Pesquisa++
Nova Guia Abre uma nova guia para consultar Linguagem de Consulta Kusto.

Seção de compartilhamento

Captura de tela da seção Página Inicial intitulada Compartilhar que mostra três opções.

Menu Comportamento
Dados para a Área de Transferência Exporta Consulta e conjunto de dados para uma área de transferência. Se um gráfico for apresentado, ele será exportado como bitmap
Resultado para a Área de Transferência Exporta o conjunto de dados para uma área de transferência. Se um gráfico for apresentado, ele será exportado como bitmap
Consulta para a Área de Transferência Exporta a consulta para uma área de transferência

Seção de visualizações

Captura de tela da seção Página Inicial intitulada Visualizações que mostra as diferentes opções para visualizar dados.

Para visualizações de variáveis, consulte o operador de renderização.

Menu Comportamento
Gráfico de área Exibe um gráfico de área em que o eixo x é a primeira coluna (precisa ser numérica). Todas as colunas numéricas são mapeadas para séries diferentes (eixo y).
Gráfico de Coluna Exibe um gráfico de colunas em que todas as colunas numéricas são mapeadas para séries diferentes (eixo y). A coluna de texto antes do numérico é o eixo X (pode ser controlada na interface do usuário).
Gráfico de Barras Exibe um gráfico de barras em que todas as colunas numéricas são mapeadas para séries diferentes (eixo x). A coluna de texto antes do numérico é o eixo Y (pode ser controlado na interface do usuário).
Gráfico de área empilhada Exibe um gráfico de área empilhado em que o eixo x é a primeira coluna (precisa ser numérica). Todas as colunas numéricas são mapeadas para séries diferentes (eixo y).
Gráfico de Tempo Exibe um gráfico de tempo em que o eixo x é a primeira coluna (precisa ser datetime). Todas as colunas numéricas são mapeadas para séries diferentes (eixo y).
Gráfico de linhas Exibe um gráfico de linhas em que o eixo x é a primeira coluna (precisa ser numérica). Todas as colunas numéricas são mapeadas para séries diferentes (eixo y).
Gráfico de anomalias Semelhante ao Gráfico de Tempo, mas localiza anomalias em dados de série temporal, usando um algoritmo de detecção de anomalias de machine learning. Os dados devem estar em buckets de intervalo fixo. Para a detecção de anomalias, o Kusto.Explorer usa a função series_decompose_anomalies.
Gráfico de pizza Exibe um gráfico de pizza em que o eixo da cor é a primeira coluna. O eixo teta (precisa ser uma medida convertida em porcentagem) é a segunda coluna.
Escada de Tempo Exibe um gráfico de escada em que o eixo x são as duas últimas colunas (precisa ser datetime). O eixo y é uma composição das outras colunas.
Gráfico de dispersão Exibe um gráfico de pontos em que o eixo x é a primeira coluna (precisa ser numérica). Todas as colunas numéricas são mapeadas para séries diferentes (eixo y).
Gráfico Dinâmico Exibe uma tabela dinâmica e um gráfico dinâmico que oferece total flexibilidade para selecionar dados, colunas, linhas e vários tipos de gráfico.
Dinamização de Tempo Navegação interativa pela linha de tempo de eventos (dinamização no eixo de tempo)

Seção de exibição

Captura de tela da seção Página Inicial intitulada Exibição que mostra opções para alterar a exibição de dados.

Menu Comportamento
Modo de Exibição Completa Maximiza o espaço de trabalho ocultando o menu de faixa e o painel de conexões. Saia do Modo de Exibição Completa selecionando Página Inicial>Modo de Exibição Completa ou pressionando F11.
Ocultar Colunas Vazias Remove colunas vazias da grade de dados.
Recolher Colunas Singulares Recolhe colunas com valores singulares.
Explorar Valores de Coluna Mostra a distribuição de valores de coluna
Aumentar Fonte Aumenta o tamanho da fonte da guia de consulta e da grade de dados de resultados.
Diminuir Fonte Diminui o tamanho da fonte da guia de consulta e da grade de dados de resultados.

Observação

Configurações de Exibição de Dados:

o Kusto.Explorer controla quais configurações são usadas por conjunto exclusivo de colunas. Quando as colunas são reordenadas ou removidas, a exibição de dados é salva e será usada novamente sempre que os dados com as mesmas colunas forem recuperados. Para redefinir a exibição para as configurações padrão, selecione Redefinir Exibição na guia Exibição.

Guia Arquivo

Captura de tela da guia Arquivo que mostra as cinco seções da guia Arquivo.

Menu Comportamento
---------Consultar Script---------
Nova Guia Abre uma nova janela de guia para consultar o Kusto.
Abrir arquivo Carrega dados de um arquivo *.kql para o painel de script ativo.
Salvar em Arquivo Salva o conteúdo do painel de script ativo no arquivo *.kql.
Fechar Guia Fecha a janela da guia atual
---------Perfis---------
Importar Perfil Importar um Kusto. Explorer perfil.
Exportar Perfil Exportar um Kusto. Explorer perfil.
---------Salvar Dados---------
Dados para CSV Exporta dados para um arquivo CSV (valores separados por vírgulas).
Dados para JSON Exporta dados para um arquivo formatado em JSON.
Dados para o Excel Exporta dados para um arquivo XLSX (Excel).
Dados para Texto Exporta dados para um arquivo TXT (texto).
Dados para Script KQL Exporta Consulta para um arquivo de script.
Dados para Resultados Exporta consultas e dados para um arquivo de Resultados (QRES).
Executar Consulta em CSV Executa uma consulta e salva os resultados em um arquivo CSV local.
---------Carregar Dados---------
Dos Resultados Carrega a Consulta e os dados de um arquivo de Resultados (QRES).
---------Área de Transferência---------
Consulta e Resultados para a Área de Transferência Exporta Consulta e conjunto de dados para uma área de transferência. Se um gráfico for apresentado, ele exportará o gráfico como um bitmap.
Resultado para a Área de Transferência Exporta o conjunto de dados para uma área de transferência. Se um gráfico for apresentado, ele exportará o gráfico como um bitmap.
Consulta à área de transferência Exporta a Consulta para uma área de transferência.
Resultados para área de transferência (datatable()) Exporta os resultados da consulta para uma área de transferência. O valor máximo permitido da célula é 30000.
---------Resultados---------
Limpar Cache de Resultados Limpa os resultados armazenados em cache de consultas executadas anteriormente.

Guia Conexões

Captura de tela da guia Conexões que mostra as cinco seções da guia Conexão.

Menu Comportamento
---------Grupos---------
Adicionar grupo Adiciona um novo grupo do Servidor Kusto.
---------Clusters---------
Importar Conexões Importa conexões de um arquivo que especifica conexões.
Exportar Conexões Exporta conexões para um arquivo.
Adicionar Conexão Adiciona uma nova conexão do Servidor Kusto.
Editar Conexão Abre uma caixa de diálogo para edição de propriedades de conexão do Servidor Kusto.
Remover Conexão Remove a conexão existente com o Servidor Kusto.
Atualizar Atualiza as propriedades de uma conexão de servidor Kusto.
---------Perfis---------
Importar Perfil Importar um Kusto. Explorer perfil.
Exportar Perfil Exportar um Kusto. Explorer perfil.
---------Segurança---------
Inspecionar Sua Entidade de Segurança do ADD Mostra os detalhes do usuário ativo de correntes.
Sair Desconscreve o usuário atual da conexão com Microsoft Entra ID.
---------Escopo de Dados---------
Escopo do cache
Coluna de datetime Nome de uma coluna que pode ser usada para pré-filtragem de tempo.
Filtro de tempo Valor de tempo pré-filtrado.

Guia Exibir

Captura de tela da guia Exibir que mostra as quatro seções da guia Exibir.

Menu Comportamento
---------Aparência---------
Modo de Exibição Completa Maximiza o espaço de trabalho ocultando o menu de faixa e o painel de conexões. Saia do Modo de Exibição Completa selecionando Página Inicial>Modo de Exibição Completa ou pressionando F11.
Aumentar Fonte Aumenta o tamanho da fonte da guia de consulta e da grade de dados de resultados.
Diminuir Fonte Diminui o tamanho da fonte da guia de consulta e da grade de dados de resultados.
Redefinir Layout Redefine o layout dos controles e janelas de encaixe da ferramenta.
Renomear Guia de Documento Renomeie a guia selecionada.
---------Exibição de Dados---------
Redefinir Exibição Redefine as configurações de exibição de dados para seus padrões.
Explorar Valores de Coluna Mostra a distribuição de valores de coluna.
Foco em Estatísticas de Consulta Altera o foco para consultar estatísticas em vez de consultar os resultados após a conclusão da consulta.
Ocultar Duplicatas Alterna a remoção das linhas duplicadas dos resultados da consulta.
Ocultar Colunas Vazias Remove colunas vazias dos resultados da consulta.
Recolher Colunas Singulares Recolhe colunas com valores singulares.
Seleção de Linha Habilita a seleção de linhas específicas no painel Resultados
Cor por coluna Agrupa registros idênticos na primeira coluna por cor.
Quebra de Texto Automática Formata células para encapsular os dados para ajustar a largura da coluna.
---------Filtro de Dados---------
Filtrar Linhas na Pesquisa Alterna a opção para mostrar apenas linhas correspondentes na pesquisa de resultados da consulta (Ctrl+F).
---------Visualizações---------
Visualizações Confira Visualizações.

Observação

Configurações de Exibição de Dados:

o Kusto.Explorer controla as configurações usadas por conjunto exclusivo de colunas. Quando as colunas são reordenadas ou removidas, a exibição de dados é salva e será usada novamente sempre que os dados com as mesmas colunas forem recuperados. Para redefinir a exibição para as configurações padrão, selecione Redefinir Exibição na guia Exibição.

Guia Ferramentas

Captura de tela da guia Ferramenta que mostra as seis seções da guia Ferramenta.

Menu Comportamento
---------IntelliSense---------
Habilitar o IntelliSense Habilita e desabilita o IntelliSense no Painel de Script.
Lista de problemas Lista os problemas no painel Script.
---------Automação---------
Adicionar Nova Automação Produz um relatório de análise que fornece insights sobre a consulta.
---------Utilitários---------
Ferramentas da linha de comando Abre o prompt de comando no computador.
Compactar arquivo LZ4 Compacta arquivos usando o algoritmo LZ4.
Descompactar o arquivo LZ4 Descompacta arquivos usando o algoritmo LZ4.
---------Analytics---------
Relatórios Analíticos Abre um dashboard com vários relatórios pré-criados para análise de dados.
---------Traduzir---------
Consulta no Power BI Converte uma consulta em um formato adequado para uso no Power BI.
---------Opções---------
Redefinir Opções Define as configurações do aplicativo como valores padrão.
Opções Abre uma ferramenta para definir as configurações do aplicativo. Para saber mais, confira Opções do Kusto.Explorer.

Cores de linha da tabela

O Kusto.Explorer tenta interpretar o nível de gravidade ou de detalhamento de cada linha no painel de resultados e colori-las adequadamente. Ele faz isso correspondendo os valores distintos de cada coluna com um conjunto de padrões conhecidos ("Aviso", "Erro" e assim por diante).

Para modificar o esquema de cores de saída ou desativar esse comportamento, no menu Ferramentas, selecione Opções> Esquema decores verbosity doVisualizador> de Resultados.

Captura de tela da modificação do esquema de cores do Kusto Explorer.

Legenda do esquema de cores do Excel Legenda do esquema de cores Vívido
Captura de tela da legenda do esquema de cores do Excel no kusto Explorer. Captura de tela da legenda do esquema de cores vívidas no kusto Explorer.

Guia Monitoramento

Captura de tela da guia Monitoramento que mostra duas opções para monitorar dados.

Menu Comportamento
---------Monitoramento---------
Diagnóstico de Cluster Mostra um resumo de integridade do Grupo de Servidores atualmente selecionado no Painel de Conexões.
Dados Mais Recentes: Todas as Tabelas Mostra um resumo dos dados mais recentes em todas as tabelas do banco de dados selecionado no momento.
Dados Mais Recentes: Tabela Selecionada Mostra na barra de status os dados mais recentes na tabela selecionada.

Guia Gerenciamento

Captura de tela da guia Gerenciamento que mostra as opções para gerenciar entidades de segurança autorizadas.

Menu Comportamento
---------Entidades de Segurança Autorizadas---------
Gerenciar Entidades de Segurança Autorizadas por Banco de Dados Habilita o gerenciamento de entidades de segurança de um banco de dados para usuários autorizados.
Gerenciar Entidades de Segurança Autorizadas por Tabela Habilita o gerenciamento de entidades de segurança de uma tabela para usuários autorizados.
Gerenciar Entidade de Segurança Autorizada por Função Habilita o gerenciamento de entidades de segurança de uma função para usuários autorizados.

Guia Ajuda

Captura de tela da guia Ajuda que mostra as opções de Documentação.

Menu Comportamento
---------Documentação---------
Ajuda Abre um link para a documentação online do Kusto.
Novidades Abre um documento que lista todos os Kusto. Explorer alterações.
Relatar Problema Abre uma caixa de diálogo com duas opções:
  • Relatar problemas relacionados ao serviço
  • Relatar problemas no aplicativo cliente
.
Atalhos do teclado Abre um link para a lista de atalhos de teclado do Kusto.Explorer.
Mostrar EULA Abre um link para o artigo Informações Legais do Microsoft Azure.

Controlar a identidade do usuário que se conecta ao Kusto.Explorer

O modelo de segurança padrão para novas conexões é Microsoft Entra ID-Federated segurança. A autenticação é feita por meio da ID de Microsoft Entra usando o padrão Microsoft Entra experiência do usuário.

Se precisar de mais controle sobre os parâmetros de autenticação, expanda a caixa de edição "Avançado: Cadeias de Conexão" e forneça um valor válido de cadeia de conexão Kusto.

Por exemplo, os usuários com presença em vários locatários Microsoft Entra às vezes precisam usar uma "projeção" específica de suas identidades para um locatário Microsoft Entra específico, o que pode ser feito por meio do cadeia de conexão (substitua palavras EM MAIÚsculas por valores específicos):

Data Source=https://CLUSTER_NAME.kusto.windows.net;Initial Catalog=DATABASE_NAME;AAD Federated Security=True;Authority Id=AAD_TENANT_OF_CLUSTER;User=USER_DOMAIN
  • AAD_TENANT_OF_CLUSTERé um nome de domínio ou Microsoft Entra ID de locatário (um GUID) do locatário no qual o cluster está hospedado. Por exemplo, contoso.com.
  • USER_DOMAIN é a identidade do usuário convidado para esse locatário (por exemplo, user@example.com).

Observação

O nome de domínio do usuário não é necessariamente o mesmo do locatário que hospeda o cluster.

Captura de tela do painel Adicionar Conexão mostrando a opção intitulada Cadeia de Conexão Avançada.