Instalar a CLI do Azure no Linux

Este artigo explica como instalar a CLI do Azure no Linux. Selecione o gerenciador de pacotes apropriado para sua distribuição nas opções na parte superior da página. É recomendável usar o gerenciador de pacotes de uma distribuição Linux, mas você pode instalar manualmente a CLI do Azure no Linux selecionando a opção Script de instalação.

A versão atual da CLI do Azure é 2.57.0. Para saber mais sobre a versão mais recente, veja as notas de versão. Para localizar a versão instalada e ver se você precisa atualizá-la, execute az version.

Antes de começar

  • A CLI do Azure 2.38.1 (lançada em 01ª de setembro de 2023) é a última versão com suporte no RHEL 7 e Centos 7 e continuará recebendo correções de segurança até o fim da vida útil dos sistemas operacionais. A Microsoft não está fornecendo outras atualizações ou correções de bugs para essas distribuições.

  • A Microsoft continua desenvolvendo e dando suporte à CLI do Azure e ao Script de instalação do Linux.

  • Use o gerenciador de pacotes yum se você estiver usando um sistema Linux que não seja compatível com o gerenciador de pacotes dnf.

Instalar a CLI do Azure.

Para instalar a CLI do Azure, siga estas etapas:

  1. Importe a chave do repositório da Microsoft.

    sudo rpm --import https://packages.microsoft.com/keys/microsoft.asc
    
  2. Para o RHEL 9 ou o CentOS Stream 9, adicione o repositório packages-microsoft-com-prod:

    sudo dnf install -y https://packages.microsoft.com/config/rhel/9.0/packages-microsoft-prod.rpm
    

    Para o RHEL 8 ou o CentOS Stream 8, adicione o repositório packages-microsoft-com-prod:

    sudo dnf install -y https://packages.microsoft.com/config/rhel/8/packages-microsoft-prod.rpm
    

    Para o RHEL 7 ou o CentOS 7, adicione o repositório azure-cli:

    echo -e "[azure-cli]
    name=Azure CLI
    baseurl=https://packages.microsoft.com/yumrepos/azure-cli
    enabled=1
    gpgcheck=1
    gpgkey=https://packages.microsoft.com/keys/microsoft.asc" | sudo tee /etc/yum.repos.d/azure-cli.repo
    
  3. Instale com o comando dnf install.

    sudo dnf install azure-cli
    

Instalar uma versão específica

Você deve primeiro configurar as informações do repositório azure-cli, conforme mostrado anteriormente. As versões disponíveis podem ser encontradas nas Notas sobre a versão da CLI do Azure.

  1. Para exibir as versões disponíveis com o comando:

    dnf list --showduplicates azure-cli
    
  2. Para instalar uma versão específica:

    sudo dnf install azure-cli-<version>-1.el7
    

Atualizar a CLI do Azure

A partir da versão 2.11.0, a CLI do Azure fornece um comando na ferramenta para atualizar para a versão mais recente.

az upgrade

Esse comando também atualiza todas as extensões instaladas por padrão. Para obter mais opções de az upgrade, confira a página de referência do comando. Para versões da CLI do Azure anteriores à 2.11.0, atualize reinstalando conforme descrito em Instalar a CLI do Azure.

Você também pode atualizar a CLI do Azure com o comando dnf update.

sudo dnf update azure-cli

Desinstalar a CLI do Azure

Se você decidir desinstalar a CLI do Azure, lamentamos sua saída. Antes de desinstalar, use o comando az feedback para nos informar sobre o que poderia ser melhorado ou corrigido. Nosso objetivo é deixar a CLI do Azure livre de bugs e amigável ao usuário. Se você encontrou um erro, agradeceríamos se registrasse um problema do GitHub.

  1. Remova o pacote do seu sistema.

    sudo dnf remove azure-cli
    
  2. Se você não pretende reinstalar a CLI, remova as informações do repositório.

    sudo rm /etc/yum.repos.d/azure-cli.repo
    
  3. Se você não usa outros pacotes da Microsoft, remova a chave de assinatura.

    MSFT_KEY=`rpm -qa gpg-pubkey /* --qf "%{version}-%{release} %{summary}\n" | grep Microsoft | awk '{print $1}'`
    sudo rpm -e --allmatches gpg-pubkey-$MSFT_KEY
    

Remover dados

Se você não planeja reinstalar a CLI do Azure, remova os respectivos dados.

rm -rf ~/.azure

Solução de problemas

Aqui estão alguns problemas comuns vistos durante a instalação com dnf. Se você tiver um problema não abordado aqui, arquive um problema no GitHub.

Instalar no RHEL 7.6 ou em outros sistemas sem Python 3

Se puder, atualize seu sistema para uma versão com suporte oficial para o pacote python 3.6+. Caso contrário, primeiro, você precisará instalar um python3 e instalar a CLI do Azure sem nenhuma dependência.

Você pode usar o seguinte comando para baixar e instalar o script de instalação da CLI do Azure com o python 3.6 criado da origem:

curl -sL https://azurecliprod.blob.core.windows.net/rhel7_6_install.sh | sudo bash

Faça isso também passo a passo:

Primeiro, a CLI do Azure exige o SSL 1.1+ e você precisará criar o openssl 1.1 da origem antes de compilar o python3:

sudo dnf install gcc gcc-c++ make ncurses patch wget tar zlib zlib-devel -y
# build openssl from source
cd ~
wget https://www.openssl.org/source/openssl-1.1.1d.tar.gz
tar -xzf openssl-1.1.1d.tar.gz
cd openssl-1.1.1d
./config --prefix=/usr/local/ssl --openssldir=/usr/local/ssl
make
sudo make install
# configure shared object lookup directory so that libssl.so.1.1 can be found
echo "/usr/local/ssl/lib" | sudo tee /etc/ld.so.conf.d/openssl-1.1.1d.conf
# reload config
sudo ldconfig -v

Em seguida, crie o Python 3 da origem:

PYTHON_VERSION="3.6.9"
PYTHON_SRC_DIR=$(mktemp -d)
wget -qO- https://www.python.org/ftp/python/$PYTHON_VERSION/Python-$PYTHON_VERSION.tgz | tar -xz -C "$PYTHON_SRC_DIR"
cd $PYTHON_SRC_DIR/Python-$PYTHON_VERSION
./configure --prefix=/usr --with-openssl=/usr/local/ssl
make
sudo make install

Por fim, siga as etapas 1 e 2 das instruções de instalação para adicionar o repositório da CLI do Azure. Agora, você pode baixar o pacote e instalá-lo sem nenhuma dependência.

Observação

Se o plug-in de download dnf ainda não estiver instalado, você encontrará um erro command not found ao executar o código a seguir. Use dnf install 'dnf-command(download)' para instalar o plug-in de download do dnf.

sudo dnf download azure-cli
sudo rpm -ivh --nodeps azure-cli-*.rpm

Como alternativa, você também pode instalar o Python 3 usando outro repositório. Use esse método se você tiver configurado python3, mas ainda estiver recebendo o erro python3: command not found. Verifique se ele foi incluído no seu caminho.

scl enable rh-python36 bash

Conexão de blocos de proxy

Se você não conseguir se conectar a um recurso externo por causa de um proxy, verifique se as variáveis HTTP_PROXY e HTTPS_PROXY foram definidas corretamente no shell. Você precisa entrar em contato com o administrador do sistema para saber qual(is) host(s) e porta(s) usar nesses proxies.

Os valores nessas variáveis são usados por muitos programas do Linux e durante o processo de instalação. Para definir esses valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Se você estiver atrás de um proxy, as variáveis do shell precisarão ser definidas para se conectarem aos serviços do Azure com a CLI. Se você não estiver usando a autenticação básica, é recomendável exportar as variáveis no arquivo .bashrc. Sempre siga as políticas de segurança da sua empresa e os requisitos do administrador do sistema.

Talvez você queira configurar explicitamente dnf para sempre usar esse proxy. Verifique se as linhas a seguir aparecem na seção [main] de /etc/dnf/dnf.conf:

[main]
# ...
proxy=http://[proxy]:[port] # If your proxy requires https, change http->https
proxy_username=[username] # Only required for basic auth
proxy_password=[password] # Only required for basic auth

Para obter a chave de assinatura da Microsoft e o pacote do nosso repositório, o proxy precisa permitir conexões HTTPS com o seguinte endereço:

  • https://packages.microsoft.com

A CLI não consegue instalar nem ser executada no Subsistema Windows para Linux

Como o Subsistema Windows para Linux (WSL) é uma camada de tradução de chamadas do sistema com base na plataforma Windows, você pode encontrar um erro ao tentar instalar ou executar a CLI do Azure. A CLI depende de alguns recursos que podem apresentar um bug no WSL. Caso encontre um erro independentemente da forma de instalação da CLI, há uma boa chance de ser um problema com o WSL, e não com o processo de instalação da CLI.

Para solucionar os problemas de instalação do WSL e possivelmente resolvê-los:

  • Se possível, execute um processo de instalação idêntico em um computador Linux ou em uma VM para ver se tem êxito. Se isso acontecer, é provável que seu problema esteja relacionado ao WSL. Para iniciar uma VM Linux no Azure, confira a documentação para criar uma VM Linux no portal do Azure.
  • Verifique se você está executando a versão mais recente do WSL. Para obter a versão mais recente, atualize sua instalação do Windows 10.
  • Verifique se há problemas em aberto com o WSL que possam resolver o problema. Frequentemente, há sugestões sobre como contornar o problema ou informações sobre uma versão em que o problema foi corrigido.
  • Se não houver nenhum problema existente seu caso, registre um novo problema no WSL e inclua o máximo de informações possível.

Se continuar ocorrendo problemas de instalação ou execução no WSL, cogite instalar a CLI para Windows.

Antes de começar

  • A CLI 2.38.1 do Azure (lançada em 01 de setembro de 2023) é a versão mais recente com suporte no SUSE Linux Enterprise Server (SLES) e no OpenSUSE (Leap) e continuará a receber correções de segurança até o final de junho de 2024. A Microsoft não está fornecendo outras atualizações ou correções de bugs para essas distribuições.

  • A Microsoft continua desenvolvendo e dando suporte à CLI do Azure e ao Script de instalação do Linux. O SUSE mantém e dá suporte a pacotes fornecidos por repositórios SUSE/OpenSUSE.

  • No Azure, as VMs (máquinas virtuais) do SUSE e do OpenSUSE com base em imagens do Azure Marketplace já têm a CLI do Azure instalada.

Instalar a CLI do Azure.

Para instalar a CLI do Azure no SUSE/OpenSUSE, escolha um dos seguintes métodos:

  1. Use o pacote Enterprise fornecido pelo SUSE nos repositórios SUSE/OpenSUSE.

  2. Use o método de instalação descrito na guia "Instalar script (qualquer um)".

  3. Instalar pelos repositórios da Microsoft

Instalar por meio de repositórios SUSE ou OpenSUSE

O pacote RPM da CLI do Azure depende do pacote python3.

sudo zypper install -y azure-cli

Instalar com o Install-Script

Você pode instalar manualmente a CLI do Azure em qualquer versão do Linux usando a opção Instalar script.

Se você estiver atualizando para a versão mais recente usando esse método, desinstale a versão anterior primeiro e todos os repositórios que você possa ter adicionado para essa versão.

Instalar por meio de repositórios da Microsoft

Para instalar a versão histórica mais recente da CLI do Azure usando repositórios da Microsoft, siga estas etapas.

(Este pacote foi testado com SLES 15 e OpenSUSE Leap 15.1.)

  1. Instale curl:

    sudo zypper install -y curl
    
  2. Importe a chave de repositório da Microsoft:

    sudo rpm --import https://packages.microsoft.com/keys/microsoft.asc
    
  3. Crie informações sobre o repositório do azure-cli local:

    sudo zypper addrepo --name 'Azure CLI' --check https://packages.microsoft.com/yumrepos/azure-cli azure-cli
    
  4. Atualize o índice de pacote do zypper e instale:

    sudo zypper install --from azure-cli azure-cli
    

    Entrada 2 para continuar a instalar, ignorando algumas dependências.

Instalar versão específica

Você deve primeiro configurar as informações do repositório azure-cli, conforme mostrado anteriormente. As versões disponíveis podem ser encontradas nas Notas sobre a versão da CLI do Azure.

  1. Exiba as versões disponíveis usando este comando:

    zypper search --details --match-exact azure-cli
    
  2. Para instalar uma versão específica:

    sudo zypper install --from azure-cli azure-cli=<version>-1.el7
    

Atualizar a CLI do Azure

A partir da versão 2.11.0, a CLI do Azure fornece um comando na ferramenta para atualizar para a versão mais recente.

az upgrade

Esse comando também atualiza todas as extensões instaladas por padrão. Para obter mais opções de az upgrade, confira a página de referência do comando. Para versões da CLI do Azure anteriores à 2.11.0, atualize reinstalando conforme descrito em Instalar a CLI do Azure.

Você também pode atualizar o pacote com o comando zypper update.

sudo zypper refresh
sudo zypper update azure-cli

Desinstalar a CLI do Azure

Se você decidir desinstalar a CLI do Azure, lamentamos sua saída. Antes de desinstalar, use o comando az feedback para nos informar sobre o que poderia ser melhorado ou corrigido. Nosso objetivo é deixar a CLI do Azure livre de bugs e amigável ao usuário. Se você encontrou um erro, agradeceríamos se registrasse um problema do GitHub.

  1. Remova o pacote do seu sistema.

    sudo zypper remove -y azure-cli
    
  2. Se você não pretende reinstalar a CLI, remova as informações do repositório.

    sudo zypper removerepo azure-cli
    
  3. Se você não usa outros pacotes da Microsoft, remova a chave de assinatura da Microsoft.

    MSFT_KEY=`rpm -qa gpg-pubkey /* --qf "%{version}-%{release} %{summary}\n" | grep Microsoft | awk '{print $1}'`
    sudo rpm -e --allmatches gpg-pubkey-$MSFT_KEY
    

Remover dados

Se você não planeja reinstalar a CLI do Azure, remova os respectivos dados.

rm -rf ~/.azure

Solução de problemas

Aqui estão alguns problemas comuns vistos durante a instalação com zypper. Se você tiver um problema não abordado aqui, arquive um problema no GitHub.

Instalar sem o Python 3

Importante

O pacote RPM da CLI do Azure depende do pacote python3. Em seu sistema, isso pode ser uma versão do Python que antecede o requisito do Python 3.6.x. Se isso afeta você, localize um pacote python3 de substituição.

Lembre-se de que o Python 2 foi retirado do mercado em 1º de janeiro de 2020 e não receberá mais atualizações. A CLI do Azure não é mais compatível com o Python 2.7 desde a versão 2.1.0. As versões mais recentes da CLI podem não funcionar corretamente usando o Python 2.7.

NotImplementedError na VM do OpenSUSE 15

A VM do OpenSUSE 15 tem uma CLI do Azure pré-instalada com a versão 2.0.45, que está desatualizada e apresenta problemas com az login. Remova essa versão junto com as dependências antes de seguir as instruções de Instalação para adicionar a última CLI do Azure:

sudo zypper rm -y --clean-deps azure-cli

Se você atualizou a CLI do Azure sem remover as dependências da versão 2.0.45, as dependências antigas podem afetar a última versão da CLI do Azure. Você precisará adicionar novamente a versão antiga para vinculá-la às dependências e remover a azure-cli junto com as dependências:

# The package name may vary on different system version, run 'zypper --no-refresh info azure-cli' to check the source package format
sudo zypper install --oldpackage azure-cli-2.0.45-4.22.noarch

sudo zypper rm -y --clean-deps azure-cli

Instalar no SLES 12 ou em sistemas sem o Python 3.6

No SLES 12, o pacote python3 padrão é 3.4 e não é compatível com a CLI do Azure. Primeiro, siga as etapas 1 a 3 das instruções de instalação para adicionar o repositório da azure-cli. Em seguida, crie uma versão posterior do python3 da origem. Por fim, você poderá baixar o pacote da CLI do Azure e instalá-lo sem nenhuma dependência.

Use o comando a seguir para instalar ou atualizar a CLI do Azure de acordo com as etapas acima. O script instalará o Python 3.8 em /usr/local/azcli e fará com que a CLI do Azure o use definindo um alias igual de az para PATH=/usr/local/azcli/bin:$PATH az. Baixe também o script e modifique-o de acordo com suas necessidades. Por exemplo, você pode alterar o local de instalação ou a versão do Python.

curl -sL https://azurecliprod.blob.core.windows.net/sles12_install_v2.sh | sudo bash

Ao instalá-lo pela primeira vez, lembre-se de executar o seguinte comando para ativar o alias:

source ~/.bashrc

Conexão de blocos de proxy

Se você não conseguir se conectar a um recurso externo por causa de um proxy, verifique se as variáveis HTTP_PROXY e HTTPS_PROXY foram definidas corretamente no shell. Você precisa entrar em contato com o administrador do sistema para saber qual(is) host(s) e porta(s) usar nesses proxies.

Os valores nessas variáveis são usados por muitos programas do Linux e durante o processo de instalação. Para definir esses valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Se você estiver atrás de um proxy, as variáveis do shell precisarão ser definidas para se conectarem aos serviços do Azure com a CLI. Se você não estiver usando a autenticação básica, é recomendável exportar as variáveis no arquivo .bashrc. Sempre siga as políticas de segurança da sua empresa e os requisitos do administrador do sistema.

Talvez você queira configurar explicitamente zypper (por meio de yast2) para sempre usar esse proxy. Para fazer isso, execute o comando yast2 proxy como superusuário e preencha as informações apresentadas no formulário. Se você tiver um gerenciador de janelas disponível no sistema, também poderá usar o painel Network Services > Proxy no YaST Control Center.

Para configurações avançadas ou mais informações, confira a documentação de configuração do Proxy do OpenSUSE

Para obter a chave de assinatura da Microsoft e o pacote do nosso repositório, o proxy precisa permitir conexões HTTPS com os seguintes endereços:

  • https://packages.microsoft.com
  • https://download.opensuse.org

A CLI não consegue instalar nem ser executada no Subsistema Windows para Linux

Como o Subsistema Windows para Linux (WSL) é uma camada de tradução de chamadas do sistema com base na plataforma Windows, você pode encontrar um erro ao tentar instalar ou executar a CLI do Azure. A CLI depende de alguns recursos que podem apresentar um bug no WSL. Caso encontre um erro independentemente da forma de instalação da CLI, há uma boa chance de ser um problema com o WSL, e não com o processo de instalação da CLI.

Para solucionar os problemas de instalação do WSL e possivelmente resolvê-los:

  • Se possível, execute um processo de instalação idêntico em um computador Linux ou em uma VM para ver se tem êxito. Se isso acontecer, é provável que seu problema esteja relacionado ao WSL. Para iniciar uma VM Linux no Azure, confira a documentação para criar uma VM Linux no portal do Azure.
  • Verifique se você está executando a versão mais recente do WSL. Para obter a versão mais recente, atualize sua instalação do Windows 10.
  • Verifique se há problemas em aberto com o WSL que possam resolver o problema. Frequentemente, há sugestões sobre como contornar o problema ou informações sobre uma versão em que o problema foi corrigido.
  • Se não houver nenhum problema existente seu caso, registre um novo problema no WSL e inclua o máximo de informações possível.

Se continuar ocorrendo problemas de instalação ou execução no WSL, cogite instalar a CLI para Windows.

Problema com o certificado SSL

Quando um certificado é inválido ou está desatualizado em um computador, você pode receber um erro indicando que o cURL falhou ao verificar a legitimidade do servidor e, portanto, não foi possível estabelecer uma conexão segura. Atualize o certificado para corrigir o problema.

sudo zypper update-ca-certificates

Antes de começar

  • O gerenciador de pacotes apt contém pacotes x86_64 e ARM64 para a CLI do Azure que foi testado nas distribuições a seguir.

    Distribuição Versão
    Ubuntu 20.04 LTS (Focal Fossa), 22.04 (Jammy Jellyfish)
    Debian 10 (Buster), 11 (Bullseye), 12 (Bookworm)
  • Ubuntu 20.04 (Focal Fossa) e 20.10 (Groovy Gorilla) incluem um pacote azure-cli com a versão 2.0.81 fornecido pelo repositório universe. Esse pacote está desatualizado e não é recomendado. Se esse pacote estiver instalado, remova-o antes de continuar executando o comando sudo apt remove azure-cli -y && sudo apt autoremove -y. Para obter mais informações sobre apt remove, consulte o gerenciamento de pacotes do Ubuntu ou o Ask Ubuntu.

Instalar a CLI do Azure.

Há duas formas de instalar a CLI do Azure no seu sistema. Você pode baixar um script de instalação que executará os comandos de instalação para você ou pode executar os comandos de instalação por conta própria em etapas. Os dois métodos são apresentados abaixo:

Opção 1: Instalar com um comando

A maneira mais fácil de instalar a CLI do Azure é por meio de um script mantido pela equipe da CLI do Azure. Esse script executa todos os comandos de instalação em uma única etapa. Esse script é baixado por meio de curl e encaminhado diretamente para bash a fim de instalar a CLI.

Se você quiser inspecionar o conteúdo do script por conta própria antes de executá-lo, basta baixar o script primeiro usando curl e inspecioná-lo no seu editor de texto favorito.

curl -sL https://aka.ms/InstallAzureCLIDeb | sudo bash

Opção 2: Instruções de instalação passo a passo

Se você preferir um processo de instalação passo a passo, conclua as etapas a seguir para instalar a CLI do Azure.

  1. Obtenha os pacotes necessários para o processo de instalação:

    sudo apt-get update
    sudo apt-get install ca-certificates curl apt-transport-https lsb-release gnupg
    
  2. Baixe e instale a chave de autenticação da Microsoft:

    sudo mkdir -p /etc/apt/keyrings
    curl -sLS https://packages.microsoft.com/keys/microsoft.asc |
        gpg --dearmor |
        sudo tee /etc/apt/keyrings/microsoft.gpg > /dev/null
    sudo chmod go+r /etc/apt/keyrings/microsoft.gpg
    
  3. Adicionar o repositório de software da CLI do Azure:
    AZ_DIST=$(lsb_release -cs)
    echo "deb [arch=`dpkg --print-architecture` signed-by=/etc/apt/keyrings/microsoft.gpg] https://packages.microsoft.com/repos/azure-cli/ $AZ_DIST main" |
        sudo tee /etc/apt/sources.list.d/azure-cli.list
    
  4. Atualize as informações do repositório e instale o pacote azure-cli:

    sudo apt-get update
    sudo apt-get install azure-cli
    

Instalar uma versão específica

Configure as informações do repositório azure-cli, conforme mostrado anteriormente. As versões disponíveis podem ser encontradas nas Notas sobre a versão da CLI do Azure.

  1. Exiba as versões disponíveis da CLI do Azure.

    apt-cache policy azure-cli
    
  2. Para instalar uma versão específica.

    # Obtain the currently installed distribution
    AZ_DIST=$(lsb_release -cs)
    
    # Store an Azure CLI version of choice
    AZ_VER=2.51.0
    
    # Install a specific version
    sudo apt-get install azure-cli=$AZ_VER-1~$AZ_DIST
    

    Para instalar uma versão específica sem variáveis, substitua a versão da CLI do Azure e o nome de distribuição do Linux mostrados:

    sudo apt-get install azure-cli=2.51.0-1~bullseye
    

Se você receber uma mensagem de erro Não é possível localizar o pacote azure-cli, as informações do repositório azure-cli não estão configuradas. Siga as etapas fornecidas na Opção 2: instruções de instalação passo a passo.

Se você receber uma mensagem de erro A versão x.xx.x-1~distributionName para a azure-cli não foi encontrada, use lsb_release -cs para localizar a distribuição que você está executando.

Atualizar a CLI do Azure

A partir da versão 2.11.0, a CLI do Azure fornece um comando na ferramenta para atualizar para a versão mais recente.

az upgrade

Esse comando também atualiza todas as extensões instaladas por padrão. Para obter mais opções de az upgrade, confira a página de referência do comando. Para versões da CLI do Azure anteriores à 2.11.0, atualize reinstalando conforme descrito em Instalar a CLI do Azure.

Você também pode usar apt-get upgrade para atualizar o pacote da CLI. Esse comando atualiza todos os pacotes instalados no sistema que não tiveram uma alteração de dependência.

sudo apt-get update && sudo apt-get upgrade

Para atualizar apenas a CLI, use apt-get install.

sudo apt-get update && sudo apt-get install --only-upgrade -y azure-cli

Desinstalar a CLI do Azure

Se você decidir desinstalar a CLI do Azure, lamentamos sua saída. Antes de desinstalar, use o comando az feedback para nos informar sobre o que poderia ser melhorado ou corrigido. Nosso objetivo é deixar a CLI do Azure livre de bugs e amigável ao usuário. Se você encontrou um erro, agradeceríamos se registrasse um problema do GitHub.

  1. Desinstalar com apt-get remove:

    sudo apt-get remove -y azure-cli
    
  2. Se você não pretender reinstalar a CLI, remova as informações do repositório da CLI do Azure:

    sudo rm /etc/apt/sources.list.d/azure-cli.list
    
  3. Se você não estiver usando nenhum outro pacote da Microsoft, remova a chave de assinatura:

    sudo rm /etc/apt/trusted.gpg.d/microsoft.gpg
    
  4. Remova quaisquer pacotes desnecessários:

    sudo apt autoremove
    

Remover dados

Se você não planeja reinstalar a CLI do Azure, remova os respectivos dados.

rm -rf ~/.azure

Solução de problemas

Aqui estão alguns problemas comuns vistos durante a instalação com apt. Se você tiver um problema não abordado aqui, arquive um problema no GitHub.

O pacote azure-cli é compatível com a arquitetura ARM64 a partir da versão 2.46.0 da CLI.

Nenhum problema com o módulo no Ubuntu 20.04 (Focal)/WSL

Se você tiver instalado azure-cli em Focal sem adicionar o repositório de software da CLI do Azure na etapa 3 das instruções de instalação manual ou sem usar nosso script, poderá encontrar problemas indicando, por exemplo, que não há nenhum módulo chamado "decorator" ou "antlr4", já que o pacote instalado é o azure-cli 2.0.81 desatualizado do repositório focal/universe. Remova-a primeiro executando sudo apt remove azure-cli -y && sudo apt autoremove -y e, em seguida, siga as instruções acima para instalar o pacote azure-cli mais recente.

lsb_release não retorna a versão correta da distribuição de base

Algumas distribuições do Ubuntu ou derivadas do Debian (como o Linux Mint) podem não retornar o nome correto da versão de lsb_release. Esse valor é usado no processo de instalação para determinar o pacote de instalação. Se você souber o nome do código da versão do Ubuntu ou do Debian da qual sua distribuição é derivada, poderá definir o valor de AZ_REPO manualmente ao adicionar o repositório. Caso contrário, procure informações para sua distribuição sobre como determinar o nome do código da distribuição de base e defina AZ_REPO com o valor correto.

Nenhum pacote para distribuição

Às vezes, um pacote atualizado da CLI do Azure não está disponível imediatamente após uma versão de distribuição. A CLI do Azure é projetada para ser resiliente em relação a versões futuras de dependências e faz uso da menor quantidade possível delas. Se não houver pacotes disponíveis para sua distribuição de base, tente um pacote de uma distribuição anterior.

Para experimentar um pacote para uma distribuição anterior, defina o valor de AZ_REPO manualmente ao adicionar o repositório. Para as distribuições do Ubuntu, use o repositório jammy mais recente:

AZ_REPO="jammy"

Para as distribuições do Debian, use o repositório bookworm mais recente:

AZ_REPO="bookworm"

Importante

Não há suporte para as distribuições lançadas antes do Ubuntu Bionic e do Debian Buster.

O EOS (SO elementar) falha ao instalar a CLI do Azure

O EOS não consegue instalar a CLI do Azure porque lsb_release retorna HERA, que é o nome da versão de EOS. A solução é corrigir o arquivo /etc/apt/sources.list.d/azure-cli.list e alterar hera main para bionic main.

Conteúdo do arquivo original:

deb [arch=amd64] https://packages.microsoft.com/repos/azure-cli/ hera main

Conteúdo do arquivo modificado

deb [arch=amd64] https://packages.microsoft.com/repos/azure-cli/ bionic main

Conexão de blocos de proxy

Se você não conseguir se conectar a um recurso externo por causa de um proxy, verifique se as variáveis HTTP_PROXY e HTTPS_PROXY foram definidas corretamente no shell. Você precisa entrar em contato com o administrador do sistema para saber qual(is) host(s) e porta(s) usar nesses proxies.

Os valores nessas variáveis são usados por muitos programas do Linux e durante o processo de instalação. Para definir esses valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Se você estiver atrás de um proxy, as variáveis do shell precisarão ser definidas para se conectarem aos serviços do Azure com a CLI. Se você não estiver usando a autenticação básica, é recomendável exportar as variáveis no arquivo .bashrc. Sempre siga as políticas de segurança da sua empresa e os requisitos do administrador do sistema.

Talvez você queira configurar explicitamente apt para sempre usar esse proxy. Verifique se as linhas a seguir aparecem em um arquivo de configuração apt em /etc/apt/apt.conf.d/. É recomendável usar o arquivo de configuração global existente, um arquivo de configuração de proxy existente, 40proxies ou 99local. No entanto, siga os requisitos de administração do sistema.

Acquire {
    http::proxy "http://[username]:[password]@[proxy]:[port]";
    https::proxy "https://[username]:[password]@[proxy]:[port]";
}

Se o proxy não usar autenticação básica, remova a parte [username]:[password]@ do URI do proxy. Se você precisar de mais informações sobre a configuração do proxy, confira a documentação oficial do Ubuntu:

Para obter a chave de assinatura da Microsoft e o pacote do nosso repositório, o proxy precisa permitir conexões HTTPS com o seguinte endereço: `https://packages.microsoft.com.

A CLI não consegue instalar nem ser executada no Subsistema Windows para Linux

Como o Subsistema Windows para Linux (WSL) é uma camada de tradução de chamadas do sistema com base na plataforma Windows, você pode encontrar um erro ao tentar instalar ou executar a CLI do Azure. A CLI depende de alguns recursos que podem apresentar um bug no WSL. Caso encontre um erro independentemente da forma de instalação da CLI, há uma boa chance de ser um problema com o WSL, e não com o processo de instalação da CLI.

Para solucionar os problemas de instalação do WSL e possivelmente resolvê-los:

  • Se possível, execute um processo de instalação idêntico em um computador Linux ou em uma VM para ver se tem êxito. Se isso acontecer, é provável que seu problema esteja relacionado ao WSL. Para iniciar uma VM Linux no Azure, confira a documentação para criar uma VM Linux no portal do Azure.
  • Verifique se você está executando a versão mais recente do WSL. Para obter a versão mais recente, atualize sua instalação do Windows 10.
  • Verifique se há problemas em aberto com o WSL que possam resolver o problema. Frequentemente, há sugestões sobre como contornar o problema ou informações sobre uma versão em que o problema foi corrigido.
  • Se não houver nenhum problema existente seu caso, registre um novo problema no WSL e inclua o máximo de informações possível.

Se continuar ocorrendo problemas de instalação ou execução no WSL, cogite instalar a CLI para Windows.

Instalar a CLI do Azure.

Os RPMs são lançados para o Azure Linux por meio do CBL-Mariner. O pacote azure-cli é compatível com a arquitetura ARM64 a partir da versão 2.46.0 da CLI.

Para instalar a CLI do Azure, siga estas etapas:

  1. Instale o conjunto oficial coletado pela Microsoft de certificados raiz confiáveis:

    sudo tdnf install ca-certificates
    
  2. Instalar a CLI do Azure:

    sudo tdnf install azure-cli
    

Instalar uma versão específica

As versões disponíveis podem ser encontradas nas Notas sobre a versão da CLI do Azure.

Para exibir as versões disponíveis com o comando:

tdnf list azure-cli

Para instalar a versão específica:

sudo tdnf install azure-cli-<version>-1

Atualizar a CLI do Azure

Atualizar a CLI do Azure com o comando tdnf update:

sudo tdnf update azure-cli

Desinstalar a CLI do Azure

Se você decidir desinstalar a CLI do Azure, lamentamos sua saída. Antes de desinstalar, use o comando az feedback para nos informar sobre o que poderia ser melhorado ou corrigido. Nosso objetivo é deixar a CLI do Azure livre de bugs e amigável ao usuário. Se você encontrou um erro, agradeceríamos se registrasse um problema do GitHub.

Remover o pacote do seu sistema:

sudo tdnf remove azure-cli

Remover dados

Se você não planeja reinstalar a CLI do Azure, remova os respectivos dados.

rm -rf ~/.azure

Antes de começar

É altamente recomendável instalar a CLI com um gerenciador de pacotes. Um gerenciador de pacotes garante que você sempre obtenha as atualizações mais recentes, além da estabilidade dos componentes da CLI. Verifique e veja se há um pacote de distribuição antes de instalar manualmente.

A CLI requer o seguinte software:

Instale ou atualize a CLI do Azure

Para instalar e atualizar a CLI do Azure é preciso executar novamente o script de instalação.

curl -L https://aka.ms/InstallAzureCli | bash

O script também pode ser baixado e executado localmente. Talvez você precise reiniciar o shell para que as alterações entrem em vigor.

Desinstalar a CLI do Azure

Se você decidir desinstalar a CLI do Azure, lamentamos sua saída. Antes de desinstalar, use o comando az feedback para nos informar sobre o que poderia ser melhorado ou corrigido. Nosso objetivo é deixar a CLI do Azure livre de bugs e amigável ao usuário. Se você encontrou um erro, agradeceríamos se registrasse um problema do GitHub.

Desinstale a CLI excluindo diretamente os arquivos do local escolhido no momento da instalação. O local de instalação padrão é o diretório base do usuário ($HOME).

  1. Remova os arquivos da CLI instalados.

    rm -r <install location>/lib/azure-cli
    rm <install location>/bin/az
    
  2. Modifique o arquivo $HOME/.bash_profile para remover a seguinte linha:

    <install location>/lib/azure-cli/az.completion
    
  3. Se usar bash ou zsh, recarregue o cache de comando do shell.

    hash -r
    

Remover dados

Se você não planeja reinstalar a CLI do Azure, remova os respectivos dados.

rm -rf ~/.azure

Solução de problemas

Aqui estão alguns problemas comuns observados durante uma instalação manual. Se você tiver um problema não abordado aqui, arquive um problema no GitHub.

Instalar sem o Python 3

A CLI do Azure não é mais compatível com o Python 2.7 desde a versão 2.1.0. Em seu sistema, pode haver uma versão do Python anterior ao Python 3.6.x. Encontre um pacote de substituição python3.

Erro "Objeto movido" de cURL

Se você receber um erro de curl relacionado ao parâmetro -L ou uma mensagem de erro incluindo o texto "Objeto movido", tente usar a URL completa em vez da aka.ms de redirecionamento:

curl https://azurecliprod.blob.core.windows.net/install | bash

az comando não encontrado

Se você não puder executar o comando após a instalação usando bash ou zsh, tente limpar o cache de hash de comando do shell e verifique se o problema foi resolvido.

hash -r

O problema também pode ocorrer se você não reiniciou o shell após a instalação. Verifique se o local do comando az está no $PATH. A localização do comando az é

 <install path>/bin

Conexão de blocos de proxy

Se você não conseguir se conectar a um recurso externo por causa de um proxy, verifique se as variáveis HTTP_PROXY e HTTPS_PROXY foram definidas corretamente no shell. Você precisa entrar em contato com o administrador do sistema para saber qual(is) host(s) e porta(s) usar nesses proxies.

Os valores nessas variáveis são usados por muitos programas do Linux e durante o processo de instalação. Para definir esses valores:

# No auth
export HTTP_PROXY=http://[proxy]:[port]
export HTTPS_PROXY=https://[proxy]:[port]

# Basic auth
export HTTP_PROXY=http://[username]:[password]@[proxy]:[port]
export HTTPS_PROXY=https://[username]:[password]@[proxy]:[port]

Importante

Se você estiver atrás de um proxy, as variáveis do shell precisarão ser definidas para se conectarem aos serviços do Azure com a CLI. Se você não estiver usando a autenticação básica, é recomendável exportar as variáveis no arquivo .bashrc. Sempre siga as políticas de segurança da sua empresa e os requisitos do administrador do sistema.

Para obter os scripts de instalação, o proxy precisa permitir conexões HTTPS com os seguintes endereços:

  • https://aka.ms/
  • https://azurecliprod.blob.core.windows.net/
  • https://pypi.python.org
  • Pontos de extremidade usados pelo gerenciador de pacotes da distribuição (se houver) para pacotes essenciais

A CLI não consegue instalar nem ser executada no Subsistema Windows para Linux

Como o Subsistema Windows para Linux (WSL) é uma camada de tradução de chamadas do sistema com base na plataforma Windows, você pode encontrar um erro ao tentar instalar ou executar a CLI do Azure. A CLI depende de alguns recursos que podem apresentar um bug no WSL. Caso encontre um erro independentemente da forma de instalação da CLI, há uma boa chance de ser um problema com o WSL, e não com o processo de instalação da CLI.

Para solucionar os problemas de instalação do WSL e possivelmente resolvê-los:

  • Se possível, execute um processo de instalação idêntico em um computador Linux ou em uma VM para ver se tem êxito. Se isso acontecer, é provável que seu problema esteja relacionado ao WSL. Para iniciar uma VM Linux no Azure, confira a documentação para criar uma VM Linux no portal do Azure.
  • Verifique se você está executando a versão mais recente do WSL. Para obter a versão mais recente, atualize sua instalação do Windows 10.
  • Verifique se há problemas em aberto com o WSL que possam resolver o problema. Frequentemente, há sugestões sobre como contornar o problema ou informações sobre uma versão em que o problema foi corrigido.
  • Se não houver nenhum problema existente seu caso, registre um novo problema no WSL e inclua o máximo de informações possível.

Se continuar ocorrendo problemas de instalação ou execução no WSL, cogite instalar a CLI para Windows.

Próximas etapas

Agora que você instalou a CLI do Azure, faça um tour breve de seus recursos e comandos comuns.