Problemas de conexão do Outlook com as caixas de correio do Exchange causados pelo requisito de criptografia RPC

Número original do KB: 3032395

O artigo só se aplica a problemas de conexão do Microsoft Outlook que são causados pelo requisito de criptografia RPC.

Captura de tela sobre a opção de criptografia R P C.

Sintomas

Quando você inicia o Microsoft Office Outlook usando um perfil que inclui uma caixa de correio em um servidor que está executando o Microsoft Exchange Server 2010, o Exchange Server 2013 ou o Exchange Server 2016, você pode receber as seguintes mensagens de erro:

Não é possível iniciar o Microsoft Office Outlook. Não é possível abrir a janela do Outlook. O conjunto de pastas não pôde ser aberto.

Não é possível abrir as pastas de email padrão. O computador do Microsoft Exchange Server não está disponível. Pode haver problemas de rede ou o computador do Microsoft Exchange Server está desligado para manutenção.

A conexão com o Microsoft Exchange Server não está disponível. O Outlook deve estar online ou conectado para concluir essa ação.

Não é possível abrir as pastas de email padrão. O repositório de informações não pôde ser aberto.

O Outlook não pôde fazer logon. Verifique se você está conectado à rede e está usando o nome apropriado de servidor e da caixa de correio. A conexão com o Microsoft Exchange Server não está disponível. O Outlook deve estar online ou conectado para concluir essa ação.

No entanto, se você estiver usando um perfil de modo em cache, o Outlook não exibirá um erro. Você poderá notar os seguintes sintomas:

  • O Outlook inicia no estado Desconectado (o canto inferior direito das janelas do Outlook exibe "Desconectado", a captura de tela para o estado é mostrada abaixo).

    Captura de tela do erro no canto inferior direito da janela do Outlook.

  • O Outlook inicia e você pode enviar e receber mensagens de email. No entanto, você só vê duas conexões no "Status da Conexão do Microsoft Exchange" e pode ver o Diretório de Tipos exibido como Desconectado/Conectando.

    Captura de tela desse sintoma.

Ao tentar criar um novo perfil do Outlook para uma caixa de correio em um servidor que está executando o Exchange 2010 ou o Exchange Server 2013, você pode receber as seguintes mensagens de erro:

Não foi possível concluir a ação. A conexão com o Microsoft Exchange Server não está disponível. O Outlook deve estar online ou conectado para concluir essa ação.

Não foi possível resolver o nome. A conexão com o Microsoft Exchange Server não está disponível. O Outlook deve estar online ou conectado para concluir essa ação.

O Outlook não pôde fazer logon. Verifique se você está conectado à rede e está usando o nome apropriado de servidor e da caixa de correio. A conexão com o Microsoft Exchange Server não está disponível. O Outlook deve estar online ou conectado para concluir essa ação.

Não foi possível resolver o nome. Não foi possível concluir a ação.

Seus nomes de Servidor ou Caixa de Correio não puderam ser resolvidos.

Resolução

Observação

Se você estiver usando um dos métodos automatizados (Política de Grupo ou um arquivo .prf), certifique-se de testar totalmente o método antes de implantá-lo em grande escala.

Método 1: atualizar ou criar o perfil do Outlook com criptografia RPC

Atualizar manualmente um perfil existente

Para atualizar manualmente um perfil do Outlook existente para que ele use criptografia RPC, siga estas etapas:

  1. No Painel de Controle, abra o item Email.

  2. Selecione Mostrar Perfis.

  3. Selecione seu perfil e clique em Propriedades.

  4. Selecione Contas de Email.

  5. Selecione a conta Microsoft Exchange (enviar desta conta por padrão)>Alterar.

  6. Na caixa de diálogo que contém seu servidor de caixa de correio e nome de usuário, selecione Mais Configurações.

  7. Na caixa de diálogo Microsoft Exchange, selecione a guia Segurança.

  8. Selecione Criptografar dados entre o Microsoft Office Outlook e o Microsoft Exchange>OK Uma captura de tela para esta etapa pode ser vista aqui).

    Captura de tela com a opção Criptografar dados entre o Microsoft Office Outlook e o Microsoft Exchange selecionada.

  9. Selecione Avançar>Concluir.

  10. Selecione Fechar>Fechar>OK.

Implantar uma configuração de Política de Grupo para atualizar perfis do Outlook existentes com criptografia RPC

Da perspectiva do cliente, a implantação da configuração de criptografia Outlook-Exchange é provavelmente a solução mais simples para organizações que têm muitos clientes do Outlook. Essa solução envolve uma única alteração em um servidor (controlador de domínio) e seus clientes são atualizados automaticamente depois que a política é baixada para o cliente.

Outlook 2010

Por padrão, a configuração de criptografia RPC está habilitada Outlook 2010. Portanto, você só deve implantar essa configuração usando a Política de Grupo por um dos seguintes motivos:

  • Sua implantação do Outlook 2010 original desabilitou a criptografia RPC entre Outlook e Exchange.
  • Você deseja impedir que os usuários mudem a configuração de criptografia RPC em seu perfil do Outlook.

O modelo de Política de Grupo padrão para o Outlook 2010 contém a configuração de Política de Grupo que controla a criptografia RPC Outlook-Exchange. Para atualizar perfis existentes do Outlook 2010 usando a Política de Grupo, siga estas etapas:

  1. Baixe a versão mais recente do modelo de Política de Grupo Outlk14.adm.

  2. Adicione o arquivo .adm ao controlador de domínio.

    Observação

    As etapas para adicionar o arquivo .adm a um controlador de domínio variam de acordo com a versão do Windows que você está executando. Além disso, como você pode estar aplicando a política a uma unidade organizacional e não ao domínio, as etapas também podem variar para esse aspecto de aplicação de uma política. Portanto, verifique sua documentação do Windows para obter informações detalhadas.

    Vá para a etapa 3 depois de adicionar o modelo .adm ao Editor de Política de Grupo Local.

  3. Em Configuração do Usuário, expanda Modelos Administrativos (ADM) para localizar o nó de política do modelo. Usando o modelo Outlk14.adm, esse nó será nomeado Microsoft Outlook 2010.

  4. Em Configurações da Conta, selecione o nó Exchange (Uma captura de tela para esta etapa pode ser vista aqui).

    Captura de tela com o nó do Exchange no Outlook 2010 selecionado.

  5. Clique duas vezes na configuração de política Habilitar criptografia RPC.

  6. Na guia Configuração, selecione Ativado.

  7. Selecione OK.

Nesse ponto, a configuração da política será aplicada em suas estações de trabalho de cliente Outlook quando a atualização da Política de Grupo for replicada. Para testar essa alteração, execute o seguinte comando:

 gpupdate /force

Depois de executar esse comando, inicie o Editor do Registro na estação de trabalho para garantir que os seguintes dados do Registro existam no cliente:

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\RPC
DWORD: EnableRPCEncryption
Value: 1

Se você vir esses dados do Registro no Registro, a configuração da Política de Grupo será aplicada a esse cliente. Inicie o Outlook para verificar se a alteração resolve o problema.

Outlook 2013

Por padrão, a configuração de criptografia RPC está habilitada no Outlook 2013. Portanto, você só deve implantar essa configuração usando a Política de Grupo por um dos seguintes motivos:

  • Sua implantação do Outlook 2013 original desabilitou a criptografia RPC entre o Outlook e o Exchange.
  • Você deseja impedir que os usuários mudem a configuração de criptografia RPC em seu perfil do Outlook.

O modelo de Política de Grupo padrão para o Outlook 2013 contém a configuração de Política de Grupo que controla a criptografia RPC do Outlook-Exchange. Para atualizar os perfis do Outlook 2013 existentes usando a Política de Grupo, siga estas etapas:

  1. Baixe os modelos ADM do Office 2013.

  2. Adicione os arquivos .admx e .adml ao controlador de domínio. Isso adiciona o modelo ADM do Outlook para torná-lo disponível no Editor de Política de Grupo Local.

    Observação

    As etapas para adicionar os arquivos .admx e adml a um controlador de domínio variam de acordo com a versão do Windows que você está executando. Além disso, como você pode estar aplicando a política a uma unidade organizacional e não ao domínio, as etapas também podem variar para esse aspecto do aplicativo de política. Portanto, verifique sua documentação do Windows para obter informações detalhadas. (Este artigo é rotulado para o Office 2010. No entanto, isso também se aplica ao Office 2013.)

  3. Abra o Editor de Política de Grupo Local.

  4. Em Configuração do Usuário, expanda Modelos Administrativos (ADM) para localizar o nó de política do modelo. Quando você usar o modelo Outlk15.admx, esse nó será nomeado Microsoft Outlook 2013.

  5. Em Configurações da Conta, selecione o nó Exchange (Uma captura de tela para esta etapa pode ser vista aqui).

    Captura de tela com o nó do Exchange no Outlook 2013 selecionado.

  6. Clique duas vezes na configuração de política Habilitar criptografia RPC.

  7. Na guia Configuração, selecione Ativado.

  8. Selecione OK.

Nesse ponto, a configuração da política será aplicada em suas estações de trabalho de cliente Outlook quando a atualização da Política de Grupo for replicada. Para testar essa alteração, execute o seguinte comando em uma estação de trabalho:

 gpupdate /force

Depois de executar esse comando, inicie o Editor do Registro na estação de trabalho para garantir que os seguintes dados do Registro existam no cliente:

Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\RPC
 DWORD: EnableRPCEncryption
 Value: 1

Se você vir esses dados do Registro no Registro, a configuração da Política de Grupo será aplicada a esse cliente. Inicie o Outlook para verificar se a alteração resolve o problema.

Método 2: desabilitar o requisito de criptografia em todos os servidores CAS

Importante

A Microsoft recomenda que você deixe o requisito de criptografia habilitado em seu servidor e use um dos outros métodos listados neste artigo. O Método 2 só é fornecido neste artigo para situações em que você não pode implantar imediatamente as configurações de criptografia RPC necessárias em seus clientes do Outlook. Se você usar o Método 2 para permitir que os clientes do Outlook se conectem sem criptografia RPC, reabilite o requisito de criptografia RPC em seus servidores CAS o mais rápido possível para manter o nível mais alto de comunicação de cliente para servidor.

Para desabilitar a criptografia necessária entre Outlook e Exchange, siga estas etapas:

  1. Execute o seguinte comando no Shell de Gerenciamento do Exchange:

     Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$False
    

    Observação

    O espaço reservado Exchange_server_name representa o nome de um Exchange Server que tem a função de Servidor de Acesso para Cliente.

    Você deve executar esse cmdlet para todos os servidores de Acesso para Cliente que estão executando o Exchange Server 2010 ou uma versão posterior.

  2. Execute novamente esse comando para cada servidor Exchange que tenha a função Servidor de Acesso para Cliente. O comando também precisa ser executado em cada função de Servidor de Caixa de Correio que contém um Armazenamento de Pastas Públicas. As conexões de Pasta Pública do cliente MAPI vão diretamente para o Serviço de Acesso para Cliente RPC no servidor de Caixa de Correio.

  3. Depois que seus clientes do Outlook são atualizados com a configuração para habilitar a comunicação RPC criptografada com o Exchange (consulte as etapas fornecidas abaixo), você pode habilitar o requisito de criptografia RPC em seus servidores Exchange que tenham a função Servidor de Acesso para Cliente.

    Para reabilitar o requisito de criptografia RPC em seus servidores Exchange que tenham a função Servidor de Acesso para Cliente, execute o seguinte comando no Shell de Gerenciamento Exchange:

     Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$True
    

    Observação

    O espaço reservado Exchange_server_name representa o nome de um servidor Exchange que tem a função Servidor de Acesso para Cliente.

    Você deve executar esse cmdlet para todos os servidores de Acesso para Cliente que estão executando o Exchange Server 2010 ou uma versão posterior.

Motivo

Uma possível causa é que você está usando o Outlook e desabilita a configuração de perfil Criptografar dados entre o Microsoft Office Outlook e o Microsoft Exchange. A configuração padrão para o Exchange Server 2013 requer Criptografia RPC do cliente do Outlook. Isso impede que o cliente seja capaz de se conectar.

Observação

A configuração padrão RTM (Versão para Manufatura) do Exchange Server 2010 requer criptografia RPC. Esse comportamento é uma alteração do Exchange Server 2010 Service Pack 1 em que o requisito de criptografia RPC está desabilitado por padrão. No entanto, qualquer CAS (Servido de Acesso para Cliente) implantado antes do Service Pack 1 ou atualizado para o Service Pack 1 manterá a configuração de requisito de criptografia RPC existente que ainda pode impedir que o cliente consiga se conectar.