Compartilhar via


Não é possível abrir OWA, ECP ou EMS depois que um certificado autoassinado for removido do site do Exchange Back End

Número de KB original: 2779694

Sintomas

Considere o seguinte cenário quando você estiver usando Microsoft Exchange Server 2013 ou Exchange Server 2016:

  • Você remove o certificado do Microsoft Exchange Self-Signed do site do Exchange Back End usando Certificados MMC, Remove-Exchangecertificate, Gerenciador do IIS ou outro método.
  • Você limpa o cache do IIS reiniciando ou IISReset.

Nesse cenário, vários protocolos de cliente, como Exchange Painel de Controle (ECP), Outlook Web App (OWA), Exchange ActiveSync e EMS (Exchange Management Shell) não podem se conectar. Os seguintes problemas podem ocorrer:

  • A OWA e o ECP exibem uma página em branco.

  • Exchange ActiveSync usuários não podem receber emails.

  • O EMS não pode se conectar e exibe o seguinte erro:

    New-PSSession : [xy.local.contoso.com] Processing data from remote server xy.local.contoso.com failed with the
    following error message: The WinRM Shell client cannot process the request. The shell handle passed to the WSMan Shell
    function is not valid. The shell handle is valid only when WSManCreateShell function completes successfully. Change
    the request including a valid shell handle and try again. For more information, see the about_Remote_Troubleshooting
    Help topic.
    At line:1 char:1
    + New-PSSession -ConnectionURI "$connectionUri" -ConfigurationName Microsoft.Excha ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
       gTransportException
        + FullyQualifiedErrorId : -2144108212,PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:
    

Motivo

Durante o processo de instalação, um certificado autoassinado chamado Microsoft Exchange está vinculado ao site de back-end do Exchange na porta 444. O certificado é para comunicação entre o Site da Web Padrão e sites de back-end do Exchange. Quando o certificado é removido, o Site Da Web Padrão não pode fazer proxy de conexões com o site do Exchange Back End.

Resolução

Para resolve esse problema, adicione o certificado de volta ao site do Exchange Back End criando um novo certificado autoassinado e, em seguida, associe-o ao site do Exchange Back End.

Observação

Essas etapas devem ser tomadas na função de servidor do Exchange Mailbox.

  1. Inicie o Shell de Gerenciamento no servidor da caixa de correio.
  2. Digite New-ExchangeCertificate.

    Observação

    Se você for solicitado a substituir o certificado padrão, selecione Não.

  3. Inicie o Gerenciador do IIS no Servidor de Caixa de Correio.
  4. Expanda Site, realce o Back End do Exchange e selecione Associações no painel Ações na coluna do lado direito.
  5. Selecione Typehttps na Porta 444.
  6. Selecione Editar e selecione o certificado do Microsoft Exchange.
  7. Em um prompt de comando de administrador, execute IISReset.