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Falha na pesquisa híbrida para rastrear ou retornar resultados

Sintomas

Você enfrenta um ou mais dos seguintes problemas ao usar a pesquisa híbrida no SharePoint no Microsoft 365:

  • O rastreamento falha.
  • Nenhum resultado é retornado.
  • Você recebe uma mensagem de erro, como "Uma conexão existente foi fechada à força".

Motivo

Começamos a preterir o TLS 1.1 e 1.0 no Microsoft 365. A partir de 30 de junho de 2021, o serviço Pesquisa não aceitará mais conexões que usam o TLS 1.1 ou 1.0. Se você estiver usando o SSA (aplicativo de serviço Pesquisa de nuvem) em versões mais antigas do Windows, você precisará habilitar manualmente o TLS 1.2 para ter conteúdo local indexado no SharePoint no Microsoft 365.

Resolução

Para corrigir esse problema, habilite o TLS 1.2 seguindo estas instruções:

Observação

Se você ainda tiver esses problemas no Windows Server 2012 ou no Windows Server 2008 R2 SP1, experimente as seguintes soluções:

Além disso, marcar os pacotes de criptografia com suporte e a ordem de classificação do pacote de cifras. Para o TLS 1.2, os seguintes pacotes de codificação são compatíveis com o Azure Front Door:

  • TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256
  • TLS_DHE_RSA_WITH_AES_256_GCM_SHA384
  • TLS_DHE_RSA_WITH_AES_128_GCM_SHA256

Para adicionar pacotes de criptografia, implante uma configuração de Política de Grupo ou use a Política de Grupo Editor Local, conforme descrito em Configurar o TLS Cipher Suite Order usando Política de Grupo.

Importante

Altere a ordem dos pacotes de criptografia para garantir que esses quatro pacotes estejam no topo da lista (a maior prioridade).

Para obter mais informações, confira Quais são os pacotes de codificação atuais compatíveis com o Azure Front Door?.

Referências

Ainda precisa de ajuda? Acesse a Comunidade do SharePoint.