Não é possível entrar em sua conta ao tentar se conectar a uma VM do Windows do Azure

Este artigo discute como solucionar problemas do erro "Não podemos entrar em sua conta" ao tentar se conectar a uma VM do Windows do Azure usando o RDP (Protocolo de Área de Trabalho Remota).

Sintomas

Ao tentar conectar a VM do Windows usando RDP, você recebe a seguinte mensagem de erro:

Não podemos entrar em sua conta
Esse problema geralmente pode ser corrigido ao sair da sua conta e entrar novamente. Se você não sair agora, todos os arquivos criados ou alterações que você fizer serão perdidos.

No log de Eventos de Aplicativos, você vê que a ID do Evento 1511 está registrada para cada tentativa de conexão RDP.

ID: 1511
Nível: erro
Fonte: Serviço de Perfis de Usuário Microsoft-Windows
Máquina: RDPDemo.contoso.net
Mensagem: o Windows não pode encontrar o perfil local e está fazendo logon com um perfil temporário. As alterações feitas nesse perfil serão perdidas quando você fizer logon.

Motivo

O problema pode ocorrer se o perfil local do usuário estiver corrompido e o Windows não conseguir criar um novo perfil local para a sessão RDP.

Solução

Antes de prosseguir com qualquer uma das soluções neste documento, faça backup do disco do sistema operacional da VM tomando um instantâneo. Se você precisar reverter quaisquer alterações feitas durante a solução de problemas, poderá usar o instantâneo para recriar o disco.

Reparo online usando o Console Serial do Azure

  1. Conecte-se à VM usando o Console Serial do Azure e inicie uma sessão do PowerShell. Se o Console Serial do Azure não funcionar, conecte-se à VM usando o PowerShell remoto. Para obter mais informações, confira Como usar ferramentas remotas para solucionar problemas de VM do Azure.

  2. Depois de se conectar à VM, execute o comando a seguir para listar as entradas de perfis de usuário. Localize todos os perfis que tenham a extensão ".bak" no final do nome.

    reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList" /s | more
    
  3. Identifique a entrada de perfil do usuário afetado examinando o valor da chave "ProfileImagePath".

  4. Remova a entrada de backup do perfil de usuário para o usuário afetado (termina com ".bak"), não remova entradas para as contas internas do sistema S-1-5-18, S-1-5-19 e S-1-5-20:

    reg delete "HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\ProfileList\<GUID>.bak"
    
  5. Tente se conectar à VM e veja se o problema foi resolvido.

  6. Se o problema ainda ocorrer, você poderá tentar remover a entrada do perfil de usuário para o usuário afetado.

Reparo off-line

Se você não conseguir acessar a VM usando o Console Serial do Azure ou outras ferramentas remotas, o reparo deve ser feito no modo offline.

  1. Siga as etapas 1-3 do processo de reparo de VM para criar uma VM de reparo. Um disco do sistema operacional copiado da VM com falha será anexado à VM de Reparo automaticamente. Normalmente, o disco é anexado como unidade F.
  2. Conecte-se à VM de Reparo.
  3. Na VM de Reparo, inicie o Registro Editor (regedit.exe). Selecione a chave HKEY_LOCAL_MACHINE,selecione Hive de Carga de Arquivo> no menu. Localize e carregue o arquivo hive software na pasta F:\Windows\System32\config e digite RepairSOFTWARE como o nome do hive.
  4. Navegue até RepairSOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList.
  5. Identifique a entrada de perfil do usuário afetado examinando o valor da chave "ProfileImagePath".
  6. Remova a entrada de backup do perfil de usuário para o usuário afetado (termina com ".bak"), não remova entradas para as contas internas do sistema S-1-5-18, S-1-5-19 e S-1-5-20.
  7. Use a etapa 5 do processo de reparo da VM para montar o disco do sistema operacional reparado na VM com falha.
  8. Inicie a VM com falha e tente se conectar à VM usando RDP. Se o problema continuar a ocorrer, você poderá tentar remover a entrada do perfil de usuário para o usuário afetado.

Próximas etapas

Se o problema do Azure não for resolvido neste artigo, visite os fóruns do Azure no MSDN e no Stack Overflow. Você pode postar seu problema nesses fóruns ou postar em @AzureSupport no Twitter. Você também pode enviar uma solicitação de suporte do Azure.

Para enviar uma solicitação de suporte, acesse a página Suporte do Azure e selecione Obter suporte.

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.