Compartilhar via


Alguns dispositivos são relatados como falha no painel de integridade do cliente

A partir da versão 1902 do branch atual do Configuration Manager, o painel de integridade do cliente está disponível para avaliar a integridade dos clientes do Configuration Manager em seu ambiente. Este artigo descreve um problema no qual alguns dispositivos são relatados inesperadamente como Falha na barra Mensagens de Status do gráfico de barras Integridade do Cenário. Este artigo também fornece alguns insights sobre os componentes internos e os cálculos do gráfico de barras de Integridade do Cenário.

Aplica-se a: Gerenciador de Configurações (branch atual)
Número original do KB: 4643234

Sintomas

No gráfico de barras Integridade do Cenário do painel de integridade do cliente, alguns dispositivos são relatados inesperadamente como Falha na barra Mensagens de Status. As informações correspondentes também são refletidas na barra Combinado (Qualquer).

Captura de tela do gráfico de barras de integridade do cenário.

Causa

Um cliente do Configuration Manager envia uma mensagem de status nos seguintes cenários:

  • Você executa uma distribuição de software herdada, como um pacote clássico, no cliente.
  • Algo é alterado ou quebrado no cliente. Por exemplo, um inventário de software não é concluído dentro do período de tempo limite.

Se você usar apenas as tecnologias de Distribuição de Software Moderna e implantar atualizações de software, nenhuma mensagem de status será enviada e o carimbo de data/hora da última mensagem de status não será atualizado no banco de dados.

Observação

Implantações de pacotes herdados ocultos, como pacotes de Atualização de Cliente do Configuration Manager, podem atualizar o carimbo de data/hora da última mensagem de status.

Solução alternativa

É possível implementar um pacote legado fictício (como o comando) em um cliente afetado cmd /c echo para gerar um fluxo de mensagens de status constante. Em seguida, um carimbo de data/hora da mensagem de status será atualizado regularmente e o cliente será relatado como Sucesso na barra de mensagens de status. Como alternativa, você pode ignorar ou ocultar a barra de mensagens de status.

Mais informações

O painel de integridade do cliente exibe as informações resumidas de integridade do cliente. Para exibir informações do cliente no console do Configuration Manager, os administradores podem adicionar as colunas relevantes (como Solicitação de Política ou Mensagem de Status) ou verificar a seção Atividade do Cliente do cliente.

Captura de tela da integridade do cenário do painel de integridade do cliente no console do Configuration Manager.

Por padrão, as informações de integridade são resumidas em um servidor do site uma vez por dia. Na caixa de diálogo Propriedades das Configurações de Status do Cliente no site Atividade do Cliente, os administradores também podem definir as configurações para monitorar o status do cliente. Se a mensagem de status recente tiver sido criada nos últimos sete dias, esse cliente será considerado ativo em Visão geral>do monitoramento>Status>do cliente Atividade do cliente.

Captura de tela da caixa de diálogo Propriedades das Configurações de Status do Cliente.

No Configuration Manager, os administradores podem usar uma tarefa de manutenção (Excluir Mensagens de Status Antigas) para excluir mensagens de status com mais de 30 dias (por padrão), conforme configurado nas regras de filtro de status.

Uma configuração de tarefa para excluir mensagens de status antigas.

O Procedimento Armazenado SQL (spGetClientHealthDashboard) calcula o status de Êxito e Falha para clientes individuais, da seguinte maneira:

  • Se o carimbo de data/hora da mensagem de status recente tiver menos de sete dias ou não houver mensagem de status, o cliente será relatado como Êxito.
  • Se o carimbo de data/hora da mensagem de status recente tiver mais de sete dias e a mensagem de status não for excluída, o cliente será relatado como Falha.

Observação

Este algoritmo também é aplicável a outras barras. No entanto, não há mecanismo de limpeza para carimbos de data/hora de inventário.

Por padrão, o painel de integridade do cliente exibe as informações de integridade dos clientes que estavam online durante os três dias anteriores.

Configurações do painel de integridade do cliente.

Confira também

MMS: Mensagens de estado e status do ConfigMgr

Aviso de isenção de responsabilidade para contatos de terceiros

A Microsoft fornece informações de contato de terceiros para ajudá-lo a encontrar informações adicionais sobre esse tópico. Essas informações de contato podem ser alteradas sem aviso prévio. A Microsoft não garante a precisão das informações de contato de terceiros.