Compartilhar via


O envio com winhttp falhou no erro 80072f8f em Smsts.log durante a implantação do sistema operacional usando mídia inicializável ou prestaged

Este artigo ajuda você a corrigir um problema no qual o Assistente de Sequência de Tarefas retorna o erro 80004005 e Smsts.log registra o erro Envio com winhttp com falha; 80072f8f durante uma implantação do sistema operacional que usa mídia inicializável ou prestaged.

Versão original do produto: Configuration Manager (branch atual), Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 Configuration Manager
Número de KB original: 4551033

Sintomas

Você cria mídia inicializável ou mídia prestaged em Configuration Manager. Quando a mídia é usada para iniciar o computador de destino, o Assistente de Sequência de Tarefas fica preso na política de recuperação desta etapa do computador por cerca de 90 segundos e retorna a seguinte mensagem de erro:

Falha ao executar a sequência de tarefas
Ocorreu um erro ao recuperar a política para este computador (0x80004005). Para obter mais informações, entre em contato com o administrador do sistema ou o operador de helpdesk.

As seguintes mensagens de erro são registradas em X:\Windows\Temp\SMSTSLog\smsts.log no computador quando o mecanismo de sequência de tarefas tenta entrar em contato com o ponto de gerenciamento para sincronizar as informações de tempo:

TSMBootstrap Informações de tempo atual:
TSMBootstrap Obtendo informações de tempo mp
TSMBootstrap Solicitando identidade do cliente
TSMBootstrap Configurando o autenticador.
TSMBootstrap CLibSMSMessageWinHttpTransport::Send: WinHttpOpenRequest - URL: <MP>:443 CCM_POST /ccm_system_AltAuth/request
SSL TSMBootstrap, usando o autenticador na solicitação.
TSMBootstrap no SSL, mas sem certificado de cliente.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE Encontrado
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength é 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation é 0x8
TSMBootstrap [TSMESSAGING] : WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA está definido
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
Erro TSMBootstrap. Recebeu 0x80072f8f do WinHttpSendRequest.
Falha no envio de TSMBootstrap com winhttp; 80072f8f. Repetindo.
TSMBootstrap Repetindo e ignorando falhas de segurança de data.
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback(): WINHTTP_CALLBACK_STATUS_SECURE_FAILURE Encontrado
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength é 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation é 0x8
TSMBootstrap [TSMESSAGING] : WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA está definido
TSMBootstrap [TSMESSAGING] AsyncCallback():
-----------------------------------------------------------------
TSMBootstrap hr, HRESULT=80072f8f
Falha no envio de TSMBootstrap com winhttp; 80072f8f

Após o erro inicial, o mecanismo de sequência de tarefas tenta mais quatro vezes entrar em contato com o ponto de gerenciamento e experimenta uma pausa crescente entre cada tentativa. No entanto, todas as tentativas falham e retornam as mesmas mensagens de erro antes que algumas mensagens de erro final sejam retornadas, da seguinte maneira:

  • Se a mídia estiver configurada como mídia dinâmica, as seguintes mensagens de erro finais serão registradas no Smsts.log:

    TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
    O TSMBootstrap falhou ao enviar a solicitação
    TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
    TSMBootstrap Falha ao obter a identidade do cliente (80072f8f)
    TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
    Falha na solicitação de TSMBootstrap para o cliente
    Falha em TSMBootstrap SyncTimeWithMP(). 80072f8f.
    TSMBootstrap Falha ao obter informações de tempo de MP: https://<MP>.
    TSMBootstrap MpCnt > 0, HRESULT=80004005
    TSMBootstrap QueryMPLocator: nenhum local de MP válido é recebido
    TSMBootstrap TSMBootstrapUtil::QueryMPLocator ( true, sSMSTSLocationMPs.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, httpS, http, accessibleMpCnt), HRESULT=80004005
    Falha do TSMBootstrap ao consultar o localizador do Ponto de Gerenciamento
    TSMBootstrap saindo de TSMediaWizardControl::GetPolicy.
    TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
    Erro do assistente de configuração TSMBootstrap: ocorreu um erro ao recuperar a política para este computador (0x80004005). Para obter mais informações, entre em contato com o administrador do sistema ou o operador de helpdesk.

  • Se a mídia estiver configurada como baseada em site, as seguintes mensagens de erro finais serão registradas no Smsts.log:

    TSMBootstrap Send (pReply, nReplySize), HRESULT=80072f8f
    O TSMBootstrap falhou ao enviar a solicitação
    TSMBootstrap DoRequest (sReply, true), HRESULT=80072f8f
    TSMBootstrap Falha ao obter a identidade do cliente (80072f8f)
    TSMBootstrap ClientIdentity.RequestClientIdentity (), HRESULT=80072f8f
    Falha na solicitação de TSMBootstrap para o cliente
    Falha em TSMBootstrap SyncTimeWithMP(). 80072f8f.
    TSMBootstrap Falha ao obter informações de tempo de MP: https://<MP>.
    TSMBootstrap sMP.length() > 0, HRESULT=80004005
    TSMBootstrap TSMBootstrapUtil::SelectMP ( sSMSTSMP.c_str(), sMediaPfx.c_str(), sMediaGuid.c_str(), sAuthenticator.c_str(), sEnterpriseCert.c_str(), sServerCerts.c_str(), nHttpPort, nHttpsPort, bUseCRL, m_bWinPE, sSiteCode, sAssignedSiteCode, sMP, sCertificates, sX86UnknownMachineGUID, sX64UnknownMachineGUID), HRESULT=80004005
    Falha no TSMBootstrap ao selecionar MP
    TSMBootstrap saindo de TSMediaWizardControl::GetPolicy.
    TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>>(), HRESULT=80004005
    Erro do assistente de configuração TSMBootstrap: ocorreu um erro ao recuperar a política para este computador (0x80004005). Para obter mais informações, entre em contato com o administrador do sistema ou o operador de helpdesk.

As seguintes informações detalhadas se aplicam ao erro 80072F8F:

Código de Erro: 0x80072F8F (2147954575)
Nome do erro: WININET_E_DECODING_FAILED
Fonte do erro: Windows
Mensagem de erro: falha na decodificação de conteúdo

Motivo

Esse problema ocorre se as seguintes condições forem verdadeiras:

  • Você usa pki em seu ambiente de Configuration Manager.
  • Você cria a mídia inicializável ou mídia prestaged no site de administração central.
  • Você configura seus pontos de gerenciamento para usar HTTPS.

Se você usar o PKI em seu ambiente Configuration Manager, a autoridade de certificado raiz (AC) será especificada no site primário, mas não no site de administração central. Como o site de administração central não tem as informações raiz da AC, a mídia criada não contém as informações de AC raiz. Portanto, as solicitações enviadas para um ponto de gerenciamento habilitado para HTTPS falham sem as informações de AC raiz.

Resolução

Para corrigir o problema, crie a mídia inicializável ou mídia prestaged em um site primário, em vez de no site de administração central.

Mais informações

Para mídia que será usada em vários sites, configure a mídia como mídia dinâmica. Você pode criar mídia dinâmica em qualquer site. Você não se limita a criá-lo no site de administração central.