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Um computador cliente pode roubar o GUID Configuration Manager de um objeto De computador desconhecido durante a imagem

Este artigo fornece as informações para resolver o problema que o GUID (Identificador Exclusivo) Configuration Manager de um objeto De computador desconhecido é obtido por um computador cliente que está sendo imagens.

Versão original do produto: Configuration Manager (branch atual)
Número de KB original: 4471061

Sintomas

Configuration Manager branch atual versão 1702 incluiu um novo recurso que permite usar o botão Anterior para tentar novamente uma sequência de tarefas com falha no Assistente de Sequência de Tarefas quando ele é executado no Windows PE (Ambiente de Pré-instalação do Microsoft Windows).

Para obter mais informações sobre esse recurso, consulte Retornar à página anterior quando uma sequência de tarefas falhar.

Este recurso introduziu o seguinte problema:

Quando o botão Anterior é selecionado, o computador cliente que está sendo imagem pode roubar o guid (identificador exclusivo) Configuration Manager do objeto Unknown Computer que está sendo usado (o computador desconhecido x64 ou o computador desconhecido x86).

Esse problema foi corrigido na reversão de atualização para Configuration Manager branch atual, versão 1702.

Esse problema também é corrigido em todas as versões subsequentes de Configuration Manager branch atual.

No entanto, a partir de Configuration Manager branch atual versão 1702, computadores desconhecidos iniciados a partir da mídia ou do ambiente de execução de pré-lançamento (PXE) podem não encontrar sequências de tarefas direcionadas a eles. Nesse cenário, a seguinte mensagem de erro é registrada no SMSTS.log:

Não há sequências de tarefas disponíveis para este computador. Verifique se você tem pelo menos uma sequência de tarefas anunciada para este computador.

Erro não especificado (Erro: 80004005; Fonte: Windows)

Esse problema poderá ocorrer se o botão Anterior na página Selecionar uma sequência de tarefas a ser executada estiver selecionado no computador desconhecido.

Esse problema também é corrigido em todas as versões subsequentes de Configuration Manager branch atual.

Apesar de aplicar a reversão de atualização no Configuration Manager versão atual do branch 1702 ou atualizar para uma versão posterior do Configuration Manager, o problema ainda ocorre.

Motivo

Esse problema pode continuar ocorrendo porque a correção na distribuição de atualização para Configuration Manager branch atual versão 1702 e posterior Configuration Manager versões atuais do branch impede que o problema ocorra apenas daqui para frente. Ele não corrigirá o problema se o problema existir atualmente no ambiente.

Portanto, o problema pode continuar a ocorrer no Configuration Manager versão atual do branch 1702 ou mais recente, mesmo depois que a versão 1702 update rollup ou uma versão posterior for aplicada. Isso é verdade, a menos que as seguintes etapas sejam tomadas:

  • Atualize as imagens de inicialização em pontos de distribuição.
  • Recrie a mídia de inicialização usando as imagens atualizadas.
  • Limpo corretamente o computador cliente que roubou o GUID.

Resolução

Aviso

Não tente corrigir esse problema recriando os objetos de Computador Desconhecido. Isso não corrige corretamente o problema e não impede que o problema se repita daqui para frente. Além disso, há problemas conhecidos que ocorrem em ambientes que têm vários objetos de Computador Desconhecido para um único site. Se você já tentou resolve esse problema recriando os objetos de Computador Desconhecido, consulte Remover objetos de Computador Desconhecido duplicados.

Para resolve esse problema e impedir que ele retorne no ambiente, siga estas etapas:

  1. Atualize todas as imagens de inicialização no ambiente. Para fazer isso, clique com o botão direito do mouse nas imagens no console Configuration Manager e selecione Atualizar Pontos de Distribuição. Isso coloca os binários Configuration Manager atualizados que contêm a correção na imagem de inicialização. Para obter mais informações, confira Atualizar pontos de distribuição com a imagem de inicialização.

  2. Se você usar mídia no ambiente, recrie todas as mídias no ambiente depois de atualizar todas as imagens de inicialização nos pontos de distribuição. Isso garante que as imagens de inicialização atualizadas que têm a correção estejam na mídia que está sendo usada no ambiente.

    Para impedir que a mídia com imagens de inicialização antigas seja usada, os certificados para essas imagens de inicialização podem ser bloqueados no console Configuration Manager no nóCertificados deSegurança> de Administração>. Para garantir que o problema não se repita, recomendamos bloquear todos os certificados para todas as mídias criadas antes que as imagens de inicialização sejam atualizadas na etapa 1. A data em que a mídia foi criada é exibida na coluna Data de Início .

    Para obter mais informações sobre como criar mídia, consulte Criar mídia de sequência de tarefas.

  3. O computador cliente que roubou o GUID deve ser limpo corretamente.

Para limpo corretamente o cliente que roubou o GUID, siga estas etapas:

  1. Identifique o computador que adquiriu o GUID. Para fazer isso, examine as propriedades do objeto Unknown Computer (geralmente x64 Unknown Computer), observe o valor de Configuration Manager Identificador Exclusivo e execute uma consulta no console Configuration Manager para identificar o objeto do computador que tem o mesmo GUID. Você pode fazer todas essas etapas do console. Você não precisa entrar no banco de dados SQL Server para fazer isso.

  2. Depois de identificar o computador que adquiriu o GUID roubado, conecte-se remotamente a esse computador e, em seguida, limpo completamente o cliente Configuration Manager. Isso envolve mais do que simplesmente desinstalar o cliente. Em vez disso, você deve seguir as etapas 3-7.

  3. No computador cliente, em C:\Windows\CCMSetup, execute o CCMSetup.exe /uninstall comando em um prompt de comando elevado.

  4. Monitore o Gerenciador de Tarefas até que o CCMSetup termine a execução. Marcar o arquivo ccmsetup.log para verificar se o cliente foi desinstalado corretamente.

  5. No computador cliente, exclua os seguintes diretórios:

    • C:\Windows\CCM
    • C:\Windows\CCMSetup

    Observação

    Para excluir totalmente esses diretórios, talvez seja necessário reiniciar o computador.

  6. No computador cliente, exclua as seguintes chaves do registro (se elas existirem):

    • HKEY_LOCAL_MACHINE\Software\Microsoft\CCM
    • HKEY_LOCAL_MACHINE\Software\Microsoft\CCMSetup
    • HKEY_LOCAL_MACHINE\Software\Microsoft\SMS
  7. No computador cliente, exclua o arquivo C:\Windows\SMSCFG.ini.

  8. No computador cliente, exclua todos os certificados no nóCertificadosSMS> no console Certificados para a conta de computador. Para fazer isso, siga estas etapas:

    1. Execute MMC.exe em um prompt de comando elevado.

    2. No menu Arquivo, clique em Adicionar/Remover Snap-in.

    3. Selecione Certificados e selecione Adicionar.

    4. Selecione Conta de computador e selecione Avançar.

    5. Selecione Computador local e selecione Concluir.

    6. Selecione OK.

    7. Navegue até Certificados>SMS>certificados.

    8. No painel de resultados, clique com o botão direito do mouse em cada certificado listado no nó Certificados certificados>SMS>e selecione Excluir. Repita essa etapa até que todos os certificados sejam excluídos.

    9. Feche o console certificados .

  9. Exclua o registro do computador ofensivo do console Configuration Manager. Novamente, você não precisa entrar no banco de dados SQL Server para fazer isso. Você pode excluir o registro do console Configuration Manager. Certifique-se de fazer isso depois de concluir as etapas 1-8. Fazer isso primeiro pode fazer com que o registro seja recriado se os relatórios do cliente forem backup antes de serem totalmente limpos.

  10. Reinstale o Configuration Manager cliente no computador cliente ofensivo.

Remover objetos de Computador Desconhecido duplicados

Se os objetos de Computador Desconhecido tiverem sido recriados no site quando você tentou corrigir o problema, os objetos extras do Computador Desconhecido devem ser excluídos. Para fazer isso, todos os objetos de Computador Desconhecido atuais devem ser excluídos para o site afetado seguido pela criação de um novo conjunto de objetos de Computador Desconhecido para o site. A exclusão de objetos de Computador Desconhecido só pode ser concluída no banco de dados SQL Server. Ele não pode ser feito do console Configuration Manager.

Observação

É aceitável ter vários objetos de Computador Desconhecido se houver vários sites primários. No entanto, cada site deve ter apenas um objeto De computador desconhecido por arquitetura. Por exemplo, deve haver apenas um objeto x64 rotulado x64 Unknown Computer e apenas um objeto x86 rotulado como x86 Unknown Computer.

Para excluir os objetos extras do Computador Desconhecido, siga estas etapas:

  1. Verifique se você tem um backup atual e válido do site Configuration Manager usando a tarefa de manutenção de backup interna.

  2. Abra o console do Gerente de Configurações. Se houver vários sites primários, recomendamos que você abra um console Configuration Manager conectado ao site de administração central.

  3. No console Configuration Manager, acesse Conjuntos deDispositivos deVisão Geral> de Ativos e Conformidade>.

  4. Clique duas vezes na coleção Todos os Computadores Desconhecidos .

  5. No painel de resultados, classifique os objetos na coleção Todos os Computadores Desconhecidos selecionando a coluna Código do Site .

  6. Observe se há vários objetos x64 Unknown Computer ou objetos x86 Unknown Computer para qualquer site individual.

  7. Se houver vários objetos x64 Unknown Computer ou objetos x86 Unknown Computer para qualquer site individual, clique com o botão direito do mouse nas colunas no painel de resultados e adicione a ID do recurso à lista de colunas.

  8. Determine o valor da ID do recurso para cada objeto x64 Unknown Computer e cada objeto x86 Unknown Computer para qualquer site. Observe a ID do recurso para todos os objetos de Computador Desconhecido, mesmo que apenas um dos objetos de Computador Desconhecido esteja duplicado.

  9. Depois de determinar as IDs de recurso dos objetos de Computador Desconhecido para um site, os objetos x64 Unknown Computer e os objetos x86 Unknown Computer para o site podem ser excluídos.

  10. Abra SQL Server Management Studio e conecte-se ao banco de dados do site que hospeda os objetos extras do Computador Desconhecido.

  11. Expanda o nó Bancos de Dados e selecione o banco de dados Configuration Manager (geralmente CM_Site_Code).

  12. Na barra de ferramentas, selecione Nova Consulta.

  13. Verifique se o banco de dados correto está selecionado no menu suspenso à esquerda do botão Executar na barra de ferramentas.

  14. No painel de consulta, execute a seguinte consulta SQL:

    SELECT C.CollectionID, C.SiteID, C.CollectionName, CM.MachineID, CM.Name FROM Collections C JOIN CollectionMembers CM ON C.SiteID = CM.SiteID JOIN UnknownSystem_DISC USD ON USD.ItemKey = CM.MachineID
    

    Essa consulta exibe todas as coleções às quais todos os objetos de Computador Desconhecido pertencem. Use essa consulta para determinar de quais coleções os objetos de Computador Desconhecido são membros. Anote essas informações para que, quando o novo conjunto de objetos de Computador Desconhecido for criado, elas possam ser adicionadas de volta às coleções apropriadas. A ID do recurso está listada na coluna MachineID .

  15. No painel de consulta, execute a seguinte consulta SQL:

    SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
    

    Nesta consulta, Resource_ID_x está a ID de recurso de cada um dos objetos de Computador Desconhecido para o site, conforme determinado na etapa 9. Por exemplo, se as IDs de recurso estiverem 2046820354 e 2046820355, a consulta será a seguinte:

    SELECT * FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354','2046820355')
    
  16. Verifique se os registros retornados pela consulta na etapa 15 estão corretos. Se estiverem, execute a seguinte consulta para excluir os registros:

    DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('Resource_ID_1','Resource_ID_2', 'Resource_ID_3')
    

    Nesta consulta, Resource_ID_x está a ID de recurso de cada um dos objetos de Computador Desconhecido para o site, conforme determinado na etapa 9. Por exemplo, se as IDs de recurso forem 2046820354 e 2046820355, a consulta de exclusão será a seguinte:

    DELETE FROM UnknownSystem_DISC WHERE ItemKey IN ('2046820354', '2046820355')
    

    Observação

    Lembre-se de excluir todos os objetos de Computador Desconhecido para o site afetado, x64 e x86, mesmo que apenas um deles tenha sido duplicado.

  17. Siga a seção Recriar objetos de Computador Desconhecido em caso de exclusão acidental para criar novos objetos de Computador Desconhecido para o site afetado.

  18. Retorne ao console Configuration Manager e vá paraColeções de Dispositivos deVisão Geral> de Ativos e Conformidade>.

  19. Clique com o botão direito do mouse na coleção Todos os Computadores Desconhecidos e selecione Atualizar Associação.

  20. Aguarde alguns minutos e selecione Atualizar. Verifique se existe apenas um objeto x64 Unknown Computer ou x86 Unknown Computer para cada site. Se os objetos não forem exibidos, aguarde mais alguns minutos e tente novamente.

  21. Depois que os novos objetos de Computador Desconhecido aparecerem, adicione-os de volta às coleções apropriadas, conforme determinado na etapa 14.

  22. Repita as etapas 10-21 para todos os sites primários adicionais, conforme necessário.

Recriar objetos de Computador Desconhecido em caso de exclusão acidental

Se, por qualquer motivo, todos os objetos de Computador Desconhecido forem excluídos acidentalmente para qualquer site que use esse processo, eles poderão ser recriados usando as etapas a seguir. Essas etapas só devem ser tomadas se não houver objetos de Computador Desconhecido para um site. Se apenas um dos dois objetos de Computador Desconhecido existir em um site, exclua o objeto de Computador Desconhecido restante usando as etapas na seção Remover objetos de Computador Desconhecido duplicados deste artigo e siga estas etapas :

  1. Entre no servidor de site primário do qual os objetos do Computador Desconhecido estão ausentes.

  2. Abra um prompt de comando elevado e execute o seguinte comando:

    REG.exe ADD "HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_DISCOVERY_DATA_MANAGER" /v CreatedUnknownDDR /t REG_DWORD /d 0 /f
    

Depois que esse valor de chave do registro for atualizado, os objetos de Computador Desconhecido devem ser recriados automaticamente logo depois. Você pode marcar o progresso da criação dos objetos de Computador Desconhecido no arquivo DDM.log no servidor de site primário.

Para acelerar a recriação dos registros do Computador Desconhecido, reinicie o SMS_DISCOVERY_DATA_MANAGER thread seguindo estas etapas:

  1. Abra o console Configuration Manager no site primário do qual os objetos do Computador Desconhecido estão ausentes e vá para Monitoramento>Visão geral> dostatus>do componente status do sistema.

  2. Na barra de ferramentas, selecione Iniciar>Configuration Manager Service Manager.

  3. Em Configuration Manager Service Manager, expanda o nó no código do site e selecione Componentes.

  4. No painel de resultados, clique com o botão direito do mouse em SMS_DISCOVERY_DATA_MANAGER e selecione Consulta. O thread deve ser exibido como Em execução.

  5. Clique com o botão direito do mouse em SMS_DISCOVERY_DATA_MANAGER e clique em Parar.

  6. Clique com o botão direito do mouse em SMS_DISCOVERY_DATA_MANAGER e clique em Consulta.

    Observação

    O thread deve ser exibido como Parado.

  7. Clique com o botão direito do mouse em SMS_DISCOVERY_DATA_MANAGER e clique em Iniciar.

  8. Clique com o botão direito do mouse em SMS_DISCOVERY_DATA_MANAGER e clique em Consulta.

    Observação

    O thread deve ser exibido como Em execução.

  9. Feche a janela Configuration Manager Service Manager.

Os objetos de Computador Desconhecido devem ser recriados automaticamente em breve. Você pode marcar o progresso desse processo no arquivo DDM.log no servidor de site primário.