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Não é possível ligar a um computador remoto ou iniciar uma aplicação remota quando utiliza o Acesso Web dos Serviços de Terminal ou a Área de Trabalho Web Remota num computador baseado no Windows XP SP3 ou no Windows Small Business Server 2003 SP1

Este artigo fornece soluções para um problema em que não é possível ligar a um computador remoto ou iniciar uma aplicação remota quando utiliza o Acesso Web TS ou a Área de Trabalho Web Remota.

Número original da BDC: 951607

Sintomas

Num computador baseado no Windows XP Service Pack 3 (SP3) ou no Windows Small Business Server 2003 Service Pack 1 (SP1), tem os seguintes sintomas:

  • Quando tenta ligar a um computador remoto através da Ligação à Web de Ambiente de Trabalho Remoto (TSWeb), o botão Ligar é desativado. A página TSWeb também pode conter a seguinte mensagem de aviso:

    O controlo ActiveX da Ligação à Web do Ambiente de Trabalho Remoto não está instalado. Não é possível estabelecer uma ligação sem uma versão do controlo instalada em funcionamento.

    Observação

    Quando tenta instalar o cliente de Ligação ao Ambiente de Trabalho Remoto 6.0, recebe uma mensagem a indicar que este já está instalado no computador.

  • Quando utiliza o Web site da Área de Trabalho Web Remota (RWW) para ligar a um computador remoto, repara que não pode transferir o controlo ActiveX da Ligação ao Ambiente de Trabalho Remoto. Em alternativa, recebe a seguinte mensagem de erro:

    Nome de servidor inválido.

    Observação

    A Área de Trabalho Web Remota é uma funcionalidade que está disponível no Microsoft Windows Small Business Server (Windows SBS).

  • Quando utiliza o Web site do Acesso Web dos Serviços de Terminal (TSWA) para ligar a um computador remoto ou para iniciar uma aplicação remota, recebe a seguinte mensagem de erro: este Web site requer o Cliente dos Serviços de Terminal, que parece não estar instalado neste Sistema. Instale o cliente mais recente e certifique-se de que tem as Atualizações do Windows mais recentes antes de continuar.

  • Quando acede à página Computadores de Acesso Remoto utilizando o Windows Home Server, poderá receber a seguinte mensagem de erro: Suplemento Desativado Esta página Web está a pedir um suplemento que está desativado. Para ativar o suplemento, clique aqui. Além disso, quando tentar ligar ao Windows Home Server ou a um computador doméstico, poderá receber a seguinte mensagem de erro:

    Esta funcionalidade requer que o endereço https://my.homeserver.com do site do Windows Home Server seja adicionado à zona Sites Fidedignos no Internet Explorer. Para adicionar o endereço do site do Windows Home Server, abra a caixa de diálogo Opções da Internet do Internet Explorer, clique no separador Segurança. Selecione "Sites fidedignos" e clique no botão Sites. Adicione o endereço https://my.homeserver.com do site com o botão Adicionar e, em seguida, prima Fechar.

    Observação

    Depois de adicionar o URL do servidor principal à lista de sites fidedignos, recebe a mesma mensagem de erro e continua a não conseguir estabelecer ligação.

  • Quando aceder ao Windows Home Server através do Acesso Remoto ao Site, poderá receber a seguinte mensagem de erro:

    Suplemento Desativado Esta página Web está a pedir um suplemento que está desativado. Para ativar o suplemento, clique aqui.

    Além disso, quando tentar ligar ao Windows Home Server, poderá receber a seguinte mensagem de erro: para ligar remotamente ao servidor doméstico ou ao computador doméstico, o suplemento Controlo de Cliente dos Serviços de Terminal da Microsoft ou o suplemento RDP da Microsoft têm de estar instalados e ativados para o browser. Se recusou a instalar o suplemento, atualize a página e instale-a quando lhe for pedido. Caso contrário, ative este suplemento com o ícone Gerir suplementos na barra de estado do browser ou consulte a documentação do browser sobre como ativar este suplemento.

Motivo

Este problema ocorre se o controlo ActiveX para o cliente de Ligação ao Ambiente de Trabalho Remoto não estiver ativado no browser. Por predefinição, o controlo ActiveX é desativado depois de instalar o Windows XP Service Pack 3 (SP3) ou o Windows Small Business Server 2003 SP1.

Solução alternativa

Como solução alternativa a esse problema, execute as seguintes etapas:

  1. Inicialize o Internet Explorer.

  2. Visite o Web site que está a causar este problema.

  3. Se estiver a utilizar o Windows Internet Explorer 7, siga estes passos:

    1. No menu Ferramentas , aponte para Gerir Suplementos e, em seguida, clique em Ativar ou Desativar Suplementos. É apresentada a caixa de diálogo Gerir Suplementos .
    2. Na lista de suplementos, procure o controlo ActiveX do Controlo de Cliente dos Serviços de Terminal da Microsoft ou o controlo ActiveX do cliente RDP da Microsoft. Se não conseguir encontrar o controlo, veja os passos em "Se o controlo não for apresentado na lista de suplementos" no final desta secção.
    3. Clique no controlo, clique em Ativar e, em seguida, clique em OK para fechar a caixa de diálogo Gerir Suplementos.

    Se estiver a utilizar o Internet Explorer 6, siga estes passos:

    1. No menu Ferramentas , clique em Gerir Suplementos. É apresentada a caixa de diálogo Gerir Suplementos .
    2. Na lista de suplementos, procure o controlo ActiveX do Controlo de Cliente dos Serviços de Terminal da Microsoft ou o controlo ActiveX do cliente RDP da Microsoft. Se não conseguir encontrar o controlo, veja os passos em "Se o controlo não for apresentado na lista de suplementos" no final desta secção.
    3. Clique no controlo, clique em Ativar e, em seguida, clique em OK para fechar a caixa de diálogo Gerir Suplementos .
  4. Adicione o site aos seus Sites Fidedignos no Internet Explorer.

  5. Reinicie o Internet Explorer.

  6. Tente ligar ao computador remoto. Em alternativa, tente iniciar a aplicação remota.

Se o controlo não for apresentado na lista de suplementos

Por vezes, o controlo ActiveX do Controlo de Cliente dos Serviços de Terminal da Microsoft não será apresentado na lista de suplementos.

Para corrigir este problema, pode experimentar os seguintes passos para tentar apresentar o controlo ao repor o Internet Explorer para uma configuração predefinida.

  1. Inicialize o Internet Explorer.
  2. Clique em Ficheiro e, em seguida, clique em Importar e Exportar.
  3. Siga os passos no assistente para exportar os seus Favoritos.
  4. Clique em Ferramentas e, em seguida, clique em Opções da Internet.
  5. Clique em Avançadas e, em seguida, clique em Repor.

Assim que o Internet Explorer tiver sido reposto para uma configuração predefinida, tente ligar ao computador remoto ou inicie a aplicação remota. Se não funcionar, siga os passos na solução para ativar o controlo ActiveX do Controlo de Cliente do Serviço de Terminal da Microsoft. Se o controlo ainda não estiver listado, pode modificar o registo para remover uma chave, se existir.

Importante

Este artigo contém informações sobre como modificar o Registro. Faça backup do Registro antes de modificá-lo. Você deve saber como restaurar o Registro caso ocorra algum problema. Para obter mais informações sobre como criar cópias de segurança, restaurar e modificar o registo, clique no seguinte número de artigo para ver o artigo na Base de Dados de Conhecimento Microsoft: 322756 Como criar cópias de segurança e restaurar o registo no Windows

Remova as seguintes chaves de registo, se existirem:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}

Assim que as chaves do registo forem removidas, saia e reinicie o Internet Explorer e tente ligar ao computador remoto ou inicie a aplicação remota novamente.

Se isto não resolver o problema, pode voltar a registar o ficheiro mstscax.dll. Para fazer isso, siga estas etapas:

  1. Saia do Internet Explorer.

  2. Clique em Iniciar, clique em Executar e escreva ou copie e cole o seguinte texto na caixa Abrir e clique em OK: %windir%\system32\regsvr32 mstscax.dll

  3. Na linha de confirmação, clique em OK.

  4. Reinicie o Internet Explorer e tente ligar ao computador remoto ou inicie a aplicação remota.

Mais informações

No Windows XP Service Pack 2 (SP2), teve de instalar o ficheiro Msrdp.ocx para ativar o controlo ActiveX dos Serviços de Terminal. O Windows XP Service Pack 3 (SP3) já inclui este controlo ActiveX e instala-o com o ficheiro Mstscax.dll. Por predefinição, este controlo ActiveX está desativado no Windows XP Service Pack 3 (SP3).