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O redirecionamento de impressora do Windows Server não está funcionando

Este artigo fornece uma solução para um problema em que o redirecionamento de impressora não está funcionando e nenhuma ID de evento ocorre.

Número original do KB: 2003646

Sintomas

O redirecionamento de impressora não está funcionando. O redirecionamento de unidade funciona. Nenhuma ID de evento é vista.

Motivo

O descritor de segurança do spooler deve conter a ACL (Lista de Controle de Acesso) "AU" (Usuário Autenticado) que permite que qualquer usuário autenticado abra o serviço de spooler para operações de leitura.

Nesse caso, essa ACL estava ausente do descritor de segurança do spooler.

Resolução

Execute o seguinte comando para mostrar os descritores de segurança atuais no spooler de impressão:

C:\sc sdshow spooler 

Um SD (descritor de segurança) inalterado para spooler de impressão deve ter esta aparência:

D:(A;; CCLCSWLOCRRC;;; AU)(A;; CCDCLCSWRPWPDTLOCRSDRCWDWO;;; BA)(A;; CCLCSWRPWPDTLOCRRC;;; SY)

A ACL importante nesse caso é a do usuário autenticado (AU), como o TS é executado como um serviço de rede, ele depende da presença dessa ACL para abrir com êxito o serviço de spooler. Adicionar a seguinte ACL de volta corrigiu o problema.

(UMA;; CCLCSWLOCRRC;;; AU)

O método a seguir pode ser implementado para adicionar a ACL ausente.

Execute o comando a seguir:

c:\>sc sdshow spooler >temp.txt  

Você veria todas as ACLs, exceto as ACLs "(A;; CCLCSWLOCRRC;;; AU)" quando você abre o arquivo de texto.

Veja a seguir um exemplo: (você pode ver uma saída diferente dependendo das permissões definidas no spooler)

D:(A;; CCLCSWLOCRRC;;; AU)(A;; CCDCLCSWRPWPDTLOCRSDRCWDWO;;; BA)(A;; CCLCSWRPWPDTLOCRRC;;; SY)

Você pode então copiar a saída acima em um bloco de notas da seguinte maneira:

sc sdset spooler D: (A;; CCLCSWLOCRRC;;; AU)(A;; CCLCSWLOCRRC;;; AU)(A;; CCDCLCSWRPWPDTLOCRSDRCWDWO;;; BA)(A;; CCLCSWRPWPDTLOCRRC;;; SY)

Observação

Certifique-se de anexar o spooler "sc sdset D: (A;; CCLCSWLOCRRC;;; AU)" do comando acima para a saída que você vê no seu caso.

Copie e cole esse comando no prompt de comando. (Certifique-se de que "(A;; CCLCSWLOCRRC;;; AU)" aparece no início. Caso contrário, isso pode não funcionar.)

Ao executar o comando acima, você retém as ACLs antigas e também adiciona a ACL ausente que é a do usuário autenticado (AU).

Mais informações

A seguir está uma lista de mais algumas coisas que podem ser analisadas em um problema de "Redirecionamento de impressora não está funcionando":

  1. Se os computadores cliente estiverem executando o Windows XP, verifique se o .NET Framework 3.5 SP1 está instalado e se pelo menos o RDC 6.1 está sendo usado.
  2. Mesmo que o RDC 6.1 ou superior seja usado, o usuário deve instalar uma versão com suporte do .NET Framework separadamente. O Microsoft .NET Framework 3.5 (que inclui o .NET Framework 3.0 SP1) pode ser baixado do Centro de Download da Microsoft.
  3. Se você se conectar pelo Gateway de Área de Trabalho Remota, verifique se a política que desabilita o redirecionamento de impressora está desativada.
  4. Se o servidor também for um controlador de domínio, consulte Instalar o serviço de função Host da Sessão da Área de Trabalho Remota no Windows Server sem o serviço de função do Agente de Conexão.
  5. A Política de Grupo deve ser configurada corretamente para habilitar a Impressão Fácil no Servidor. O local da política é "Modelos administrativos de configuração > do computador, componentes > do Windows, serviços > de área de trabalho remota, sessão de área de trabalho remota, redirecionamento de impressora de host>".> A configuração "Usar primeiro o driver de impressora Easy Print da Área de Trabalho Remota" deve ser definida como "Ativada" para redirecionamento de Impressão Fácil e deve ser "Desabilitada" para Impressão Legada. Para "Não configurado", a Impressão Fácil é escolhida por padrão.
  6. Certifique-se de que a caixa de seleção Impressoras na janela do cliente (mstsc.exe) na guia Recursos Locais esteja marcada. A configuração correspondente no arquivo RDP associado é "redirectprinters:i:1".

Coleta de dados

Se você precisar de ajuda do suporte da Microsoft, recomendamos coletar as informações seguindo as etapas mencionadas em Coletar informações usando o TSS para problemas relacionados à Experiência do Usuário.