Notas de versão doVisual Studio 2019 2019 versão 16.1



| Developer Community System Requirements | Compatibility | Code Release | History | Terms Blogs | Whats | New in Visual Studio Docs


Observação

Esta não é a versão mais recente do Visual Studio. Para baixar a versão mais recente, visite o site do Visual Studio .



Novidades no Visual Studio 2019 versão 16.1

Período de suporte

Esta versão agora está sem suporte. Para obter mais informações sobre o suporte do Visual Studio, examine a Política de Suporte do Visual Studio 2019.

Consulte a versão mais recente das notas de versão ou visite o site do Visual Studio para baixar a versão mais recente com suporte do Visual Studio 2019.

Lançamento das versões do Visual Studio 2019 versão 16.1

Blog do Visual Studio 2019

O Blog do Visual Studio 2019 é a fonte oficial de insights do produto da equipe de engenharia do Visual Studio. É possível encontrar informações detalhadas sobre as versões do Visual Studio 2019 nas seguintes postagens:


Ícone de Notas de Versão Visual Studio 2019 versão 16.1.6

lançado em 9 de julho de 2019

Avisos de Consultoria de Segurança

CVE-2019-1077 Vulnerabilidade da Atualização Automática da Extensão do Visual Studio

Há uma vulnerabilidade de elevação de privilégio quando o processo de atualização automática da Extensão do Visual Studio executa incorretamente determinadas operações de arquivo. Um invasor que explorar com êxito essa vulnerabilidade poderá excluir esses arquivos em localizações arbitrárias. Para explorar essa vulnerabilidade, um invasor precisaria de acesso sem privilégios a um sistema vulnerável. A atualização de segurança corrige a vulnerabilidade protegendo as localizações nas quais a atualização automática da Extensão do Visual Studio executa as operações de arquivo.

CVE-2019-1075 Vulnerabilidade de Falsificação do ASP.NET Core

Há uma vulnerabilidade de falsificação no ASP.NET Core que pode gerar um redirecionamento aberto. Se um invasor explorasse a vulnerabilidade, poderia redirecionar um usuário de destino para um site mal-intencionado. Para explorar a vulnerabilidade, o invasor poderia enviar um link de uma URL criada especialmente para isso e convencer o usuário a clicar nele.

A atualização de segurança resolve a vulnerabilidade corrigindo o modo como o ASP.NET Core analisa as URLs. Veja mais detalhes nas notas sobre a versão do .NET Core.

CVE-2019-1113 A desserialização de XOML do WorkflowDesigner permite a execução de código

Um arquivo XOML referenciando determinados tipos poderia fazer com que o código aleatório fosse executado quando o arquivo XOML fosse aberto no Visual Studio. Agora há uma restrição para quais tipos têm permissão para serem usados em arquivos XOML. Se um arquivo XOML contendo um dos tipos recentemente não autorizados for aberto, será exibida uma mensagem explicando que o tipo é não autorizado.

Saiba mais em https://support.microsoft.com/help/4512190/remote-code-execution-vulnerability-if-types-are-specified-in-xoml.


Ícone de Notas de Versão Visual Studio 2019 versão 16.1.5

lançado em 2 de julho de 2019

###Summary de problemas resolvidos no Visual Studio 2019 versão 16.1.5


Ícone de Notas de Versão Visual Studio 2019 versão 16.1.4

lançado em 25 de junho de 2019

Resumo dos problemas corrigidos no Visual Studio 2019 versão 16.1.4


Ícone de Notas de Versão Visual Studio 2019 versão 16.1.3

lançado em 11 de junho de 2019

Resumo dos problemas corrigidos no Visual Studio 2019 versão 16.1.3


Ícone de Notas de Versão Visual Studio 2019 versão 16.1.2

lançado em 4 de junho de 2019

Resumo dos problemas corrigidos no Visual Studio 2019 versão 16.1.2


Ícone de Notas de Versão Visual Studio 2019 versão 16.1.1

lançada em 24 de maio de 2019

Resumo dos problemas corrigidos no Visual Studio 2019 versão 16.1.1


Ícone de Notas de Versão Visual Studio 2019 versão 16.1

lançada em 21 de maio de 2019

Resumo das novidades no Visual Studio 2019 versão 16.1

IDE

  • O Visual Studio IntelliCode está disponível e vem instalado com qualquer carga de trabalho compatível com C#, C++, Typescript/JavaScript ou XAML.
  • Adicionamos suporte a reconhecimento por monitor.
  • Novas correções de código estão disponíveis para C#.
  • Itens usados mais recentemente foram adicionados à Pesquisa do Visual Studio.

Depurador

  • As melhorias de autenticação do Link de origem foram implementadas.
  • Adicionamos servidor de símbolos nuget.org à lista de servidores de símbolos padrão.
  • A versão prévia de Depuração de Viagem no Tempo agora inclui suporte à depuração passo a passo de exceção.

Extensibilidade

  • Removemos a necessidade de arquivo .resx em projetos do VSIX (atualização de BuildTools).
  • Agora o modelo de projeto do VSIX usa a nova versão do SDK.

Desempenho

  • Experiência de otimização do usuário para aprimorar o tempo de carregamento da solução de soluções muito grandes.
  • Autores de modelo podem adicionar marcas personalizadas a seus modelos.
  • Suporte do CodeLens para interface do usuário personalizada.
  • Fornecemos atualizações para a implementação do Language Server Protocol.
  • Comportamento atualizado para alternar entre as soluções, pastas e outras exibições.

C++

F#

.NET

  • Novos recursos de produtividade do .NET incluem a limpeza de código com um clique em projetos e soluções, um novo atalho de teclado para alternância de comentário de bloco, refatoração para mover os tipos para outros namespaces.
  • Agora os usuários podem clonar o código de um URI SSH por meio da tela de clone na janela inicial.
  • As adições ao .NET Productivity contam com o preenchimento do IntelliSense para tipos não importados, opção de ativar/desativar a inserção e remoção de marca de comentário de linha única, exportação de estilos de nomenclatura para o editorconfig e uma nova configuração de estilo de código para preferência de usos dentro/fora de namespaces.
  • Adições de ferramentas do .NET SDK implementadas para dar suporte a projetos com WinForms e WPF para .NET Core 3.0, além de correções de bugs e melhorias de desempenho.
  • SDK do Visual Studio v16.0 lançado para o NuGet.
  • Uma versão prévia do Designer XAML foi lançada para desenvolvimento com .NET Core 3.0 WPF.

Xamarin

Principais problemas corrigidos no Visual Studio 2019 versão 16.1

Detalhes das novidades no Visual Studio 2019 versão 16.1

  • O IntelliCode agora está disponível e vem instalado com qualquer carga de trabalho compatível com C#, C++, Typescript/JavaScript ou XAML.
  • A versão prévia de recursos do IntelliCode (Modelos personalizados, suporte para C++/TS/JS e inferência do Editorconfig) está desativada por padrão. Para habilitá-los, acesse o IntelliCode de Opções > de Ferramentas>.
  • O modelo do Editorconfig (IntelliCode) foi removido do Assistente de Novo Item. Para criar uma configuração de Editor inferida, clique com o botão direito do mouse no local desejado no Gerenciador de Soluções e escolha Adicionar > Novo EditorConfig (IntelliCode).
  • Use a janela inicial para clonar o código de um repositório online por meio do SSH.
Clonar com SSH na janela inicial
Clonar com SSH na janela inicial
  • O Visual Studio IntelliCode é instalado por padrão ao instalar qualquer carga de trabalho compatível com C#, XAML ou C++.
    • Modelos de base C# e XAML serão ativados por padrão.
    • Recursos de visualização, como treinamento de modelo personalizado e conclusão de argumentos, podem ser habilitados por meio do IntelliCode de Opções > de Ferramentas>.
  • Adicionado suporte a reconhecimento por monitor
  • Novas correções de código disponíveis para C#.
  • Adicionado suporte a reconhecimento por monitor para a janela PropertyBrowser do Visual Studio baseada em WinForms. Requer a versão RTM 4.8 do .NET Framework instalada no computador.
  • O Link de Origem agora pode usar a autenticação do Windows para dar suporte ao controle do código-fonte do TFS local.
  • Servidor de símbolos nuget.org adicionado à lista de servidores de símbolos padrão

Project

  • O botão para mudar o modo de exibição do Gerenciador de Soluções agora mostrará consistentemente um menu suspenso de todos os modos de exibição possíveis.
Comutação de solução
Alternância de modo de exibição da solução
  • Tempo de carregamento aprimorado para soluções muito grandes. A melhoria varia de acordo com o tamanho das soluções.

  • Removeu a caixa de diálogo Converter em Conversão de Arquivos > . Esse recurso foi preterido anteriormente no Visual Studio 2015.

  • Atualizadas as regras de validação para os esquemas task.vs.json e launch.vs.json. Adicionadas descrições para as propriedades.

  • Adicionado suporte para depuração remota do Linux usando um programa personalizado por meio de launch.vs.json.

Extensibilidade

  • Agora os usuários podem usar a versão mais recente do Microsoft.VisualStudio.SDK para direcionar suas extensões ao Visual Studio 2019. Lembre-se de usar esta versão do SDK somente se a versão mais antiga compatível do Visual Studio for a 16.0.
  • A criação de novos projetos VSIX agora contém a versão 16.0 do pacote do NuGet Microsoft.VisualStudio.SDK.
  • Agora os usuários podem adicionar marcas aos seus modelos de projeto para habilitar a categorização e filtragem na caixa de diálogo Novo Projeto do Visual Studio 2019. Os usuários também podem escolher entre as marcas internas ou suas próprias marcas personalizadas de linguagem, plataforma e tipo de projeto.
Marcação de modelo
Marcação de modelo
  • Extensões de CodeLens agora podem exibir o conteúdo de interface do usuário arbitrário em seu pop-up de detalhes do CodeLens.

  • Language Server Protocol atualizado com:

    • Suporte para buffers projetados para habilitar o LSP para comparação em linha e arquivos do Razor em LiveShare.
    • Suporte para diagnóstico desnecessário.
    • Suporte para textDocument/typeDefinition.
    • Suporte para textDocument/foldingRange (estrutura de tópicos).
  • Removida a necessidade de arquivo .resx em projetos do VSIX (atualização de BuildTools)

  • O pacote do NuGet Microsoft.VSSDK.BuildTools agora fornecerá um arquivo .resx vazio como parte do build se nenhum .resx com a propriedade MergeWithCTO existir. A maioria das extensões não usa nem precisa de um arquivo .resx para mesclar, portanto, isso manterá o projeto mais limpo.

  • As alterações de reconhecimento por monitor podem afetar algumas extensões. Saiba mais sobre o suporte dos Extensores do Visual Studio a reconhecimento por monitor.

Editor

  • A Pesquisa do Visual Studio agora exibirá com destaque as três ações usadas mais recentemente invocadas por meio da Pesquisa do Visual Studio, conforme mostrado no modelo de exemplo. (Observação: ícones e itens de linha específicos não foram totalmente atualizados nesse modelo.)
Pesquisa do Visual Studio
Modelo da Pesquisa do Visual Studio

C++

  • Use a instalação local do WSL (Subsistema do Windows para Linux) com C++ nativamente no Visual Studio sem configuração adicional ou conexão SSH.
Subsistema do Windows para Linux
Subsistema do Windows para Linux
  • O AddressSanitizer agora está integrado ao Visual Studio para projetos do Linux e WSL.
Integração do ASan
Integração a ASan
  • Agora os usuários podem separar computadores de build remoto de computadores de depuração remota ao direcionar para Linux, em projetos do MSBuild e do CMake.
  • As dicas de ferramenta Informações Rápidas agora contêm um link para pesquisar documentos online para saber mais sobre a construção do código. No caso do código sublinhado em vermelho, o link em Informações Rápidas procurará o erro online.
  • O código nas dicas de ferramenta Informações Rápidas agora é colorido para refletir sua colorização no editor.
Código colorido nas dicas de ferramentas de Informações Rápidas
Código coloridos em dicas de ferramenta Informações Rápidas
  • Correções rápidas automáticas para os avisos de Análise de código C6001: o uso de <variável> de memória não inicializada e C26494 VAR_USE_BEFORE_INIT está disponível no menu de lâmpada em linhas relevantes, ativado por padrão no conjunto de regras nativas mínimas da Microsoft e nos conjuntos de regras de Tipo da Verificação Principal do C++, respectivamente.
Novas correções rápidas da Análise de Código
Novas correções rápidas de Análise de código
  • Armazena em cache os aperfeiçoamentos no Editor de Configurações do CMake, incluindo suporte para o WSL (Subsistema do Windows para Linux) e configurações de caches existentes, alterações ao build padrão e raízes de instalação, bem como suporte a variáveis de ambiente em configurações do Linux CMake.
Melhorias no Editor de Configurações do CMake
Melhorias no Editor de Configurações do CMake
  • O registro aprimorado para conexões remotas torna mais fácil diagnosticar problemas com o desenvolvimento multiplataforma.
Registro em log aprimorado para conexões remotas
Registro aprimorado para conexões remotas
  • Agora você pode separar seu computador de build remoto de seu computador para depuração remota ao direcionar para Linux (específico para projetos do MSBuild, disponível em breve para CMake).
  • A Barra de Modelo pode preencher o menu suspenso com base em instanciações desse modelo em sua base de código.
Menu suspenso Nova Barra de Modelos
Novo menu suspenso Barra de Modelo
  • O C++ IntelliCode agora é fornecido em caixa e pode ser habilitado em Opções > de Ferramentas > IntelliCode > Geral. Esta versão do IntelliCode tem precisão melhorada e inclui suporte para funções gratuitas.
  • A integração do CMake agora é compatível com a cadeia de ferramentas de Clang/LLVM para projetos direcionados ao Windows e/ou ao Linux. Agora você pode criar, editar e depurar projetos do CMake que usam Clang, MSVC ou GCC.
A integração do CMake dá suporte à cadeia de ferramentas Clang/LLVM
A integração do CMake é compatível com a cadeia de ferramentas de Clang/LLVM
  • Lâmpadas para #includes ausentes que podem ser instaladas por vcpkg e preenchimento automático de pacotes disponíveis para a diretiva find_package do CMake.
Preenchimento automático de pacotes disponíveis
Preenchimento automático de pacotes disponíveis
  • Atualizada a versão do CMake fornecida com o Visual Studio para 3.14. Esta versão adiciona suporte interno para geradores de MSBuild direcionados a projetos do Visual Studio 2019, bem como APIs de integração de IDE baseado em arquivo.

  • As Páginas de Propriedades Gerais de projetos C++ foram revisadas, dividindo algumas opções sob uma nova página Avançado. A página Avançado também inclui as propriedades adicionais de arquitetura preferencial do conjunto de ferramentas, bibliotecas de depuração, a versão secundária do conjunto de ferramentas MSVC e builds do Unity (jumbo).

  • As seguintes versões prévias de recursos do C++20 foram adicionados à nossa implementação da Biblioteca Padrão C++, disponível em /std:c++latest:

    • starts_with() e ends_with() para basic_string/basic_string_view.
    • contains() para contêineres associativos.
    • remove(), remove_if(), e unique() para list e forward_list agora retornam size_type.
    • shift_left() e shift_right() adicionados a <algorithm>.
  • As seguintes versões prévias dos recursos C++20 foram implementadas no compilador C++, disponível em /std:c++latest:

    • Maior capacidade de localizar os modelos de função por meio de pesquisa dependente de argumento para expressões de chamada de função com argumentos de modelo explícitos (P0846R0).
    • Inicialização atribuída (P0329R4), que permite que os membros específicos sejam selecionados na inicialização de agregação, por exemplo, usando a sintaxe Type t { .member = expr }.
  • O suporte a lambda foi revisado, resolvendo um grande número de bugs de longa data. Essa alteração é habilitada por padrão ao usar /std:c++latest. Em outros modos de linguagem /std:c++* e no modo padrão, o novo analisador pode ser habilitado por /experimental:newLambdaProcessor, por exemplo, /std:c++17 /experimental:newLambdaProcessor.

  • Documentação do CMake inclusa no editor

  • Os preenchimentos e informações rápidas para comandos internos CMake, variáveis e propriedades facilitam a edição dos arquivos CMakeLists.txt.

Informações de dica de ferramenta para add_subdirectory comando CMake
Informações de dica de ferramenta para o comando CMake add_subdirectory

F# e ferramentas do F#

Esta é uma versão relativamente secundária para a linguagem e as ferramentas de F#, mas contém algumas vantagens. Assim como na atualização do VS 16.0, esta versão também se concentrou no desempenho das ferramentas de edição.

Compilador F# e F# interativo
  • Adicionamos suporte a P/Invoke ao F# interativo no .NET Core (N.º 6544)
  • Adicionamos uma otimização do compilador para Span<'T> quando usado em um loop de for (N.º 6195)
  • Adicionamos uma otimização para evitar alocações Some incorretas para opções de F# em vários cenários (N.º 6532)
  • Alteramos a ordem de execução das expressões usadas na instanciação de registros anônimos para serem de cima para baixo, ao invés de alfabéticas, a fim de corresponder à experiência atual com registros normais (N.º 6487)
  • Solucionado um bug em que expressões literais muito grandes ou declarações de sctruct muito grandes podiam fazer com que o compilador acumulasse um excedente de pilha na compilação (N.º 6258)
  • Corrigido um bug em que pontos de interrupção não eram mais acionados na depuração de uma função com registros anônimos (N.º 6512)
  • Corrigido um bug em que registros anônimos passados para constructos que esperavam que um parâmetro obj causavam uma falha no compilador (N.º 6434)
  • Corrigido um bug em que loops de for var expr1 to expr2 do ... podiam resultar em uma sintaxe estranhamente válida (e descartada) (N.º 6586)
  • Corrigido um bug em que registros anônimos não podiam ser usados corretamente com eventos (N.º 6572)
  • Solucionado um bug antigo em que analisadores extremamente grandes eram gerados em FsLexYacc (mais de 100 milhões de linhas, N.º 5967)
  • Solucionado um problema antigo no componente de plug-in Provedor de Tipos do compilador que poderia deixar a porta aberta para uma perda de memória causada por um provedor de tipos (N.º 6409)
  • Adicionado suporte para --pathmap ao compilador F# por Saul Rennison, que resolve um problema em que o executável resultante de uma compilação incluiria caminhos absolutos para arquivos de origem no recurso de arquivo de assinatura F# inserido (N.º 5213)
  • Uma otimização para o AST de F# que melhora seu consumo por meio de outras ferramentas e ambientes (por exemplo, Fable) foi adicionada por ncave (N.º 6333)
  • Uma otimização em torno da passagem de informações ao resolver membros foi adicionada por Steffen Forkmann (N.º 4457)
  • Um aprimoramento para mensagens de erro, de modo que, quando uma implementação não contém substituições necessárias, uma lista dessas substituições é relatada, foi adicionado por Gauthier Segay (N.º 4982)
Ferramentas F#
  • A lista suspensa Estrutura de Destino para projetos F# no SDK do .NET agora incluirá valores para todos os valores .NET Core, .NET Standard e .NET Framework disponíveis, a fim de facilitar a migração para o .NET Core do .NET Framework no SDK do .NET
  • Foi corrigido um bug em que a renomeação de parâmetros de tipo genérico produz nomes com acento grave duplo (N.º 5389)
  • Solucionado um problema antigo em que os Provedores de Tipos eram instanciados novamente de forma redundante, causando alocações em massa ao longo do tempo (N.º 5929)
  • Solucionado um problema antigo em que a leitura de IL alocava desnecessariamente 20 MB em um curto período de tempo (N.º 6403)
  • Um bug em que o método GetToolTipText no serviço do compilador de F# podia mostrar a mesma assinatura XML para várias sobrecargas de membros foi resolvido por Vasily Kirichenko (N.º 6244)
Infraestrutura de software livre do F#

Por fim, aprimoramos a experiência de contribuição fazendo o seguinte:

  • Concluímos nossa compilação a partir do processo de origem para que o compilador e a biblioteca principal de F# possam ser compilados com o repositório de compilação de origem do .NET Core
  • Removemos nossa dependência em netstandard1.6 para que toda a base de código aponte para netstandard2.0 e net472 uniformemente
  • Adicionamos um arquivo .vsconfig à raiz do repositório para que os contribuidores que usam o Visual Studio não precisem saber com antecedência tudo o que deve ser instalado
  • Reescrevemos o LEIAME de nosso projeto para remover informações potencialmente confusas, incluir um início rápido para começar a contribuir e tentar ser mais inclusivos nas mensagens sobre os tipos de alterações que gostaríamos de fazer

Produtividade do .NET

  • Existe agora o preenchimento experimental do IntelliSense para tipos não importados! Agora os usuários receberão sugestões do IntelliSense para tipos em dependências em projetos mesmo se eles ainda não tiverem adicionado a declaração de importação ao arquivo. Ative essa opção no Editor > de Texto de Opções > de Ferramentas > C# > Intellisense.
Conclusão do intellisense para tipos sem suporte
Preenchimento do IntelliSense para tipos não importados
  • A opção de ativar/desativar a inserção e remoção de comentários de linha única está disponível por meio do atalho de teclado (Ctrl+K,/). Esse comando adiciona ou remove um comentário de linha única, dependendo do fato de sua seleção já estar comentada.
  • Capacidade de exportar estilos de nomenclatura com o botão "Gerar editorconfig" localizado no Estilo de Código C# > do Editor > de Texto de Opções > de Ferramentas>.
  • Capacidade de usar uma nova regra de estilo de código do editorconfig para exigir ou impedir usos dentro de um namespace. Essa configuração também será exportada ao usar o botão "Gerar editorconfig" localizado no Estilo de Código C# > do Editor > de Texto de Opções > de Ferramentas>.
Regra editorconfig para usos de namespaces externos/internos
Regra do Editorconfig para usos fora/dentro de namespaces
Configuração de Opções de Ferramentas para usos dentro/fora do namespace
Configuração Opções de Ferramentas para usos dentro/fora do namespace
  • A coluna "Tipo" de Localizar Todas as Referências agora tem mais opções de filtro e está ciente dos namespaces e tipos.
A coluna Localizar Todos os Tipos de Referências tem mais opções de filtro
A coluna do tipo Localizar Todas as Referências tem mais opções de filtro
  • Adicionamos uma correção de código para dividir/mesclar instruções if.
Dividir ou mesclar instruções se
Dividir ou mesclar instruções if
  • Adicionamos uma correção de código para encapsular expressões binárias.
Encapsular expressões binárias
Encapsular expressões binárias
  • Uma lista de preenchimentos de texto do regex agora pode ser acessada por meio do menu do intellisense (Ctrl + espaço) quando dentro de uma cadeia de caracteres do regex. Esses preenchimentos também incluem uma descrição na linha do que a sugestão faz.
Conclusão regex oferecida no Intellisense com (Ctrl + espaço)
Preenchimento de expressão regular
  • Adicionamos uma correção de código para desselar uma classe.
Desmarcar um codefix de classe
Desselar uma classe
  • Use a limpeza de código em um único clique para projetos e soluções. Clique com o botão direito do mouse em projetos ou na solução no Gerenciador de Soluções e selecione "Executar Limpeza de Código".
Clique com o botão direito do mouse para executar a limpeza de código em toda a solução
Clique com o botão direito do mouse para executar a limpeza de código em toda a solução
Você verá uma caixa de diálogo enquanto a limpeza é aplicada a cada arquivo
Uma caixa de diálogo é exibida enquanto a limpeza é aplicada a cada arquivo
  • Agora use uma caixa de diálogo de refatoração para mover o tipo para o namespace ou para a pasta. Coloque o cursor no nome de classe, pressione (Ctrl + .) para abrir o menu de ações e refatorações rápidas e selecione "Mover para o namespace". Isso inicia uma caixa de diálogo em que você pode selecionar o destino de namespace para o qual você gostaria de mover o tipo.
Coloque o cursor no nome e no tipo da classe (Ctrl+.) para exibir refatorações
Coloque o cursor no nome da classe e pressione (Ctrl+.) para exibir as refatorações
Selecione o namespace de destino
Selecione o namespace de destino
  • O Botão de Alternância Bloquear Comentário/Descompactação agora está disponível por meio do atalho de teclado (Ctrl+Shift+/) ou por meio de Editar > Comentário de Bloco de Alternância Avançada>. Este comando adicionará ou removerá os comentários de bloco, dependendo do que você selecionou.
Alternar comentário de bloco com (Ctrl+Shift+/)
Ative/desative o bloqueio de comentários com (Ctrl+Shift+/)
  • Agora há um codefix para transformar campos struct somente leitura em graváveis. Coloque o cursor no nome do struct, pressione (Ctrl + .) para abrir o menu de ações e refatorações rápidas e selecione "Transformar campos somente leitura em graváveis".
  • O codefix para adicionar um campo privado de um construtor e vice-versa é mais fácil de descobrir e mostrará quando qualquer parte do nome do campo for selecionada. Essa refatoração agora também oferece todos os construtores possíveis.

Visualização do Designer XAML para desenvolvimento de WPF do .NET Core 3.0

  • Não há uma versão prévia do Designer XAML para desenvolvedores que criam aplicativos do WPF do .NET Core 3.0 no Visual Studio. Muitos recursos de tempo de design estão indisponíveis no momento. Como essa é uma versão prévia, se você encontrar problemas como falhas, envie comentários sobre o Visual Studio à equipe para melhorar a experiência futura.
  • Com cada atualização para o Visual Studio 2019, continuaremos a implementar mais recursos que estavam disponíveis anteriormente no Designer XAML para aplicativos WPF do .NET Framework.

Ferramentas do SDK do .NET

Esta versão incluiu muito trabalho para desbloquear o uso do WPF no .NET Core:

  • Um problema em que uma caixa de diálogo de erro era exibida sempre que você adicionava um novo item a um projeto WinForms ou WPF do .NET Core foi resolvido (N.º 4486).
  • Suporte para arquivos XAML em projetos do SDK do .NET (N.º 1467) que inclui muitos itens menores de trabalho destinados a obter paridade de experiência com projetos .NET antigos.
  • Suporte ao item de menu de contexto para WinForms no .NET Core (N.º 137): Formulário do Windows, Controle de usuário, Componente e Classe.
  • Suporte ao item de menu de contexto para WPF no .NET Core (N.º 137): Janela, Página, Controle de usuário, Dicionário de recursos.
  • A janela Fonte de Dados agora está ativada para projetos do SDK do .NET, permitindo cenários comuns de gerenciamento de dados para WinForms (N.º 4479).

Separadamente, várias outras correções foram adicionadas nesta versão:

  • Os projetos do SDK do .NET agora são compatíveis com arquivos .razor (N.º 4468).
  • Um texto de ajuda acessível foi adicionado à página de propriedades Depurar, permitindo que seja lido por leitores de tela (N.º 4568).
  • Adicionamos uma configuração que permite desabilitar o clique duplo para abrir um arquivo de projeto (N.º 4493).
  • A opção de menu de contexto para editar um arquivo de projeto não inclui mais o nome do projeto, corrigindo um problema em que o menu de contexto podia ficar muito largo devido a um nome de projeto muito longo (N.º 1492).
  • Um bug em que a criação de uma fonte de dados com a interface do usuário de associação de dados criava dois arquivos .datasource foi corrigido (N.º 4485).
  • Um bug em que usar arquivos vinculados podia fazer com que o verificador atualizado falhasse foi resolvido (N.º 4580).
  • Vários erros envolvendo a resolução do pacote e a exibição de seu estado resolvido/não resolvido no nó Dependências foram corrigidos (N.º 2924, N.º 4577).

Veja uma lista completa dos problemas solucionados acessando o marco 16.1 no GitHub.

Xamarin

  • Atualizada a experiência do Android padrão para API 28 para modelos, criação de dispositivo, instaladores e muito mais.
  • O IntelliSense no Windows agora mostra recomendações para atributos de tempo de design durante a gravação de XAML do Xamarin.Forms.

Problemas conhecidos

Veja todos os problemas e soluções alternativas disponíveis no Visual Studio 2019 versão 16.1, seguindo o link abaixo.

Problemas conhecidos do Visual Studio 2019


Comentários e sugestões

Adoraríamos ouvir sua opinião! Em caso de problemas, informe-nos por meio da opção Relatar um Problema no canto superior direito do Instalador ou do próprio IDE do Visual Studio. O ícone Ícone de Comentários está localizado no canto superior direito. Você pode fazer uma sugestão de produto ou acompanhar os problemas na Comunidade de Desenvolvedores do Visual Studio, em que você pode fazer perguntas, encontrar respostas e propor novos recursos. Você também pode obter ajuda gratuita com a instalação por meio de nosso suporte via chat ao vivo.


Blogs

Aproveite as informações e recomendações disponíveis no site Blogs de Ferramentas de Desenvolvedor para ficar em dia com as novas versões e conferir postagens detalhadas sobre uma grande variedade de recursos.


Histórico de notas sobre a versão do Visual Studio 2019

Para obter mais informações sobre versões anteriores do Visual Studio 2019, consulte a página Histórico de notas sobre a versão do Visual Studio 2019.


Início da página