Partilhar via


Resolução de problemas com o Balanceador de Carga do Azure

Esta página fornece informações de solução de problemas para perguntas comuns básicas e padrão sobre o Balanceador de Carga do Azure. Para obter mais informações sobre o Balanceador de Carga Standard, veja Descrição geral do Balanceador de Carga Standard.

Quando a conectividade do Balanceador de Carga não está disponível, os sintomas mais comuns são os seguintes:

  • As VMs por trás do Balanceador de Carga não estão respondendo a testes de integridade
  • As VMs por trás do Balanceador de Carga não estão respondendo ao tráfego na porta configurada

Quando os clientes externos para as VMs de back-end passam pelo balanceador de carga, o endereço IP dos clientes é usado para a comunicação. Verifique se o endereço IP dos clientes foi adicionado à lista de permissões do NSG.

Problema: Nenhuma conectividade de saída de ILB (Load Balancers) interno padrão

Validação e Resolução

Os ILBs padrão são seguros por padrão. Os ILBs básicos permitiam conectar-se à Internet através de um endereço IP público oculto chamado IP de acesso de saída padrão. Isso não é recomendado para cargas de trabalho de produção, pois o endereço IP não é estático ou bloqueado por meio de grupos de segurança de rede de sua propriedade. Se você mudou recentemente de um ILB Básico para um ILB Padrão, deverá criar um IP Público explicitamente por meio da configuração Somente saída, que bloqueia o IP por meio de grupos de segurança de rede. Você também pode usar um gateway NAT em sua sub-rede. NAT Gateway é a solução recomendada para saída.

Problema: Não há conectividade de entrada com balanceadores de carga externos padrão (ELB)

Motivo

Os balanceadores de carga padrão e os endereços IP públicos padrão são fechados para conexões de entrada, a menos que sejam abertos por Grupos de Segurança de Rede. Os NSGs são usados para permitir explicitamente o tráfego permitido. Se você não tiver um NSG em uma sub-rede ou NIC do seu recurso de máquina virtual, o tráfego não terá permissão para alcançar esse recurso.

Resolução

Para permitir o tráfego de entrada, adicione um Grupo de Segurança de Rede à Sub-rede ou interface do seu recurso virtual.

Problema: Não é possível alterar a porta de back-end para a regra LB existente de um balanceador de carga que tenha o Conjunto de Dimensionamento de Máquina Virtual implantado no pool de back-end.

Motivo

A porta de back-end não pode ser modificada para uma regra de balanceamento de carga usada por uma sonda de integridade para balanceador de carga referenciado pelo Conjunto de Dimensionamento de Máquina Virtual

Resolução

Para alterar a porta, você pode remover a sonda de integridade atualizando o Conjunto de Dimensionamento de Máquina Virtual, atualizando a porta e configurando a sonda de integridade novamente.

Problema: O tráfego pequeno ainda está passando pelo balanceador de carga depois de remover VMs do pool de back-end do balanceador de carga.

Motivo

As VMs removidas do pool de back-end não devem mais receber tráfego. A pequena quantidade de tráfego de rede pode estar relacionada ao armazenamento, DNS e outras funções no Azure.

Resolução

Para verificar, você pode realizar um rastreamento de rede. O FQDN (Nome de Domínio Totalmente Qualificado) usado para sua conta de armazenamento de blob está listado nas propriedades de cada conta de armazenamento. A partir de uma máquina virtual na sua subscrição do Azure, pode executar nslookup para determinar o IP do Azure atribuído a essa conta de armazenamento.

Problema: Balanceador de carga em estado de falha

Resolução

  • Depois de identificar o recurso que está em um estado de falha, vá para o Gerenciador de Recursos do Azure e identifique o recurso nesse estado.
  • Atualize a alternância no canto superior direito para Leitura/Gravação.
  • Selecione Editar para o recurso em estado de falha.
  • Selecione PUT seguido de GET para garantir que o estado de provisionamento foi atualizado para Succeeded.
  • Em seguida, você pode prosseguir com outras ações, pois o recurso está fora do estado de falha.

Capturas de rede necessárias para solução de problemas e casos de suporte

Se você decidir abrir um caso de suporte, colete as seguintes informações para uma resolução mais rápida. Escolha uma única VM de back-end para executar os seguintes testes:

  • Use ps ping a partir de uma das VMs de back-end dentro da rede virtual para testar a resposta da porta de teste (exemplo: ps ping 10.0.0.4:3389) e registrar resultados.
  • Se nenhuma resposta for recebida nesses testes de ping, execute um rastreamento Netsh simultâneo na VM de back-end e na VM de teste de rede virtual enquanto executa o PsPing e, em seguida, pare o rastreamento Netsh.

Próximos passos

Se as etapas anteriores não resolverem o problema, abra um tíquete de suporte.