Mailbox migration times out when going from Exchange OnPrem to O365
ISSUE:
When attempting to migrate an onPrem User mailbox from Exchange 2013 to O365, the following error is generated and the migration fails:
The request channel timed out while waiting for a reply after 00:00:00.0012345. Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout.
CAUSE:
This typically happens when the ExchangeGUID property of the mail-enabled user in O365 does not match the ExchangeGUID property of the corresponding on-premises mailbox that you are trying to migrate. The migration will then timeout because it is trying to look up the wrong ExchangeGUID and will never find it.
RESOLUTION:
Set the ExchangeGUID property of the mail-enabled user in Exchange Online (O365) to match the ExchangeGUID property of the corresponding on-premises mailbox, and then retry the move. To do this, follow these steps:
Retrieve the value of the ExchangeGUID property for the on-premises mailbox that you want to move. To do this, open the Exchange Management Shell on the on-premises server, and then run the following command:
Get-Mailbox <MailboxName> | Format-List ExchangeGUID
Make a note of the value. You'll need it later in step 2B.
Connect to Exchange Online by using remote PowerShell. Then, do the following:
A. Determine the value of the ExchangeGUID property of the mail-enabled user in Exchange Online. To do this, run the following command:
Get-MailUser -Identity <UserName> | fl displayname,ExchangeGuid
B. Set the value of the ExchangeGUID property of the mail-enabled user in Exchange Online to match the ExchangeGUID property of the on-premises mailbox. To do this, run the following command:
Set-MailUser -Identity <UserName> -ExchangeGUID <Value Retrieved From Step 1>
Retry the move.
NOTES:
There are other similar issues but I see this one more than any other when it comes to failed migrations, so I am singling it out for the purpose of this article. If this does not address your issue, please refer to TechNet for other possibilities.
Comments
- Anonymous
April 15, 2017
Great stuffThanks