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Email enabled document libraries stop receiving emails

We have encountered issues related to email enabled document libraries stop receiving emails.

After investigations listed below is the synopsis of the issue.

Background

  • Intermitently we have encountered (on different environments) issues with email enabled libraries stop receiving emails
  • Emails enabled document library successfully received emails for months
  • Suddenly document library stops getting emails
  • Within the configuration of the doc lib, we see that the doc lib is still email enabled, but it would not received emails
  • Within the ULS log there is a message “The following aliases were unknown: XXXX” as SharePoint cannot verify\locate the email alias

 

Result

  • Emailed enabled document library stop receiving emails
  • As SharePoint does not send back notifications for emails it could not process, sender is unaware that the emails did not reach its destination in SharePoint
  • Within document settings, the document library still shows as email enabled

 

Cause

  • A triggering event (at present this is unknown as we cannot recreate it in dev\test) causes email alias to be marked as deleted within MOSS_CONFIG.EmailEnabledList table

 

Fix

  • Disable and enable again the email setting within the document library
  • Run “stsadm –o refreshdms –url <web application url>”. Note: This command will re-sync and enable all email enabled document library present within a specific web application.

 

Workaround

  • Until we are able to identify the triggering event, we are
    • Proactively monitoring the MOSS_CONFIG.EmailEnabledList table to check for any email enabled list with Deleted column = true. This is an indicator that email enabled document library may not be receiving emails.
    • If we encounter such a scenario, then we run “stsadm –o refreshdms –url <web application url>” noted in the Fix section above or reset the email enabled setting

 

Currently looking into the triggering event, hence if we find one, I will post it.

Comments

  • Anonymous
    November 25, 2008
    The comment has been removed

  • Anonymous
    January 20, 2009
    Can you paste the command that you are executing? Pls paste within double quotes. Thanks

  • Anonymous
    April 13, 2009
    I've been searching for an answer to this problem for days.  When I run the command, it processes, and I get: Error in the application I am also not able to use the web interface to disable incoming email on a previously email enabled list that is malfunctioning. Any help will be greatly appreciated!

  • Anonymous
    February 24, 2010
    Thanks Sameers, I had the same issue hat one library stopped receiving e-mail. I did disable and enable it started working. But I never had this on SharePoint 03. Is this a MOSS related issue?

  • Anonymous
    March 09, 2010
    Found a KB reporting similar issue http://support.microsoft.com/kb/961750

  • Anonymous
    May 03, 2010
    Hi Sameer I am beginner of Share point Server 2007. ( I dont have URL so I put google in that ) I am not able to set Incoming email for my document library. Please help me as early as possible my email id is akhot@halesi.com Thanks, Amol.

  • Anonymous
    May 13, 2010
    Hi , I have a same problem occurs in my farm. Email alert has been stopped after updating the patch. When I do the stsadm -o refreshdms -url it says "Error in application" also some time it comes like 401 http error Please suggest. SP888

  • Anonymous
    September 30, 2010
    I am not using DMS will this command still work. Thanks

  • Anonymous
    October 26, 2010
    Worked Like a charm Sameer.  You are the man.  Thanks so much for the post.

  • Anonymous
    May 23, 2012
    Hello. When I try to run the stsadm.exe -o refreshdms -url http://server/site/subsite., I am getting the following error: Unable to assign this e-mail address to the list, because the address is in use. When I change the doc lib settings disabled the incoming emails and ran the same command still not lucky. I tried with http:/server/ http://server/site/subsite and http://server/site/subsite/doclib/Forms/AllItems.aspx with enable and disabled modes... Is there some thing I am missing in running this command. Thank you

  • Anonymous
    February 19, 2016
    @ Niceguy Not sure if it helps but you need to reset IIS to associate the email address again to the list.