Códigos de erro de ingestão de dados

Este artigo contém códigos de erro que podem ocorrer durante a ingestão de dados.

Quando ativa os registos de diagnóstico de ingestão falhada no seu cluster, pode ver códigos de erro no registo de operaçõesde ingestão falhada.

Pode usar o comando .show ingestion failures para apresentar informação sobre falhas de gestão de dados em gestão de dados, embora este comando exclua falhas de outras fases do processo de ingestão. Para uma visão abrangente das falhas em todas as fases, consulte métricas de ingestão e registos de diagnóstico.

A métrica de resultado de ingestão fornece informação sobre a Categoria de erros de ingestão, embora não mostre os códigos de erro específicos. Os erros neste artigo estão organizados por estas categorias.

Note

Para erros transitórios ou erro 'General_RetryAttemptsExceeded', tentar novamente a ingestão pode ter sucesso.

Categoria: MauFormato

Mensagem de erro Descrição Permanente/Transitório
Stream_NúmeroErradoDeCampos Número inconsistente de campos nos registos de entrada. HRESULT: 0x80DA0008 Permanent
Stream_ClosingQuoteMissing Formato CSV inválido. Falta-se a citação final. HRESULT: 0x80DA000b Permanent
BadRequest_InvalidBlob Blob é inválido. Permanent
BadRequest_EmptyArchive O arquivo está vazio. Permanent
BadRequest_InvalidArchive O arquivo é inválido. Permanent
BadRequest_InvalidMapping Falhei em analisar o mapeamento de ingestão.
Para mais informações sobre como escrever mapeamento de ingestão, consulte Mapeamentos de dados.
Permanent
BadRequest_InvalidMappingReference Referência de mapeamento inválida. Permanent
BadRequest_FormatNotSupported O formato não é suportado. Isto pode dever-se ao facto de estares a usar um formato não suportado por uma ligação de dados específica.
Para mais informações sobre formatos de dados suportados para ingestão, consulte Formatos de dados suportados.
Permanent
BadRequest_InconsistentMapping O mapeamento de ingestão suportado não é consistente com o esquema da tabela existente. Permanent
BadRequest_UnexpectedCharacterInInputStream Carácter inesperado no fluxo de entrada. Permanent

Categoria: MauPedido

Mensagem de erro Descrição Permanente/Transitório
BadRequest_EmptyBlob O blob está vazio. Permanent
BadRequest_SemRegistosOuFormatoErrado O blob está vazio ou o formato de ingestão especificado não corresponde ao conteúdo do blob (por exemplo, JSON o formato usado em vez de MULTIJSON). Permanent
BadRequest_EmptyBlobUri Blob Uri está vazio. Permanent
BadRequest_DuplicateMapping As propriedades de ingestão incluem tanto ingestionMapping como ingestionMappingReference, o que não é válido. Permanent
BadRequest_InvalidOrEmptyTableName O nome da tabela está vazio ou inválido.
Para mais informações sobre convenções de nomenclatura, consulte Nomes de entidades.
Permanent
BadRequest_EmptyDatabaseName O nome da base de dados está vazio. Permanent
BadRequest_EmptyMappingReference Alguns formatos devem receber o mapeamento de ingestão para ser ingerido e a referência de mapeamento fica vazia.
Para mais informações sobre mapeamento, consulte Mapeamento de Dados.
Permanent
Download_BadRequest Falhei em descarregar o código-fonte do Armazenamento do Azure devido a um pedido inadequado. Permanent
BadRequest_MissingMappingtFailure Os formatos Avro e Json devem ser ingeridos com o parâmetro ingestionMapping ou ingestionMappingReference. Permanent
Stream_NoDataToIngest Não encontrei dados para ingerir.
Para dados em formato JSON, este erro pode indicar que o formato JSON era inválido.
Permanent
Stream_DynamicPropertyBagTooLarge Os dados contêm valores demasiado grandes numa coluna dinâmica. HRESULT: 0x80DA000E Permanent
General_BadRequest Pedido inválido. Permanent
BadRequest_CorruptedMessage A mensagem está corrompida. Permanent
BadRequest_SyntaxError Solicitar erro de sintaxe. Permanent
BadRequest_ZeroRetentionPolicyWithNoUpdatePolicy A tabela não tem política de retenção e não é a tabela fonte para qualquer política de atualização. Permanent
BadRequest_CreationTimeEarlierThanSoftDeletePeriod O tempo de criação especificado para ingestão, não está dentro do SoftDeletePeriod.
Para mais informações sobre SoftDeletePeriod, veja O objeto da política.
Permanent
BadRequest_NotSupported Pedido não suportado. Permanent
Download_SourceNotFound Falhou o download do código-fonte do Armazenamento do Azure. Fonte não encontrada. Permanent
BadRequest_EntityNameIsNotValid O nome da entidade não é válido.
Para mais informações sobre convenções de nomenclatura, consulte Nomes de entidades.
Permanent
BadRequest_MalformedIngestionProperty A propriedade de ingestão está deformada. Permanent
BadRequest_IngestionPropertyNotSupportedInThisContext A propriedade de ingestão não é suportada neste contexto. Permanent
BadRequest_NonMultiDatabaseDataConnection O evento contém a propriedade 'Database' que encaminha dados ingeridos para uma base de dados diferente da base de dados de destino configurada nas definições da ligação de dados. No entanto, como a ligação não está configurada para permitir o encaminhamento para múltiplas bases de dados, o encaminhamento dinâmico da base de dados não é permitido. Permanent
BadRequest_InvalidBlobUri O URI do blob é inválido. Permanent
BadRequest_DataCapacityLimitReached A conta de armazenamento atingiu o seu limite de capacidade de dados. Permanent
BadRequest_InvalidManagedIdentity A Identidade Gerida ou não existe ou não tem as permissões necessárias. Permanent

Categoria: DataAccessNotAuthorized

Mensagem de erro Descrição Permanente/Transitório
Download_AccessConditionNotSatisfied Falhou o download do código-fonte do armazenamento do Azure. Condição de acesso não satisfeita. Permanent
Download_Forbidden Falhou o download do código-fonte do armazenamento do Azure. Acesso proibido. Permanent
Download_AccountNotFound Falhou o download do código-fonte do armazenamento do Azure. Conta não encontrada. Permanent
BadRequest_TableAccessDenied O acesso à mesa é negado.
Para obter mais informações, consulte Controle de acesso baseado em função.
Permanent
BadRequest_DatabaseAccessDenied O acesso à base de dados é negado.
Para obter mais informações, consulte Controle de acesso baseado em função.
Permanent
BadRequest_InvalidAuthentication A autenticação dos dados não é válida. Permanent

Categoria: DownloadFalhado

Mensagem de erro Descrição Permanente/Transitório
Download_NotTransient Falhou o download do código-fonte do armazenamento do Azure. Não ocorreu erro transitório Permanent
Download_UnknownError Falhou o download do código-fonte do armazenamento do Azure. Ocorreu um erro desconhecido Transient
Download_TransientNameResolutionFailure Falhou o download do código-fonte do armazenamento do Azure. Ocorreu falha na resolução de nomes de conta de armazenamento transitório Transient

Categoria: EntidadeNãoEncontrada

Mensagem de erro Descrição Permanente/Transitório
BadRequest_MappingReferenceWasNotFound Não foi encontrada referência de mapeamento. Permanent
BadRequest_DatabaseNotExist A base de dados não existe. Permanent
BadRequest_TableNotExist Tabela não existe. Permanent
BadRequest_EntityNotFound A entidade (como mapeamento, base de dados ou tabela) não foi encontrada. Permanent

Categoria: FicheiroDemasiadoLarge

Mensagem de erro Descrição Permanente/Transitório
Stream_InputStreamTooLarge O tamanho total dos dados de entrada ou de um único campo nos dados é demasiado grande. HRESULT: 0x80DA0009
Para mais informações sobre o limite de tamanho para este tipo de ingestão, veja O tipo de dados da cadeia.
Permanent
BadRequest_FileTooLarge O tamanho do blob ultrapassou o limite permitido para ingestão. Permanent

Categoria: ErroServiço Interno

Mensagem de erro Descrição Permanente/Transitório
General_InternalServerError Ocorreu um erro interno do servidor. Transient
General_TransientSchemaMismatch O esquema da tabela alvo ao iniciar a ingestão não corresponde ao esquema ao fazer commit da ingestão. Transient
Timeout A operação foi abortada devido ao tempo morto. Transient
ForaDeMemória A operação de ingestão ficou sem memória. Transient
ServiceUnavailable_StreamingIngestionDatabaseUnderMaintenance A ingestão de streaming está temporariamente indisponível porque a política de ingestão de streaming em base de dados está em manutenção. Transient
ServiceUnavailable_StreamingIngestionMaintenanceModeWriteProtected A ingestão de streaming está temporariamente indisponível porque a base de dados está protegida contra escrita para manutenção. Transient
ServiceUnavailable_StreamingIngestionMetadataUnavailable A ingestão de streaming está temporariamente indisponível porque os metadados de serviço necessários não puderam ser recuperados. Transient
Schema_PermanentUpdateFailure Falhou a atualização permanente do esquema. Permanent

Categoria: AtualizaçãoPolíticaFalha

Mensagem de erro Descrição Permanente/Transitório
UpdatePolicy_QuerySchemaDoesNotMatchTableSchema Falharam em invocar a política de atualização. Query schema não corresponde ao esquema de tabela. Permanent
UpdatePolicy_FailedDescendantTransaction Falharam em invocar a política de atualização. Política de atualização transacional de descendentes falhada. Transient
UpdatePolicy_IngestionError Falharam em invocar a política de atualização. Ocorreu um erro de ingestão.
O erro é reportado na tabela de origem da política de atualização.
Transient
UpdatePolicy_UnknownError Falharam em invocar a política de atualização. Ocorreu um erro desconhecido.
O erro é reportado na tabela alvo da política de atualização.
Transient
UpdatePolicy_Cyclic_Update_Not_Allowed Falharam em invocar a política de atualização. A atualização cíclica não é permitida. Permanent
UpdatePolicy_BadRequest Falhei em invocar a política de atualização devido a um pedido inadequado,
por exemplo, um erro semântico de consulta.
Permanent

Categoria: UtilizadorAcessoNãoAutorizado

Mensagem de erro Descrição Permanente/Transitório
BadRequest_InvalidKustoIdentityToken Token de identidade Kusto inválido. Permanent
Proibido Permissões de segurança insuficientes para executar pedidos. Permanent

Categoria: Motor Acelerado

Mensagem de erro Descrição Permanente/Transitório
General_ThrottledIngestion Ingestão limitada. Transient

Categoria: RetentativaTentativas Ultrapassadas

Mensagem de erro Descrição Permanente/Transitório
General_RetryAttemptsExceeded A operação ultrapassou o limite de tentativas de retentativa ou o limite de tempo após um erro transitório recorrente. Permanent

Categoria: BlobJá Recebido

Mensagem de erro Descrição Permanente/Transitório
BlobAlreadyReceived_BlobAlreadyFoundInBatch Detetaram o mesmo blob no mesmo lote específico para ingestão. Neste caso, apenas uma cópia do blob será usada para ingestão. Muitos erros deste tipo podem indicar que a configuração de ingestão é subótima. Por exemplo, definir duas ligações de dados Event Grid no mesmo armazenamento. Permanent

Categoria: Desconhecida

Mensagem de erro Descrição Permanente/Transitório
Unknown Ocorreu um erro desconhecido. Transient