Configure BFD sobre ExpressRoute

O ExpressRoute suporta a Deteção bidirecional de encaminhamento (BFD) tanto sobre o estado privado como o espreitamento da Microsoft. Quando ativa a BFD através do ExpressRoute, pode acelerar a deteção de falhas de ligação entre os dispositivos Microsoft Enterprise Edge (MSEE) e os routers que o seu circuito ExpressRoute configura (CE/PE). Pode configurar o ExpressRoute através dos dispositivos de encaminhamento Edge ou dos dispositivos de encaminhamento Partner Edge (se optou pelo serviço de ligação da Camada 3 gerido). Este documento acompanha-o através da necessidade de BFD, e como ativar o BFD sobre o ExpressRoute.

Necessidade de BFD

O seguinte diagrama mostra o benefício de permitir o BFD sobre o circuito ExpressRoute: 1

Pode ativar o circuito ExpressRoute através das ligações da Camada 2 ou das ligações geridas da Camada 3. Em ambos os casos, se houver mais de um dispositivo Layer-2 na rota de ligação ExpressRoute, a responsabilidade de detetar quaisquer falhas de ligação no caminho reside na sessão de BGP sobressaída.

Nos dispositivos MSEE, o BGP mantém-se vivo e o tempo de espera são tipicamente configurados como 60 e 180 segundos, respectivamente. Por esta razão, quando acontece uma falha de ligação, pode levar até três minutos para detetar qualquer falha de ligação e mudar o tráfego para a ligação alternativa.

Pode controlar os temporizadores BGP configurando um BGP inferior mantendo-se vivo e tempo de espera no seu dispositivo de observação de borda. Se os temporizadores BGP não forem os mesmos entre os dois dispositivos de observação, a sessão de BGP estabelecerá utilizando o valor de tempo mais baixo. A continuação do BGP pode ser definida até três segundos e o tempo de espera tão baixo como 10 segundos. No entanto, a definição de um temporizador BGP muito agressivo não é recomendada porque o protocolo é intensivo em processos.

Neste cenário, o BFD pode ajudar. O BFD fornece uma deteção de falha de ligação de baixa sobrecarga num intervalo de tempo de subsegundo.

Nota

O BFD proporciona um tempo de insucesso mais rápido quando é detetada uma falha de ligação, mas a convergência global da ligação levará até um minuto para falhar entre os gateways de rede virtual ExpressRoute e os MSEEs.

Habilitação BFD

O BFD é configurado por padrão em todas as interfaces de observação privadas e Microsoft recém-criadas nos MSEEs. Como tal, para ativar o BFD, basta configurar o BFD nos seus dispositivos primários e secundários. Configurar o BFD é um processo em duas etapas. Configura o BFD na interface e, em seguida, ligue-o à sessão de BGP.

Uma configuração DE EXEMPLO CE/PE (utilizando Cisco IOS XE) é mostrada abaixo.

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Nota

Para ativar o BFD sob um olhar privado ou Microsoft já existente, terá de redefinir o espreitamento. Isto terá de ser feito em circuitos configurados com o peering privado antes de agosto de 2018 e a Microsoft a espreitar antes de janeiro de 2020. Ver reset ExpressRoute os seus pares

Negociação do Temporizador BFD

Entre os pares do BFD, o mais lento dos dois pares determina a taxa de transmissão. Os intervalos de transmissão/receção MSEEs são definidos em 300 milissegundos. Em certos cenários, o intervalo pode ser definido com um valor superior de 750 milissegundos. Ao configurar um valor mais elevado, pode forçar estes intervalos a serem mais longos, mas não é possível torná-los mais curtos.

Nota

Se tiver circuitos ExpressRoute Geo redundantes configurados ou utilizar a conectividade VPN IpSec local-a-local como cópia de segurança. Permitir o BFD ajudaria a falhar mais rapidamente após uma falha de conectividade ExpressRoute.

Passos Seguintes

Para mais informações ou ajuda, confira os seguintes links: