Resolução de problemas com o Balanceador de Carga do Azure
Este artigo fornece informações de solução de problemas para perguntas comuns sobre o Balanceador de Carga do Azure (camadas Básica e Padrão). Para obter mais informações sobre o Balanceador de Carga Standard, veja Descrição geral do Balanceador de Carga Standard.
Quando a conectividade de um balanceador de carga não está disponível, os sintomas mais comuns são:
- As máquinas virtuais (VMs) por trás do balanceador de carga não estão respondendo a testes de integridade.
- As VMs por trás do balanceador de carga não estão respondendo ao tráfego na porta configurada.
Quando os clientes externos para as VMs de back-end passam pelo balanceador de carga, o endereço IP dos clientes é usado para a comunicação. Verifique se o endereço IP dos clientes foi adicionado à lista de permissões do NSG (grupo de segurança de rede).
Problema: Nenhuma conectividade de saída de balanceadores de carga internos padrão
Validação e resolução
Os balanceadores de carga internos padrão (ILBs) têm recursos de segurança padrão. Os ILBs básicos permitem conectar-se à Internet através de um endereço IP público oculto chamado IP de acesso de saída padrão. Não recomendamos a conexão via IP de acesso de saída padrão para cargas de trabalho de produção, porque o endereço IP não é estático ou bloqueado por meio de grupos de segurança de rede de sua propriedade.
Se você mudou recentemente de um ILB Básico para um ILB Padrão e precisa de conectividade de saída para a Internet de suas VMs, você pode configurar o Gateway NAT do Azure em sua sub-rede. Recomendamos o NAT Gateway para todos os acessos de saída em cenários de produção.
Problema: Não há conectividade de entrada com balanceadores de carga externos padrão
Motivo
Os balanceadores de carga padrão e os endereços IP públicos padrão são fechados para conexões de entrada, a menos que os grupos de segurança de rede os abram. Você usa NSGs para permitir explicitamente o tráfego permitido. Você deve configurar seus NSGs para permitir explicitamente o tráfego permitido. Se você não tiver um NSG em uma sub-rede ou placa de interface de rede (NIC) do seu recurso de VM, o tráfego não terá permissão para alcançar o recurso.
Resolução
Para permitir o tráfego de entrada, adicione um grupo de segurança de rede à sub-rede ou interface do seu recurso virtual.
Problema: Não é possível alterar a porta de back-end para uma regra de balanceamento de carga existente de um balanceador de carga que tenha um conjunto de escala de máquina virtual implantado no pool de back-end
Motivo
Quando um balanceador de carga é configurado com um conjunto de dimensionamento de máquina virtual, você não pode modificar a porta de back-end de uma regra de balanceamento de carga enquanto ela estiver associada a uma investigação de integridade.
Resolução
Para alterar a porta, você pode remover a sonda de integridade. Atualize o conjunto de dimensionamento da máquina virtual, atualize a porta e configure a investigação de integridade novamente.
Problema: Pequeno tráfego ainda passando pelo balanceador de carga após a remoção de VMs do pool de back-end
Motivo
As VMs removidas do pool de back-end do balanceador de carga não devem mais receber tráfego. A pequena quantidade de tráfego de rede pode estar relacionada ao armazenamento, ao DNS (Sistema de Nomes de Domínio) e a outras funções no Azure.
Resolução
Para verificar, você pode realizar um rastreamento de rede. As propriedades de cada conta de armazenamento listam o FQDN (nome de domínio totalmente qualificado) para sua conta de armazenamento de blob. A partir de uma máquina virtual na sua subscrição do Azure, pode executar nslookup
para determinar o IP do Azure atribuído a essa conta de armazenamento.
Problema: Balanceador de carga em um estado de falha
Resolução
- Vá para o Gerenciador de Recursos do Azure e identifique o recurso que está em um estado de falha.
- Atualize a alternância no canto superior direito para Leitura/Gravação.
- Selecione Editar para o recurso em estado de falha.
- Selecione PUT seguido de GET para garantir que o estado de provisionamento foi alterado para Succeeded.
Em seguida, você pode prosseguir com outras ações, porque o recurso está fora de um estado de falha.
Capturas de rede para tíquetes de suporte
Se as resoluções anteriores não resolverem o problema, abra um tíquete de suporte.
Se você decidir abrir um tíquete de suporte, colete capturas de rede para uma resolução mais rápida. Escolha uma única VM de back-end para executar os seguintes testes:
- Use
ps ping
a partir de uma das VMs de back-end na rede virtual para testar a resposta da porta de teste (exemplo:ps ping 10.0.0.4:3389
) e registrar resultados. - Se você não receber uma resposta em testes de ping, execute um rastreamento Netsh simultâneo na VM de back-end e na VM de teste de rede virtual enquanto executa o PsPing. Em seguida, pare o rastreamento Netsh.