Partilhar via


Otimizar o desempenho com tarefas de limpeza automática

Aplica-se a estas aplicações do Dynamics 365:
Human Resources

Problema

O Microsoft Dynamics 365 Human Resources pode apresentar problemas de desempenho se o histórico de tarefas de lote crescer demasiado.

Causa

As tarefas de lote que são executadas com frequência geralmente podem levar ao crescimento insustentável do histórico de tarefas de lote. Isto pode causar problemas de desempenho.

Resolução

Agende uma tarefa automática para limpar o histórico de tarefas de lote. Recomendamos configurar a tarefa para ser executada semanalmente, mas pode ser necessário executar a limpeza com mais ou menos frequência, dependendo do seu ambiente. O procedimento a seguir contém as nossas definições recomendadas, mas pode modificá-las de acordo com as suas necessidades.

  1. No Human Resources, selecione Administração do sistema.

  2. Na barra Pesquisa, introduza Limpeza do histórico de tarefas de lote.

    Pesquisar limpeza do histórico de tarefas de lote.

  3. No Limite de histórico (dias), introduza 30.

    Defina o limite de histórico como 30.

  4. Selecione Executar em segundo plano e Periodicidade.

    Definir a periodicidade.

  5. Em Definir a periodicidade, defina a Data de início e a Hora de início para ocorrer fora do horário comercial ou no fim de semana e selecione NENHUMA DATA DE FIM.

    Definir a data e a hora de início da periodicidade.

  6. Em PADRÃO DE PERIODICIDADE, selecione Dias e defina REPETIR APÓS O INTERVALO ESPECIFICADO como 7.

    Definir limpeza para ser repetida semanalmente.

  7. Selecione OK.

  8. Altere quaisquer outros parâmetros em Executar em segundo plano conforme necessário e selecione OK.