Partilhar via


São apresentadas duas contas do OneDrive ao carregar anexos a partir de Outlook na Web

Sintomas

Quando tenta carregar anexos a partir de Outlook na Web, o menu Carregar apresenta duas contas do OneDrive em vez de uma.

Captura de ecrã de duas contas do OneDrive no menu Carregar.

Causa

Este problema ocorre se estiver num ambiente híbrido do Exchange que tenha uma caixa de correio no Microsoft Exchange Server no local e uma conta OneDrive para Empresas no Microsoft 365 e se a conta do OneDrive tiver sido movida para uma localização geográfica diferente. Após a movimentação do OneDrive, os URLs internos e externos do Anfitrião de O Meu Site não são atualizados na OwaMailboxPolicy definição.

Resolução

Para corrigir este problema, utilize um dos seguintes métodos.

Método 1: Atualizar OS URLs do Anfitrião de O Meu Site

Execute o seguinte cmdlet para atualizar os URLs internos e externos do Anfitrião de O Meu Site na OwaMailboxPolicy definição para os valores da nova localização geográfica do OneDrive:

Set-OwaMailboxPolicy Default -InternalSPMySiteHostURL <new_OneDrive_URL> -ExternalSPMySiteHostURL <new_OneDrive_URL>

Método 2: Definir valores como Null

Execute o seguinte cmdlet para definir os URLs internos e externos do Anfitrião de O Meu Site na OwaMailboxPolicy definição como Null:

Set-OwaMailboxPolicy Default -InternalSPMySiteHostURL $Null -ExternalSPMySiteHostURL $Null

Depois de atualizar a OwaMailboxPolicy definição com um dos métodos, crie um novo perfil do Outlook para utilizar os valores atualizados. Isto é necessário porque as definições anteriores OwaMailboxPolicy são colocadas em cache no seu perfil atual do Outlook e não podem ser atualizadas.

Para obter mais informações sobre a OwaMailboxPolicy definição, consulte Configurar a colaboração em documentos com o OneDrive para Empresas e o Exchange 2016 no local.