Nota
O acesso a esta página requer autorização. Pode tentar iniciar sessão ou alterar os diretórios.
O acesso a esta página requer autorização. Pode tentar alterar os diretórios.
Sintomas
Suponha que você esteja usando o Microsoft Outlook 2016 ou uma versão posterior e que lhe tenha sido delegada permissão para enviar mensagens de email como outro usuário ou em nome de outro usuário de uma caixa de correio compartilhada. No entanto, quando você envia uma mensagem como outro usuário ou em nome do usuário, a mensagem enviada não é salva na pasta Itens Enviados da caixa de correio compartilhada. Em vez disso, ele é salvo na pasta Itens Enviados da sua caixa de correio.
Motivo
No Microsoft 365, as caixas de correio compartilhadas não exigem uma licença e não podem ser adicionadas ao Outlook como caixas de correio independentes. Não é possível iniciar sessão numa caixa de correio partilhada. Em vez disso, inicie sessão na sua própria caixa de correio e, em seguida, abra a caixa de correio partilhada. Quando você envia ou responde a uma nova mensagem da caixa de correio compartilhada, o Outlook envia ou responde automaticamente da conta do remetente. Portanto, as mensagens são armazenadas na pasta Itens enviados da caixa de correio do remetente.
Solução
Para contornar esse problema, use um dos seguintes métodos.
Nota: Se estiver a utilizar o novo Outlook, apenas o Método 1 será aplicado.
Método 1
Configure a caixa de correio para salvar uma cópia da mensagem na pasta Itens Enviados da caixa de correio compartilhada no Exchange Online ou no Exchange Server local.
Para emails enviados como a caixa de correio compartilhada, execute o seguinte comando no Exchange PowerShell:
set-mailbox <mailbox name> -MessageCopyForSentAsEnabled $True
Para emails enviados em nome da caixa de correio compartilhada, execute o seguinte comando no Exchange PowerShell:
set-mailbox <mailbox name> -MessageCopyForSendOnBehalfEnabled $True
Método 2
Importante
Esta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, problemas sérios podem ocorrer se você modificar o registro incorretamente. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para proteção, faça backup do registro antes de modificá-lo para que você possa restaurá-lo se ocorrer um problema. Para mais informações sobre como fazer uma cópia de segurança e restaurar o registo, consulte Como fazer uma cópia de segurança e restaurar o registo no Windows.
Defina o valor do registo DelegateSentItemsStyle no cliente Outlook.
Observação
Para que essa opção funcione corretamente, o Outlook deve ser configurado para ser executado no modo Cache do Exchange. Para obter mais informações, consulte O email permanece na caixa de saída quando você usa o valor do Registro DelegateSentItemsStyle.
Utilize os passos seguintes:
Inicie o Editor do Registro.
Localize e, em seguida, clique na seguinte subchave do registo:
HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Preferences
No menu Editar , aponte para Novo e clique em Valor DWORD de 32 bits.
Digite DelegateSentItemsStyle e pressione Enter.
Clique com o botão direito do mouse em DelegateSentItemsStyle e clique em Modificar.
Na caixa dados do valor , digite 1 e, em seguida, clique em OK .
Saia do Editor do Registro.
Mais informações
A tabela a seguir lista o comportamento esperado com base em diferentes combinações da DelegateSentItemsStyle
configuração do valor do Registro e do valor do parâmetro MessageCopyForSentAsEnabled
da caixa de correio.
DelegateSentItemsStyle | MensagemCópiaParaEnvioComoAtivado | Comportamento esperado |
---|---|---|
0 | Verdade | Uma cópia do e-mail será salva na caixa de correio principal e na caixa de correio compartilhada. |
1 | Verdade | Duas cópias do email serão salvas na caixa de correio compartilhada e nenhuma cópia na caixa de correio principal. |
0 | Falso | Uma cópia do email será salva na caixa de correio principal e nenhuma cópia na caixa de correio compartilhada. |
1 | Falso | Uma cópia do email será salva na caixa de correio compartilhada e nenhuma cópia na caixa de correio principal. |
Ainda precisa de ajuda? Vá para a Comunidade Microsoft ou para os fóruns do Exchange TechNet.