Erro "Não é possível localizar a tabela de entrada ou a consulta" ou "a origem do registro não existe" ao usar o Access

Número de KB original: 287696

Observação

Requer habilidades básicas de macro, codificação e interoperabilidade. Este artigo se aplica somente a um banco de dados do Microsoft Access (.accdb e .mdb).

Sintomas

Ao abrir ou fazer uma referência a uma tabela vinculada no Microsoft Access, você poderá receber uma das seguintes mensagens de erro:

  • O Microsoft Office Access não consegue localizar o objeto '<name>'.

  • Erro em tempo de execução '7874': o Microsoft Office Access não consegue localizar o objeto '<name>'.

Motivo

Você poderá receber essa mensagem de erro se o Access não encontrar a tabela ou a consulta no banco de dados, se um link apontar para um arquivo externo que não existe ou se o arquivo externo tiver sido movido para um novo local. Esse erro também pode ocorrer se uma tabela ou consulta excluída ou renomeada for referenciada na guia Pesquisa de outra tabela.

Resolução

Para solucionar esse comportamento, faça o seguinte:

  • Verifique se a tabela ou consulta existe. Se ela não existir, você poderá remover todas as referências a ela ou se for uma tabela ausente, reimportar ou revincular a tabela. Se for uma consulta ausente, reimporte ou crie novamente a consulta. Geralmente, a RecordSource propriedade de um formulário ou relatório contém uma referência a uma tabela ou uma consulta cujo nome foi alterado ou que foi excluído.
  • Se a tabela ou consulta existir, é provável que haja um erro de sintaxe ou um erro de ortografia na referência a ela. Nesse caso, corrija o erro de sintaxe ou o erro de ortografia na referência.
  • Quando você tenta abrir uma tabela vinculada, a tabela de origem pode não estar no caminho que você especificou quando ela foi vinculada pela primeira vez. Se você tiver movido o arquivo, poderá usar o Gerenciador de Tabelas Vinculado para atualizar as informações do link.