Partilhar via


O Outlook 2010, 2013, 2016 ou Outlook para Microsoft 365 não liga o Exchange através de MAPI através de HTTP conforme esperado

Número original da BDC: 2937684

Sintomas

Considere o seguinte exemplo:

  • Está a utilizar o Microsoft Outlook 2010, o Outlook 2013 Service Pack 1 (SP1) ou uma versão posterior.
  • Está ligado a uma caixa de correio do Microsoft Exchange Server 2013 SP1 ou Exchange Server 2016.
  • Os servidores da caixa de correio do Exchange e do Acesso de Cliente (CAS) aos quais está a ligar têm Exchange Server 2013 SP1 ou uma versão posterior instalada ou Exchange Server 2016.
  • As definições de servidor necessárias para estabelecer ligações MapiHttp estão configuradas corretamente.

No cenário acima, a coluna Protocolo na caixa de diálogo Estado da Ligação do Outlook mostra que o Outlook 2013 está ligado ao servidor Exchange através de um mecanismo de ligação diferente de MAPI/HTTP. Por exemplo, a figura seguinte mostra uma ligação com RPC/HTTP.

Captura de ecrã a mostrar a caixa de diálogo Estado da ligação do Outlook, que mostra a coluna Protocolo como RPC/HTTP.

Nota

As ligações MAPI/HTTP são designadas na coluna Protocolo com a cadeia HTTP.

Além disso, se MAPI/HTTP estiver desativado, os utilizadores do Microsoft 365 receberão um pedido de Autenticação Básica em vez de um pedido de Autenticação Moderna.

Causa

Este problema pode ocorrer se a funcionalidade MapiHttp estiver desativada no cliente do Outlook com o seguinte valor de registo:

Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange
DWORD: MapiHttpDisabled
Value: 1

Resolução

Para resolver este problema, altere o valor de MapiHttpDisabled para 0 (zero) ou elimine o valor DWORD MapiHttpDisabled . Estes dados de registo destinam-se apenas a fins de teste.

  1. Saia do Outlook.

  2. Abra o Registry Revisor através de um dos seguintes procedimentos, conforme adequado para a sua versão do Windows:

    • Windows 10, Windows 8.1 e Windows 8: prima a tecla do logótipo do Windows + R para abrir a caixa de diálogo Executar. Introduza regedit.exe e, em seguida, clique em OK.
    • Windows 7: clique em Iniciar, escrevaregedit.exe na caixa de pesquisa e, em seguida, prima Enter.
  3. Localize e selecione a seguinte chave no registo:

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. Clique com o botão direito do rato em MapiHttpDisabled e, em seguida, clique em Modificar.

  5. Altere os Dados do valor para 0 e, em seguida, clique em OK.

  6. Feche a Revisor de Registo.

  7. Inicie o Outlook.

Mais informações

Para obter mais informações sobre os requisitos de MAPI através de ligações HTTP, consulte MAPI através de HTTP.