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Corrigir incompatibilidade de ID de usuário do site no SharePoint ou no OneDrive

Sintomas

Quando os usuários em sua organização tentam acessar um site do OneDrive ou do SharePoint usando uma nova conta que compartilha um nome de usuário com uma conta anterior, os usuários enfrentam um ou mais dos seguintes problemas:

  • Uma mensagem de erro "Acesso negado"
  • Uma experiência de usuário inconsistente
  • Um novo site do OneDrive que tenha um sufixo anexado à URL esperada, como https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1 (o sufixo pode ser um número ou um GUID)

Motivo

Esses problemas geralmente ocorrem se uma conta de usuário é excluída do centro de administração do Microsoft 365 e, em seguida, uma nova conta é criada usando o nome principal do usuário (UPN) que foi usado pela conta excluída. É atribuído um novo valor de ID à nova conta, mesmo que o UPN seja o mesmo. No entanto, a lista UserInfo para os sites do SharePoint e do OneDrive associada à conta tem apenas a ID antiga. Quando os usuários tentam acessar um site do SharePoint ou seu site do OneDrive usando sua nova conta, sua nova ID não corresponde à ID que está na lista UserInfo. Portanto, o acesso ao site é negado.

Esses problemas também podem ocorrer durante a sincronização de diretórios entre uma unidade organizacional (UO) do Ative Directory e o SharePoint. Se os usuários já tiverem feito logon no SharePoint e forem movidos posteriormente para uma UO diferente, eles poderão enfrentar esses problemas quando a UO for sincronizada com o SharePoint.

Resolução

Para corrigir esses problemas, execute o diagnóstico de incompatibilidade de usuário do site usando uma conta de administrador do SharePoint.

Nota

  • Este diagnóstico não está disponível para os ambientes GCC High ou DoD, ou para o Microsoft 365 operado pela 21Vianet.
  • Antes de executar o diagnóstico para corrigir os problemas dos sites do OneDrive, os administradores devem certificar-se de que o Nome de Utilizador da nova conta de utilizador corresponde à conta antiga. Os administradores estão proibidos de ligar sites do OneDrive que possam pertencer anteriormente a outra conta de utilizador. 
  • Se o diagnóstico tiver resolvido com êxito um problema relacionado a um site do OneDrive, as alterações podem levar aproximadamente 24 horas para ocorrer. Este período inclui a atualização do mosaico do OneDrive para apontar para o site correto e a reciclagem de quaisquer sites adicionais do OneDrive.

Selecione o seguinte botão Executar testes para preencher o diagnóstico no centro de administração do Microsoft 365. O diagnóstico executa uma grande variedade de validações para usuários internos e convidados que tentam acessar sites do SharePoint e do OneDrive.

Quando lhe for pedido, forneça as seguintes informações:

  • A conta de usuário afetada, como UserA@contoso.com
  • O URL original do site, como https://contoso-my.sharepoint.com/personal/UserA_Contoso_com

Para obter o URL original do site do OneDrive, siga estes passos:

  1. Entre no site do OneDrive usando uma conta de administrador.
  2. Selecione o ícone Configurações (engrenagem) no canto superior direito.
  3. Selecione Definições do OneDrive e, em seguida, selecione Mais Definições.
  4. Na seção Informações de Diagnóstico, copie a URL da Web do OneDrive.

Para recuperar várias URLs do OneDrive, use um dos métodos em Exibir URLs do OneDrive para usuários em sua organização.

Cenários comuns

O diagnóstico de Incompatibilidade de Usuário do Site pode corrigir os seguintes problemas comuns que podem ocorrer quando uma nova conta é criada usando o UPN que foi usado por uma conta excluída.

Um usuário é direcionado para um novo site do OneDrive que tem um sufixo anexado à URL esperada

Quando uma nova conta de usuário é criada, um novo site do OneDrive é atribuído a ela. Quando uma conta de usuário é excluída, o site do OneDrive atribuído à conta não é excluído imediatamente. Portanto, se uma nova conta de usuário for criada usando o UPN de uma conta excluída, o novo site do OneDrive atribuído à nova conta terá a mesma URL do site antigo do OneDrive, juntamente com um sufixo adicionado. Este sufixo é um número ou um GUID.

Se você quiser que a nova conta de usuário use o mesmo site do OneDrive que foi atribuído à conta antiga, o diagnóstico verificará se o usuário pode receber a propriedade do site original. Depois de verificar com êxito as permissões do usuário, o diagnóstico oferecerá para reconectar o usuário ao site original e reciclar o novo site ativo que tem o sufixo, como https://contoso-my.sharepoint.com/personal/UserA_Contoso_com1.

Se tiver de aceder ao conteúdo no novo site do OneDrive mais tarde, pode restaurar o OneDrive eliminado.

Acesso negado a um site do OneDrive

Se for negado a um usuário o acesso ao seu site antigo do OneDrive depois que uma nova conta for criada para ele, o diagnóstico reconfigurará o perfil do usuário. Em seguida, ele reconectará o usuário ao site antigo do OneDrive para corrigir o problema de acesso.

Nota

Os administradores não podem corrigir esse problema atualizando manualmente os proprietários do site do OneDrive ou editando as propriedades do perfil de usuário associadas ao site do OneDrive. O diagnóstico é a única solução recomendada para corrigir esse problema.

Incompatibilidade de ID de usuário em sites do SharePoint ou sites do OneDrive que não pertencem ao usuário

Quando o diagnóstico detetar uma incompatibilidade de ID de usuário na lista UserInfo, ele oferecerá para remover a ID antiga. Depois de aceitar a oferta e a ID antiga for removida, atribua à nova conta de usuário as permissões apropriadas para o site do SharePoint.

Nota: Se pretender corrigir este problema manualmente, tem de remover a conta de utilizador antiga da lista UserInfo e, em seguida, conceder permissões à nova conta de utilizador.

Mais informações

Para obter mais informações sobre problemas de acesso no SharePoint e no OneDrive, consulte Erros de "Acesso negado" ou "Você precisa de permissão" no SharePoint Online e no OneDrive.