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Sintomas
Depois de definir uma fila de chamadas do Microsoft 365 no centro de administração do Skype para Empresas e adicionar um grupo de distribuição, os agentes ou utilizadores não são chamados. Além disso, quando alterar a fila de chamadas, poderá receber a seguinte mensagem de aviso:
Aviso: está a operar numa topologia de domínio dividido (híbrido).
Atualmente, esta aplicação só é suportada para inquilinos online puros.
Pode prosseguir com a configuração por sua conta e risco.
Causa
Este problema ocorre porque o seu inquilino está configurado através de um domínio dividido que não é atualmente suportado para o Assistente Automático Organizacional (OrgAA) ou filas de chamadas.
No entanto, se seguir a documentação de orientação na secção "Solução", a fila de chamadas poderá funcionar se todos os utilizadores definidos como agentes estiverem a trabalhar no Microsoft 365 e estiverem devidamente licenciados.
Solução
Para contornar este problema, siga estes passos:
Certifique-se de que a implementação no local para Skype para Empresas e o Microsoft 365 está configurada corretamente para voz híbrida.
Ative o servidor Edge para aceitar chamadas encaminhadas a partir de sipfed.resources.lync.com (parte de uma configuração híbrida típica).
Configure um novo fornecedor de alojamento na configuração no local que permita a comunicação com os serviços do Azure que funcionam como parte da Infraestrutura de fila de chamadas e OrgAA. Para tal, execute o seguinte cmdlet no PowerShell Remoto:
New-CSHostingProvider -Identity SFBOnlineResources -ProxyFqdn "sipfed.resources.lync.com" -Enabled $true -EnabledSharedAddressSpace $true -HostsOCSUsers $true -VerificationLevel AlwaysVerifiable -IsLocal $false
Certifique-se de que o domínio especificado para a fila de chamadas é o domínio sip dos agentes. Além disso, certifique-se de que todos os agentes na fila estão no mesmo domínio sip. Não especifique "contoso.mail.onmicrosoft.com" ou "onmicrosoft.com". Se o domínio tiver sido selecionado incorretamente quando criou a fila de chamadas, tem de recriar a fila de chamadas ou OrgAA utilizando o domínio correto.
Mais Informações
Para verificar que agentes estão disponíveis para receber chamadas entre os agentes que estão definidos na lista de distribuição de uma fila de chamadas, execute o seguinte cmdlet no PowerShell Remoto:
Get-CsHuntGroup
Se os agentes não estiverem listados, siga estes passos:
Verifique se os agentes estão licenciados para Skype para Empresas e Cloud PBX.
Verifique se os agentes estão Voz para Empresas ativados. Se lhe for atribuída uma licença de Chamadas RTPC, já estarão Voz para Empresas ativadas. Se tiverem apenas uma licença Cloud PBX, tem de ativá-las manualmente para Voz para Empresas. Para determinar se é necessário ativar o utilizador para Voz para Empresas, execute o seguinte script a partir do PowerShell Remoto:
Get-CsOnlineUser -Identity <UPN or SIP Address> | Select SipAddress, EnterpriseVoiceEnable, HostedVoiceMail Set-CsUser -Identity <UPN or SIP Address> -EnterpriseVoiceEnable $True -HostedVoiceMail $True
Para obter mais informações, veja os seguintes tópicos do TechNet: