Nota
O acesso a esta página requer autorização. Pode tentar iniciar sessão ou alterar os diretórios.
O acesso a esta página requer autorização. Pode tentar alterar os diretórios.
Este artigo discute como identificar e resolver o AksCapacityHeavyUsage
erro que pode ocorrer quando você cria um cluster do AKS (Serviço de Kubernetes do Microsoft Azure).
Sintomas
Ao tentar criar um cluster do AKS, você recebe a seguinte mensagem de erro:
Código: AksCapacityHeavyUsage
Mensagem: O AKS está enfrentando um uso intenso na região <Região>. Estamos trabalhando na adição de novas capacidades. Enquanto isso, considere a criação de novos clusters do AKS em uma região diferente. Para obter uma lista de todas as regiões do Azure, visite https://aka.ms/aks/regions. Para obter mais detalhes sobre esse erro, visite https://aka.ms/akscapacityheavyusage.
Motivo
Você está tentando criar um cluster em uma região com capacidade limitada.
Quando você cria um cluster do AKS, o Microsoft Azure aloca recursos de computação para sua assinatura. Ocasionalmente, você pode experimentar o erro devido ao AksCapacityHeavyUsage
crescimento significativo da demanda pelo Serviço de Kubernetes do Azure em regiões específicas.
Resolução
Solução 1: Selecionar uma região diferente
A solução mais fácil e rápida é tentar implantar em uma região diferente (por exemplo, NorthEurope em vez de WestEurope ou UAENorth em vez de QatarCentral). Para encontrar regiões próximas, visite a página Geografias do Azure.
Essa abordagem pode não ser viável se você já tiver recursos existentes na região solicitada, mas é a solução preferencial em um cenário de desenvolvimento/teste.
Solução 2: implantar um cluster que tenha configurações diferentes
A infraestrutura que hospeda clusters gerenciados pelo AKS tem reservas de alocação diferentes. Portanto, o AKS pode ter mais capacidade para clusters públicos do que para clusters privados. Se você experimentar o AksCapacityHeavyUsage
erro ao tentar criar um cluster privado, tente criar um cluster público em vez disso (ou vice-versa).
Solução 3: usar uma assinatura do Azure Enterprise
Quando a capacidade está baixa, as assinaturas que não são do Contrato Enterprise Agreement (EA) são as primeiras a serem limitadas na criação de clusters do AKS para reservar recursos para cenários reais de produção. Se você tiver uma assinatura do EA, certifique-se de usá-la para criar o cluster do AKS.
Solução 4: repetir a operação
A capacidade geralmente é recuperada quando outros usuários param ou excluem seus clusters do AKS. Portanto, a operação poderá ser bem-sucedida se você tentar novamente mais tarde.
Mais informações
Garantir a capacidade dos usuários é uma prioridade máxima para a Microsoft e estamos trabalhando para escalar verticalmente nossa infraestrutura para acomodar a crescente popularidade dos serviços do Azure.
Para obter mais informações sobre melhorias que estamos fazendo para fornecer uma cadeia de fornecimento de nuvem resiliente, consulte este artigo do Blog do Azure de setembro de 2021.
Entre em contato conosco para obter ajuda
Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.