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Solucionar o erro de cota OperationNotAllowed ou PublicIPCountLimitReached

Este artigo descreve como identificar e resolver o erro de cota OperationNotAllowed or PublicIPCountLimitReached que ocorre quando você tenta criar e implantar um cluster do AKS (Serviço de Kubernetes do Microsoft Azure).

Sintomas

Ao tentar criar um cluster do AKS, você recebe a seguinte mensagem de erro:

Code="OperationNotAllowed"

Message="A operação não pôde ser concluída, pois resulta em exceder a cota aprovada de núcleos da família StandardEv3."

Detalhes adicionais - Modelo de implantação: Gerenciador de Recursos

Localização: "uksouth"

Limite atual: 200,

Uso atual: 200,

Adicional necessário: 8,

(Mínimo) Novo limite necessário: 208.

Envie uma solicitação de aumento de cota em https://aka.ms/ProdportalCRP/#blade/Microsoft_Azure_Capacity/UsageAndQuota.ReactView/Parameters/<parameter-id> especificando os parâmetros listados na seção "Detalhes" para que a implantação seja bem-sucedida. Leia mais sobre os limites de cota em https://learn.microsoft.com/azure/azure-supportability/per-vm-quota-requests"

Ou você recebe a seguinte mensagem de erro:

Falhou a reconciliação do balanceador de carga padrão.

Detalhes: falha na nova tentativa de outboundReconciler: Categoria: ClientError; Subcódigo: PublicIPCountLimitReached;

Dependência: Microsoft.Network/PublicIPAddresses;

ErroOriginal: Code="PublicIPCountLimitReached"

Message="Não é possível criar mais de 1000 endereços IP públicos para esta assinatura nesta região." Detalhes=[]; AKSTeam: Rede, Recuperável: false.

Motivo

Você esgotou a cota de um recurso na região de um SKU.

Solução 1: Solicite um aumento de cota para seu SKU

Normalmente, essas mensagens de erro fornecem um link para criar um bilhete de suporte para aumentar a cota desse SKU. Na maioria dos casos, essas solicitações são aprovadas automaticamente e a cota aumentada estará disponível em pouco tempo.

Se você não tiver o link para solicitar um aumento de cota, faça a solicitação no portal do Azure, da seguinte maneira:

  1. No portal Azure, pesquise e selecione Cotas.

  2. Selecione Microsoft.Compute para exibir a lista de registros de cota.

  3. Use a lista Local para filtrar registros apenas da sua região.

  4. No registro específico que está fora da cota, selecione o ícone de lápis no final da linha do registro.

  5. No painel Solicitar aumento de cota, preencha o campo Novo limite e selecione Enviar.

Depois que sua solicitação de aumento de cota for aprovada, você poderá repetir a operação de criação do cluster.

Solução 2: realocar o cluster para outra região ou SKU

Como alternativa, você pode reprovisionar o cluster em uma região ou SKU diferente que tenha capacidade suficiente para o cluster.

Mais informações

Entre em contato conosco para obter ajuda

Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.