Nota
O acesso a esta página requer autorização. Pode tentar iniciar sessão ou alterar os diretórios.
O acesso a esta página requer autorização. Pode tentar alterar os diretórios.
Este artigo discute como identificar e resolver o erro AKSOperationPreempted
ou AKSOperationPreemptedByDelete
que pode ocorrer quando você tenta executar uma nova operação, mas ela foi preemptada por outra operação em um cluster do Serviço de Kubernetes do Azure Microsoft (AKS).
Sintomas
Ao tentar executar uma nova operação em um cluster do AKS, você recebe uma das seguintes mensagens de erro:
-
Código: "AKSOperationPreempted"
Mensagem: "Esta operação foi antecipada por outra operação com ID <de operação ID>"
Essa mensagem indica que a operação foi antecipada por outra operação e o GUID da nova operação é fornecido na mensagem de erro.
-
Código: "AKSOperationPreemptedByDelete"
Mensagem: "Esta operação foi interrompida pela operação de exclusão."
Essa mensagem indica que a operação foi antecipada por uma operação de exclusão.
Motivo
Esse erro geralmente ocorre quando uma operação em andamento é interrompida por uma operação subsequente que foi emitida antes da conclusão da operação em andamento. O erro indicará a operação subsequente, que pode ser uma exclusão ou qualquer outra operação.
Solução
Para resolver esse problema, use um dos seguintes métodos. Quando não houver operações em execução, você poderá tentar executar sua operação novamente.
Aguarde a conclusão da operação anterior.
Você pode verificar o status da operação usando o ID fornecido na mensagem de erro com o seguinte comando:
az aks operation show \ --resource-group myResourceGroup \ --name myCluster \ --operation-id "<operation-id>"
Execute um
abort
comando para interromper a operação anterior.Para obter mais informações sobre como anular uma operação, consulte Encerrar uma operação de execução longa em um cluster do AKS (Serviço de Kubernetes do Azure).
Mais informações
Solução de problemas gerais de criação de cluster do AKS
Entre em contato conosco para obter ajuda
Se você tiver dúvidas ou precisar de ajuda, crie uma solicitação de suporte ou peça ajuda à comunidade de suporte do Azure. Você também pode enviar comentários sobre o produto para a comunidade de comentários do Azure.