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Solucionar problemas do código de erro "PublicIPCountLimitReached"

Este artigo discute como identificar e resolve o erro "PublicIPCountLimitReached" que ocorre quando você tenta atualizar um cluster do AKS (Serviço de Kubernetes do Azure).

Pré-requisitos

Este artigo requer a CLI do Azure versão 2.0.65 ou uma versão posterior. Para localizar o número da versão, execute az --version. Se você precisar instalar ou atualizar a CLI do Azure, consulte Como instalar a CLI do Azure.

Para obter informações mais detalhadas sobre o processo de atualização, consulte a seção "Atualizar um cluster AKS" no cluster do AKS (Atualizar um Serviço de Kubernetes do Azure).

Sintomas

Uma atualização de cluster do AKS falha e você recebe uma mensagem de erro "PublicIPCountLimitReached".

Motivo

O erro ocorrerá se você atingiu o número máximo de endereços IP públicos permitidos para sua assinatura.

Solução

Para aumentar o limite ou cota para sua assinatura, acesse o portal do Azure, arquive um tíquete de suporte de Serviço e de assinatura (cotas) e defina o tipo de cota como Rede.

Depois que a alteração de cota entrar em vigor, tente atualizar o cluster para a mesma versão para a qual você tentou atualizar anteriormente. Esse processo desencadeará uma reconciliação.

az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>

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