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Erro "Não é possível se conectar a Banco de Dados SQL, ErrorCode=SqlFailedToConnect" na migração de nuvem do Business Central

Este artigo resolve a mensagem de erro "Não é possível se conectar a Banco de Dados SQL, ErrorCode=SqlFailedToConnect" que ocorre quando você tenta se conectar a um banco de dados SQL na migração de nuvem do Business Central.

Sintomas

Ao tentar se conectar a um banco de dados SQL na migração de nuvem do Business Central, você recebe a seguinte mensagem de erro:

Não é possível se conectar a Banco de Dados SQL, ErrorCode=SqlFailedToConnect.

Essa mensagem de erro geralmente ocorre junto com a seguinte mensagem de erro:

Verifique se a configuração do serviço vinculado está correta e verifique se o firewall Banco de Dados SQL permite que o runtime de integração acesse.

Motivo

Pode haver vários motivos para a mensagem de erro. O motivo mais comum é retornado dentro da mensagem de erro longa, por exemplo:

  • Problemas com a conta de usuário:

    Falha no logon do usuário...

    A senha da conta deve ser alterada.

    A conta está desabilitada.

  • O SQL Server não está em execução ou o acesso remoto ao SQL Server está desabilitado:

    O servidor não foi encontrado ou não estava acessível. Verifique se o nome da instância está correto e se SQL Server está configurado para permitir conexões remotas.

Solução

Para resolver esse problema, execute o seguinte comando Windows PowerShell no host Integration Runtime. Se o host Integration Runtime não puder se conectar, ele retornará um erro descritivo.

sqlcmd –S "{SQL Server Name}" -d "{Database Name}" -U "{SQL Server Authenticated User Name}" -P "{PlaceholderSQLServerAuthenticatedPassword}" -Q 'select * from [dbo].[Intelligent Cloud]'

Para permitir que o endereço IP do cliente Integration Runtime acesse o SQL Server, execute o seguinte comando no banco de dados master local:

sp_set_firewall_rule

Para permitir o acesso remoto ao SQL Server, execute o seguinte comando:

run sp_configure 'remote access', 1;