Partilhar via


O erro "o nome a seguir já existe" ocorre durante as exportações

Observação

Em 1º de setembro de 2023, mesclamos e renomeamos Dynamics 365 Marketing e Dynamics 365 Customer Insights. Dynamics 365 Marketing agora é chamado de Dynamics 365 Customer Insights - Journeys. Dynamics 365 Customer Insights agora é chamado de Dynamics 365 Customer Insights - Data. Para obter mais informações, consulte perguntas frequentes Dynamics 365 Customer Insights.

Se uma exportação tentar criar um novo segmento no destino de exportação, mas já houver um segmento com esse nome, examine todas as exportações para esse destino para segmentos que são exportados várias vezes.

Pré-requisitos

  • Permissões de administrador em permissões de Dynamics 365 Customer Insights - Data ou colaborador com a capacidade de compartilhar o acesso à conexão usada para essa exportação
  • O nome mencionado na mensagem de erro

Sintomas

Uma execução de exportação específica falha e você recebe a mensagem de erro "o nome a seguir já existe" seguida pelo nome da tabela de saída de um segmento específico.

Motivo

Se essa mensagem de erro ocorrer repetidamente entre atualizações do sistema, é provável que suas exportações sejam configuradas para exportar o mesmo segmento várias vezes para o mesmo destino, o que, em casos raros, pode causar essa mensagem de erro.

Resolução

Para resolve esse problema,

  1. Observe o nome mencionado na mensagem de erro.
  2. Examine a lista de segmentos exportados para todas as exportações para o destino de exportação que mostra a mensagem de erro.
  3. Se você encontrar o mesmo segmento selecionado em exportações diferentes, altere as exportações para que cada segmento seja exportado apenas uma vez.
  4. Salve as alterações nas exportações.
  5. Na próxima vez que todas as exportações forem executadas, confirme se o erro não ocorre.