Share via


Excluir itens SLAs ou SLA mostra um erro na Interface Unificada durante uma atualização da solução ou exclusão manual

Este artigo fornece uma resolução para o problema em que a exclusão de SLAs (contratos de nível de serviço) ou itens SLA mostra uma mensagem de erro na Interface Unificada durante uma atualização de solução ou exclusão manual.

Sintomas

Quando você tenta excluir itens SLAs ou SLA durante uma atualização de solução ou exclusão manual, ocorre uma das seguintes mensagens de erro:

O objeto que você tentou excluir está associado a outro objeto e não pode ser excluído.

A operação de exclusão do SLAItem encontrou alguns erros. O processo faz parte de uma solução gerenciada e não pode ser excluído individualmente. Desinstale a solução pai para remover o processo. Consulte log para obter mais detalhes.

Motivo

A primeira mensagem de erro ocorre porque, no SLA da Interface Unificada, a relação entre o item SLA e as instâncias do SLA KPI é definida como "Restringir à Exclusão". A segunda mensagem de erro ocorre porque processos que fazem parte de uma solução gerenciada não podem ser excluídos. Se você tentar excluir manualmente um SLA que faz parte de uma solução gerenciada e tiver fluxos configurados, a mensagem de erro será exibida.

Solução 1

Em vez de excluir o SLA, desative o SLA em sua organização. Se ele faz parte de uma solução gerenciada, siga as seguintes etapas:

  1. Desativar o SLA na instância de origem e adicioná-lo à solução.
  2. Desativar o mesmo SLA na instância de destino e, em seguida, aplicar a atualização da solução.

Solução 2

Primeiro, você pode excluir manualmente todos os registros de entidade relacionados ao SLA e instâncias de KPI SLA e remover o SLA. Estas são as etapas:

  1. Em sua organização, acesse Localização Avançada, pesquise instâncias de KPI SLA e selecione SLAItem.
  2. Selecione Resultado. As instâncias de KPI do SLA serão listadas.
  3. Selecione as instâncias de KPI do SLA necessárias e selecione Excluir SLAKPIInstances. Isso também anulará as instâncias de KPI do SLA nos registros relacionados.

Mesmo depois de excluir os registros de referência, se a mensagem de erro "Operação de exclusão SLAItem encontrou alguns erros. O processo faz parte de uma solução gerenciada e não pode ser excluído individualmente. Desinstale a solução pai para remover o processo. Consulte log para obter mais detalhes" mostra e aplique a atualização da solução com o SLA excluído da solução de atualização.

Resolução 3

Se a resolução acima não funcionar, entre em contato com Suporte da Microsoft para solicitar a exclusão dos itens SLA ou SLA.